Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Turn off alert after opening mail

  • 12 replies
  • 2 have this problem
  • 117 views
  • Last reply by sfhowes

more options

After I open an email and/or reply to it, the alert stays on at lower right. I read a great many emails every day at work and having to turn off the alert manually wastes time. How can I set the alert to go off when I've read a new email?

All Replies (12)

more options

That sounds like a website issue. But it could also be an add-on.

more options

Sorry, I forgot to say that I have Thunderbird email.

more options

Okay. I called to have your question moved to the Thunderbird forum. Please wait.

more options

Meh. It sat unanswered for several days in the Thunderbird forum so I moved it here.

more options

I don't recall what settings we have to control the behaviour of these prompts. I use the GNotifier addon, which ties Thunderbird into the desktop's notifier. One of its settings is an automatic timed removal of incoming email notifications.

This addon works with Windows and Linux, so Mac users are out of luck.

more options

I don't think you can have the alert disappear right after you've opened a message, but you can change the time it stays on the screen, or disable it entirely and keep tray notifications (see picture).

more options

Woops! My bad! I should have said "tray icon" instead of "alert." The tray icon can't be customized the way the message alert can. I find the message alert too obtrusive. I like the small tray icon, but it has to be cleared manually.

more options

I have Thunderbird turned to On in Settings/Personalization/Taskbar/Notification area/Select which icons appear on the taskbar. When new mail arrives, the icon appears in the tray until the new messages are opened. If it's turned to Off, the icon appears when mail arrives, and then moves to the 'hidden icons' after an unspecified time.

You may also want to check the settings for TB in Settings/System/Notifications & actions, 'Get notifications from these senders'.

more options

sfhowes said

I have Thunderbird turned to On in Settings/Personalization/Taskbar/Notification area/Select which icons appear on the taskbar. When new mail arrives, the icon appears in the tray until the new messages are opened. If it's turned to Off, the icon appears when mail arrives, and then moves to the 'hidden icons' after an unspecified time. You may also want to check the settings for TB in Settings/System/Notifications & actions, 'Get notifications from these senders'.

With respect to your first suggestion, I have TB set to On as you describe. For your second point, I can't find "Get notifications from these senders." Can you provide the complete path to get there?

more options

The wording suggests it's a TB setting, but I meant W10 (v. 1709) Settings (see pictures). I don't think all of these options currently work, e.g. notifications in Action Center, without an add-on. The 2nd picture is shown when you click 'Mozilla Thunderbird' on the list shown in the 1st picture.

more options

I have W10 1703. The Notifications and actions screen is different for your screen shot. TB is not listed.

more options

I don't recall that anything significant changed with TB notifications after 1709, but you can either update to that version, or wait a month or so for 1803 (Redstone 4).