Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

hyperlink in outlook will not open

  • 4 replies
  • 7 have this problem
  • 1704 views
  • Last reply by Jeff Moritz

more options

In Firefox when I open outlook hyperlink in email will not open. It will open once the first time sometimes. then not.

This is not an issue with chrome explorer, etc. Only Firefox. this just started. I find no solutions. The issue is only in outlook email extension, not with anything else. I am now using chrome but have always used Firefox for everything. What to do.

Its hard to find any solution or to contact for such.

Thank you.

Jon

Chosen solution

hi jon, please try to update to firefox 58.0.2 - it contains a fix for some troubles with outlook webmail: https://www.mozilla.org/en-US/firefox/58.0.2/releasenotes/

Update Firefox to the latest release

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

hi jon, please try to update to firefox 58.0.2 - it contains a fix for some troubles with outlook webmail: https://www.mozilla.org/en-US/firefox/58.0.2/releasenotes/

Update Firefox to the latest release

more options

To jandKW:

If you are using Outlook installed on your computer (as opposed to an online "cloud" version), and the hyperlinks are not opening in Firefox, or are not opening at all, then it may be a registry problem.

When a browser other than Edge or Internet Explorer, especially Firefox, is set as the default browser for html files, it may change the registry "HKEY_CLASSES_ROOT \.html" (Default) value from "htmlfile" to "FIREFOXhtml", or in the case of Google Chrome, to "CHROMEhtml".

Check both the ".htm" AND the ".html" registry entries. Both may have been changed, and will need to be changed back.

Changing that value back to "htmlfile" will usually fix the problem--but don't take my word for it.

Below are three links that describe the problem you are having and the solution to the problem.

I fixed the problem by simply changing the one registry entry back to "htmlfile", as described above.

Hope this helps you and others who have the problem with Outlook on Windows 10.

1. Windows 10 Hyperlinks in emails not working. https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings-winpc/windows-10-hyperlinks-in-emails-not-working/9b663600-2890-4b43-b940-3d98377423dc?auth=1

2. Outlook on Windows 10: Hyperlinks Don't Work https://www.outlook-tips.net/tips/outlook-on-windows-10-hyperlinks-dont-work/

3. Hyperlinks not working in Outlook? How to make links open again in Outlook 2016, 2013, 2010 and lower https://www.ablebits.com/office-addins-blog/2014/01/16/hyperlinks-not-working-outlook/#edit-registry

Modified by AlSwilling

more options

Mozilla claims to value customer service, yet they have no customer service, and no inclination to fix things

more options

Hi Jon,

I had the same issue where I could not open any Firefox links from within an Outlook 2016 email message after I had first completely uninstalled Firefox (via "Programs and Features" and deleting all Mozilla entries under "Program Files", "Program Files (x86)", "Program Data", "AppData/local/Mozilla", "AppData/LocalLow/Mozilla", "AppData/roaming/Mozilla") and then reinstalled the latest version (61.0.1 (64-bit)) of Firefox.

I found that by setting the default web browser app to Chrome, that links from Outlook emails would open the links in Chrome; but when I set the default web browser app to Firefox then none of the links worked.

AlSwilling's suggestion (above) gave me the idea to look at the registry entries for both .htm and .html.

In the registry editor, I first searched for the string that AlSwilling mentioned: FirefoxHTML and I found that in my registry it was listed as: FirefoxHTML-308046B0AF4A39CB

I then searched for the .htm and .html registry entries (using the "match whole string only" flag to save time). When I examined those entries, I found that six keys similar to "Computer\HKEY_CLASSES_ROOT\.htm\OpenWithProgids" had entries for "ChromeHTML" and "IE.AssocFile.HTM". I decided to take a chance and add a new empty string value (SZ) using the name "FirefoxHTML-308046B0AF4A39CB". (See the attached image for an example of this edit)

I added this new empty string name to the following six registry keys:

Computer\HKEY_CLASSES_ROOT\.htm\OpenWithProgids Computer\HKEY_CLASSES_ROOT\.html\OpenWithProgids Computer\HKEY_CURRENT_USER\Software\Classes\.htm\OpenWithProgids Computer\HKEY_CURRENT_USER\Software\Classes\.html\OpenWithProgids Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.htm\OpenWithProgIds Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.html\OpenWithProgIds

After the addition of the six registry entries, I changed the default browser setting back to Firefox and found that clicking on links in Outlook email messages now opened in Firefox!

Please note that if you try this fix that the name of the registry value may not be the same as mine (FirefoxHTML-308046B0AF4A39CB). Please first search your registry for "FirefoxHTML" to determine the correct value to use.

As a final aside, to change the default browser in Windows 10: from the windows start menu, choose "Settings -> Windows Settings -> Apps -> Default Apps" and click the "Web Browser" icon.

Modified by Jeff Moritz