X
Tap here to go to the mobile version of the site.

Support Forum

menu's don't open in Firefox 58

Posted

Hello! These kind of menu's don't open in Firefox 58. See the image below. I hope you understand what I mean. That's why I downgraded tot Firefox 57. I also tried the nightly version 59 but the problem remains. Greetings, Roelf Oving

Hello! These kind of menu's don't open in Firefox 58. See the image below. I hope you understand what I mean. That's why I downgraded tot Firefox 57. I also tried the nightly version 59 but the problem remains. Greetings, Roelf Oving
Attached screenshots

Chosen solution

In fact I am using Avast.

I want to thank everyone for helping me finding a solution for my problems. I think this item can be closed.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

Helpful Reply

Hi Roelf, can you give a link to a page or two where the form controls do not operate so a Mac-using volunteer can take a look?

Hi Roelf, can you give a link to a page or two where the form controls do not operate so a Mac-using volunteer can take a look?
Was this helpful to you? 2
Quote

Question owner

jscher2000 said

Hi Roelf, can you give a link to a page or two where the form controls do not operate so a Mac-using volunteer can take a look?

Hi! The screenshot is from www.hattrick.org, you have to log in to see it, but I found a couple of links to (Dutch) sites: https://www.marktplaats.nl/z/audio-tv-en-foto/fotografie-camera-s-digitaal.html?categoryId=487&distance=10000&view=lr

After the word Marktplaats I cannot make another choice than Fotografie/Camera's and I cannot make another choice than < 10 km

https://www.bol.com/nl/s/algemeen/zoekresultaten/Ntt/pc3-12800%2Bddr3%2B204-pins%2Bso-dimm%2527/N/0/Nty/1/search/true/searchType/qck/suggestionType/search_history/originalSearchContext/media_all/originalSection/main/defaultSearchContext/media_all/sc/media_all/index.html

I cannot change my choice where it says Computer (befor the looking glass symbol).

''jscher2000 [[#answer-1075727|said]]'' <blockquote> Hi Roelf, can you give a link to a page or two where the form controls do not operate so a Mac-using volunteer can take a look? </blockquote> Hi! The screenshot is from www.hattrick.org, you have to log in to see it, but I found a couple of links to (Dutch) sites: https://www.marktplaats.nl/z/audio-tv-en-foto/fotografie-camera-s-digitaal.html?categoryId=487&distance=10000&view=lr After the word Marktplaats I cannot make another choice than Fotografie/Camera's and I cannot make another choice than < 10 km https://www.bol.com/nl/s/algemeen/zoekresultaten/Ntt/pc3-12800%2Bddr3%2B204-pins%2Bso-dimm%2527/N/0/Nty/1/search/true/searchType/qck/suggestionType/search_history/originalSearchContext/media_all/originalSection/main/defaultSearchContext/media_all/sc/media_all/index.html I cannot change my choice where it says Computer (befor the looking glass symbol).
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

Hmm, they work normally for me on Windows 7 and MacOS 10.12.

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of option/alt.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hmm, they work normally for me on Windows 7 and MacOS 10.12. Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of option/alt.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you?
Quote

Question owner

Nope, it still doesn't work.

I have Mac OS X 10.13.3 (17D47)

Nope, it still doesn't work. I have Mac OS X 10.13.3 (17D47)
Was this helpful to you?
Quote

Question owner

I did not get an answer yet. Does that mean nobody knows one?

I did not get an answer yet. Does that mean nobody knows one?
Was this helpful to you?
Quote
Happy112
  • Top 10 Contributor
562 solutions 5694 answers

Hi Roelf, 'Wish you'd update to the latest Firefox version (58.0.2), but I'll spare you the lecture ....

Going to give you a few things to try :

Reload the page : Hold down the Shift key and left-click the Reload button or press 'Ctrl + F5' or press 'Ctrl + Shift + R'

Another thing to try : Clear the cache and cookies only from websites that cause problems.

Clear the Cache:

3-bar menu => Options => Privacy & Security => Cached Web Content :
"Clear Now"

Remove Cookies from sites causing problems:

3-bar menu => Options => Privacy & Security => under 'History' : choose 'Use custom settings for history' => "Show Cookies"


If the above doesn't make a difference, then try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Any difference  ?

Hi Roelf, 'Wish you'd update to the latest Firefox version ('''58.0.2'''), but I'll spare you the lecture .... Going to give you a few things to try : Reload the page : Hold down the Shift key and left-click the Reload button or press 'Ctrl + F5' or press 'Ctrl + Shift + R' Another thing to try : Clear the cache and cookies only from websites that cause problems.<BR> '''Clear the Cache''': 3-bar menu => Options => Privacy & Security => Cached Web Content : <BR> "Clear Now" <BR> '''Remove Cookies''' from sites causing problems: 3-bar menu => Options => Privacy & Security => under 'History' : choose 'Use custom settings for history' => "Show Cookies" ---------------------------------------------------------------------------------------------------------- If the above doesn't make a difference, then try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Any difference ?
Was this helpful to you? 0
Quote

Question owner

I'm sorry, but it still doesn't work. My question remains: Why don't I have any problems in 57.0.4, but do I have them in 58.0.2?

I'm sorry, but it still doesn't work. My question remains: Why don't I have any problems in 57.0.4, but do I have them in 58.0.2?

Modified by Iron Flower

Was this helpful to you?
Quote
Happy112
  • Top 10 Contributor
562 solutions 5694 answers

Iron Flower said

I'm sorry, but it still doesn't work. My question remains: Why don't I have any problems in 57.0.4, but do I hav them in 58.0.2?

Beats me ....... (sorry)

Hopefully somebody else will come to your rescue ....

''Iron Flower [[#answer-1084601|said]]'' <blockquote> I'm sorry, but it still doesn't work. My question remains: Why don't I have any problems in 57.0.4, but do I hav them in 58.0.2? </blockquote> Beats me ....... (sorry) Hopefully somebody else will come to your rescue ....
Was this helpful to you?
Quote

Question owner

Well, thanks for trying to help me. I appreciate that very much.

Well, thanks for trying to help me. I appreciate that very much.
Was this helpful to you?
Quote

Question owner

I decided to refresh Firefox. Now my problem is solved, but I don' have any add-ons anymore, and this page looks terrible

I decided to refresh Firefox. Now my problem is solved, but I don' have any add-ons anymore, and this page looks terrible
Was this helpful to you?
Quote
Happy112
  • Top 10 Contributor
562 solutions 5694 answers

Iron Flower said

I decided to refresh Firefox. Now my problem is solved, but I don' have any add-ons anymore, and this page looks terrible

Oh boy - didn't see that coming  !

I hope you didn't have many add-ons  ?

You should see a folder named 'Old Firefox Data' on your desktop.

Would you please take a look at this article (and scroll all the way down) :

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

But I'm glad that your (initial) problem is solved though - well done  !

Unless you're still facing problems : please mark your own (last) post as Chosen Solution.

''Iron Flower [[#answer-1084611|said]]'' <blockquote> I decided to refresh Firefox. Now my problem is solved, but I don' have any add-ons anymore, and this page looks terrible </blockquote> Oh boy - didn't see that coming ! I hope you didn't have many add-ons ? You should see a folder named 'Old Firefox Data' on your desktop. Would you please take a look at this article (and scroll all the way down) : https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings But I'm glad that your (initial) problem is solved though - well done ! Unless you're still facing problems : please mark your own (last) post as Chosen Solution.
Was this helpful to you?
Quote

Question owner

I decided to delete Firefox and reinstall it. Some of the add-ons are now working again. This support-page still is a mess, but at least my problem has solved. Thanks again for the support!

I decided to delete Firefox and reinstall it. Some of the add-ons are now working again. This support-page still is a mess, but at least my problem has solved. Thanks again for the support!

Modified by Iron Flower

Was this helpful to you?
Quote
Happy112
  • Top 10 Contributor
562 solutions 5694 answers

Wow  ! You're on fire today - first a Refresh, now uninstall and reinstall.

I wonder what you mean by "The support page is still a mess ... " (?)

But : you did a great job - well done  !

However, should you have anymore questions  : don't hesitate to ask  !

Wow ! You're on fire today - first a Refresh, now uninstall and reinstall. I wonder what you mean by "The support page is still a mess ... " (?) But : you did a great job - well done ! However, should you have anymore questions : don't hesitate to ask !
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

I'm guessing from these two comments --

Iron Flower said

I decided to refresh Firefox. Now my problem is solved, but I don' have any add-ons anymore, and this page looks terrible

Iron Flower said

This support-page still is a mness, but at least my problem has solved.

-- that the style rules are not working completely, so the page layout is broken.

One possible reason for that is if your Firefox is having trouble making secure connections. If you notice an unusual number of untrusted connection errors, we can help you investigate that. Otherwise, we can introduce you to some panels in Firefox's developer tools that provide information on what files are loading and not loading in a site, and what errors are encountered, to get to the the bottom of it. Of course, if the problem is ONLY on this site, perhaps it's not a priority at the moment.

I'm guessing from these two comments -- ''Iron Flower [[#answer-1084611|said]]'' <blockquote> I decided to refresh Firefox. Now my problem is solved, but I don' have any add-ons anymore, and this page looks terrible </blockquote> ''Iron Flower [[#answer-1084644|said]]'' <blockquote> This support-page still is a mness, but at least my problem has solved. </blockquote> -- that the style rules are not working completely, so the page layout is broken. One possible reason for that is if your Firefox is having trouble making secure connections. If you notice an unusual number of untrusted connection errors, we can help you investigate that. Otherwise, we can introduce you to some panels in Firefox's developer tools that provide information on what files are loading and not loading in a site, and what errors are encountered, to get to the the bottom of it. Of course, if the problem is ONLY on this site, perhaps it's not a priority at the moment.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16225 solutions 146466 answers

Helpful Reply

You can copy files like these with Firefox closed to the current profile folder to recover specific data.

  • bookmarks and history: places.sqlite
  • bookmark backups: compressed .jsonlz4 JSON backups in the bookmarkbackups folder
  • cookies.sqlite for the Cookies
  • formhistory.sqlite for saved autocomplete Form Data
  • logins.json (passwords) and key4.db (58+) or key3.db (57 and older) (decryption key) for Passwords saved in the Password Manager
    if you only have key3.db then make sure to remove an existing key4.db
  • cert9.db (58+) or cert8.db (57 and older) for (intermediate) certificates stored in the Certificate Manager
    if you only have cert8.db then make sure to remove an existing cert9.db
  • persdict.dat for words you added to the spelling checker dictionary
  • permissions.sqlite for Permissions and possibly content-prefs.sqlite for other website specific data (Site Preferences)
  • sessionstore.jsonlz4 for open tabs and pinned tabs (see also the sessionstore-backups folder)
You can copy files like these with Firefox closed to the current profile folder to recover specific data. *bookmarks and history: places.sqlite *bookmark backups: compressed .jsonlz4 JSON backups in the bookmarkbackups folder *cookies.sqlite for the Cookies *formhistory.sqlite for saved autocomplete Form Data *logins.json (passwords) and key4.db (58+) or key3.db (57 and older) (decryption key) for Passwords saved in the Password Manager<br>if you only have key3.db then make sure to remove an existing key4.db *cert9.db (58+) or cert8.db (57 and older) for (intermediate) certificates stored in the Certificate Manager<br>if you only have cert8.db then make sure to remove an existing cert9.db *persdict.dat for words you added to the spelling checker dictionary *permissions.sqlite for Permissions and possibly content-prefs.sqlite for other website specific data (Site Preferences) *sessionstore.jsonlz4 for open tabs and pinned tabs (see also the sessionstore-backups folder)
Was this helpful to you? 1
Quote

Question owner

jscher2000 zei

I'm guessing from these two comments -- Iron Flower said
I decided to refresh Firefox. Now my problem is solved, but I don' have any add-ons anymore, and this page looks terrible


Iron Flower said

This support-page still is a mness, but at least my problem has solved.

-- that the style rules are not working completely, so the page layout is broken.

One possible reason for that is if your Firefox is having trouble making secure connections. If you notice an unusual number of untrusted connection errors, we can help you investigate that. Otherwise, we can introduce you to some panels in Firefox's developer tools that provide information on what files are loading and not loading in a site, and what errors are encountered, to get to the the bottom of it. Of course, if the problem is ONLY on this site, perhaps it's not a priority at the moment.

I do have an unusual number of untrusted connection errors. It even is not possible for me to use Firefox, so I am now using Safari instead.

Update: I copied the old cert9.db to my new profile folder and now it seems to be working fine again.

''jscher2000 [[#answer-1084650|zei]]'' <blockquote> I'm guessing from these two comments -- ''Iron Flower [[#answer-1084611|said]]'' <blockquote> I decided to refresh Firefox. Now my problem is solved, but I don' have any add-ons anymore, and this page looks terrible </blockquote> ''Iron Flower [[#answer-1084644|said]]'' <blockquote> This support-page still is a mness, but at least my problem has solved. </blockquote> -- that the style rules are not working completely, so the page layout is broken. One possible reason for that is if your Firefox is having trouble making secure connections. If you notice an unusual number of untrusted connection errors, we can help you investigate that. Otherwise, we can introduce you to some panels in Firefox's developer tools that provide information on what files are loading and not loading in a site, and what errors are encountered, to get to the the bottom of it. Of course, if the problem is ONLY on this site, perhaps it's not a priority at the moment. </blockquote> I do have an unusual number of untrusted connection errors. It even is not possible for me to use Firefox, so I am now using Safari instead. Update: I copied the old cert9.db to my new profile folder and now it seems to be working fine again.

Modified by Iron Flower

Was this helpful to you?
Quote

Question owner

Happy112 zei

Wow  ! You're on fire today - first a Refresh, now uninstall and reinstall. I wonder what you mean by "The support page is still a mess ... " (?) But : you did a great job - well done  ! However, should you have anymore questions  : don't hesitate to ask  !

I was going to send you a screenshot, but it is OK now...

''Happy112 [[#answer-1084649|zei]]'' <blockquote> Wow ! You're on fire today - first a Refresh, now uninstall and reinstall. I wonder what you mean by "The support page is still a mess ... " (?) But : you did a great job - well done ! However, should you have anymore questions : don't hesitate to ask ! </blockquote> I was going to send you a screenshot, but it is OK now...
Was this helpful to you?
Quote

Question owner

cor-el zei

You can copy files like these with Firefox closed to the current profile folder to recover specific data.
  • bookmarks and history: places.sqlite
  • bookmark backups: compressed .jsonlz4 JSON backups in the bookmarkbackups folder
  • cookies.sqlite for the Cookies
  • formhistory.sqlite for saved autocomplete Form Data
  • logins.json (passwords) and key4.db (58+) or key3.db (57 and older) (decryption key) for Passwords saved in the Password Manager
    if you only have key3.db then make sure to remove an existing key4.db
  • cert9.db (58+) or cert8.db (57 and older) for (intermediate) certificates stored in the Certificate Manager
    if you only have cert8.db then make sure to remove an existing cert9.db
  • persdict.dat for words you added to the spelling checker dictionary
  • permissions.sqlite for Permissions and possibly content-prefs.sqlite for other website specific data (Site Preferences)
  • sessionstore.jsonlz4 for open tabs and pinned tabs (see also the sessionstore-backups folder)

I will certainly look at it. I added cert9.db to my new profile folder. Do I have to do the same with cert8.db?

''cor-el [[#answer-1084757|zei]]'' <blockquote> You can copy files like these with Firefox closed to the current profile folder to recover specific data. *bookmarks and history: places.sqlite *bookmark backups: compressed .jsonlz4 JSON backups in the bookmarkbackups folder *cookies.sqlite for the Cookies *formhistory.sqlite for saved autocomplete Form Data *logins.json (passwords) and key4.db (58+) or key3.db (57 and older) (decryption key) for Passwords saved in the Password Manager<br>if you only have key3.db then make sure to remove an existing key4.db *cert9.db (58+) or cert8.db (57 and older) for (intermediate) certificates stored in the Certificate Manager<br>if you only have cert8.db then make sure to remove an existing cert9.db *persdict.dat for words you added to the spelling checker dictionary *permissions.sqlite for Permissions and possibly content-prefs.sqlite for other website specific data (Site Preferences) *sessionstore.jsonlz4 for open tabs and pinned tabs (see also the sessionstore-backups folder) </blockquote> I will certainly look at it. I added cert9.db to my new profile folder. Do I have to do the same with cert8.db?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7295 solutions 59409 answers

Iron Flower said

Update: I copied the old cert9.db to my new profile folder and now it seems to be working fine again.

Iron Flower said

I added cert9.db to my new profile folder. Do I have to do the same with cert8.db?

Sounds like you might use security software that intercepts your browsing (Avast, Bitdefender, ESET, Kaspersky, etc.). Before Refresh, Firefox was set up to trust the fake site certificates generated by your "man in the middle" and that certificate was stored in the old cert9.db file. So replacing the newer file with the older one restored that trust. (Hopefully the trust is well placed and it's your security software and not some spyware!)

The cert8.db file is obsolete now, so you do not need to copy that one over.

''Iron Flower [[#answer-1084871|said]]'' <blockquote> Update: I copied the old cert9.db to my new profile folder and now it seems to be working fine again. </blockquote> ''Iron Flower [[#answer-1084880|said]]'' <blockquote>I added cert9.db to my new profile folder. Do I have to do the same with cert8.db? </blockquote> Sounds like you might use security software that intercepts your browsing (Avast, Bitdefender, ESET, Kaspersky, etc.). Before Refresh, Firefox was set up to trust the fake site certificates generated by your "man in the middle" and that certificate was stored in the old cert9.db file. So replacing the newer file with the older one restored that trust. (Hopefully the trust is well placed and it's your security software and not some spyware!) The cert8.db file is obsolete now, so you do not need to copy that one over.
Was this helpful to you? 1
Quote

Chosen Solution

In fact I am using Avast.

I want to thank everyone for helping me finding a solution for my problems. I think this item can be closed.

In fact I am using Avast. I want to thank everyone for helping me finding a solution for my problems. I think this item can be closed.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.