X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Some graphics do not display, e.g., banner and stars, on Amazon

Posted

I am using Windows 7 professional and Firefox 58, 64 bit. On the amazon.com site, one of my two Windows 7 professional computers will not display the top-banner graphics (missing black background) or the average number of stars in a review - just a link to all the reviews. The missing stars is a small detail but an inconvenience. There are non-displayed graphic details on other web sites as well. Text and basic functionality are OK. Google Chrome works fine in all respects, but Firefox and IE 10 have the same problem.

All other graphics on the computer look normal, e.g., icons and images. It is just these graphic details on Firefox-displayed web pages.

I have tried the following without success: Restarting Firefox with extensions disabled (safe mode); Reinstalling Firefox; Disabling on-board graphics and installing a spare GeForce 7950 GT graphics card in the widest (16 channel ?) slot with Nvidia's latest drivers; Disabling hardware graphics acceleration under Firefox options; Disabling IE 10 from Windows configuration.

My other Windows 7 professional computer does not have this problem. The only display difference between them is that the one that displays properly has a different motherboard, a more recent graphics card, a GeForce GTX 760. and an older monitor. That said, I do not recall ever seeing this graphics problem on my own computer, even in an older hardware build with earlier graphics cards. Both computers use full resolution, a DPI setting of 125%, and 32-bit color depth.

Any ideas?

I am using Windows 7 professional and Firefox 58, 64 bit. On the amazon.com site, one of my two Windows 7 professional computers will not display the top-banner graphics (missing black background) or the average number of stars in a review - just a link to all the reviews. The missing stars is a small detail but an inconvenience. There are non-displayed graphic details on other web sites as well. Text and basic functionality are OK. Google Chrome works fine in all respects, but Firefox and IE 10 have the same problem. All other graphics on the computer look normal, e.g., icons and images. It is just these graphic details on Firefox-displayed web pages. I have tried the following without success: Restarting Firefox with extensions disabled (safe mode); Reinstalling Firefox; Disabling on-board graphics and installing a spare GeForce 7950 GT graphics card in the widest (16 channel ?) slot with Nvidia's latest drivers; Disabling hardware graphics acceleration under Firefox options; Disabling IE 10 from Windows configuration. My other Windows 7 professional computer does not have this problem. The only display difference between them is that the one that displays properly has a different motherboard, a more recent graphics card, a GeForce GTX 760. and an older monitor. That said, I do not recall ever seeing this graphics problem on my own computer, even in an older hardware build with earlier graphics cards. Both computers use full resolution, a DPI setting of 125%, and 32-bit color depth. Any ideas?

Chosen solution

Hi Peter_Smith, thank you for the screenshots. Are you using a "High Contrast" theme in Windows? It might help to set Firefox not to adapt web pages to that theme.

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type color and Firefox should filter the page down so you can easily find the "Colors" button. Go ahead and click that.

Try changing this setting:

"Override the colors specified by the page with your selections above"

Below that, it usually says

"Only with High Contrast themes"

Click that and change the setting to

"Never"

then click OK to finish the change.

Does that help at all?

Here's a screenshot of that part of the Colors dialog:

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

WestEnd
  • Top 10 Contributor
59 solutions 5131 answers

Helpful Reply

Screen shot of the amazon error so others can compare to what they see if they go to Amazon?

Screen shot of the amazon error so others can compare to what they see if they go to Amazon?

Question owner

Thanks.

Here are two screen shots showing erroneous graphics, annotated in red. 1) Amazon page with errors annotated in red. 2) This support page, missing text editing symbols.

Thanks. Here are two screen shots showing erroneous graphics, annotated in red. 1) Amazon page with errors annotated in red. 2) This support page, missing text editing symbols.

Modified by Peter_Smith

Question owner

For comparison with above erroneous images, here are two screenshots showing what it SHOULD look like, taken on the other computer.

Problem not fixed yet,

For comparison with above erroneous images, here are two screenshots showing what it SHOULD look like, taken on the other computer. Problem not fixed yet,
jscher2000
  • Top 10 Contributor
8321 solutions 68114 answers

Chosen Solution

Hi Peter_Smith, thank you for the screenshots. Are you using a "High Contrast" theme in Windows? It might help to set Firefox not to adapt web pages to that theme.

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type color and Firefox should filter the page down so you can easily find the "Colors" button. Go ahead and click that.

Try changing this setting:

"Override the colors specified by the page with your selections above"

Below that, it usually says

"Only with High Contrast themes"

Click that and change the setting to

"Never"

then click OK to finish the change.

Does that help at all?

Here's a screenshot of that part of the Colors dialog:

Hi Peter_Smith, thank you for the screenshots. Are you using a "High Contrast" theme in Windows? It might help to set Firefox not to adapt web pages to that theme. * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''color'' and Firefox should filter the page down so you can easily find the "Colors" button. Go ahead and click that. Try changing this setting: "Override the colors specified by the page with your selections above" Below that, it usually says "Only with High Contrast themes" Click that and change the setting to "Never" then click OK to finish the change. Does that help at all? Here's a screenshot of that part of the Colors dialog: <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-01-21-12-48-55-d2a6b4.png" width="500">

Question owner

Thank you, jsher2000! That "Never" option solved the problem, but it raises some questions.

I am not using a "High Contrast" theme, per se. I am using the Windows Classic theme, solid background, with modified colors - darker blue with more grey tint background . Is the Windows Classic a high contrast theme, even thought is not labeled as such? Would changing theme colors make the contrast greater?

My other computer uses the same Windows Classic theme with similar colors, set by eyeball. It works OK without this fix. Any idea why one computer would work and the other (this one) would not work?

This seems like an obscure situation that most people would not know about. Maybe it is a borderline bug. Glad you found it.

I'll set this problem as solved by you later, but I wanted some more understanding, if possible. Thanks.

Thank you, jsher2000! That "Never" option solved the problem, but it raises some questions. I am not using a "High Contrast" theme, per se. I am using the Windows Classic theme, solid background, with modified colors - darker blue with more grey tint background . Is the Windows Classic a high contrast theme, even thought is not labeled as such? Would changing theme colors make the contrast greater? My other computer uses the same Windows Classic theme with similar colors, set by eyeball. It works OK without this fix. Any idea why one computer would work and the other (this one) would not work? This seems like an obscure situation that most people would not know about. Maybe it is a borderline bug. Glad you found it. I'll set this problem as solved by you later, but I wanted some more understanding, if possible. Thanks.

Modified by Peter_Smith

jscher2000
  • Top 10 Contributor
8321 solutions 68114 answers

Hi Peter_Smith, in versions past, it was only the High Contrast themes that led Firefox to drop out all the background colors and background images, which was why I suspected that based on your screenshots. Perhaps something else is now triggering that, but I haven't researched it.

Hi Peter_Smith, in versions past, it was only the High Contrast themes that led Firefox to drop out all the background colors and background images, which was why I suspected that based on your screenshots. Perhaps something else is now triggering that, but I haven't researched it.

Question owner

OK, thanks. Maybe Mozilla should be informed of the inconsistency. I also think that if this is a problem with High Contrast or other themes, the user should be warned, or the default should be set to "Never".

Thanks again.

OK, thanks. Maybe Mozilla should be informed of the inconsistency. I also think that if this is a problem with High Contrast or other themes, the user should be warned, or the default should be set to "Never". Thanks again.