Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I fix a weird audio issue on Firefox Quantum? HTML5

  • 13 replies
  • 2 have this problem
  • 165 views
  • Last reply by Chris Ilias

more options

Currently there is some issue with sound in Firefox Quantum. It affects YouTube videos (HTML5 - not tested with other platforms). When opening up a new window to start playing a YT video, sound is perfect (all the effects of my sound card are respected, e.g. the equalizer). As soon as I jump in the video, it seems like the equalizer of my sound card is not working anymore. I can clearly hear that. But this only happens if you jump the video. After that, I need to restart the whole browser to reset this issue.

How to reproduce: 1. Start Firefox from scratch 2. Open up YouTube 3. Choose any video 4. Jump in the video to any position

Using ASUS Phoebus as sound card on Windows 10. On other browsers, this issue does not occur.

Chosen solution

So I finally managed to update all drivers and the system itself. It did not fix the issue, but it seems, that Firefox is not the problem. I was able to reproduce it in IE Edge on Netflix. Seems like Windows 10 hast issues with HTML5 streams in certain situations.

Read this answer in context 👍 0

All Replies (13)

more options

I done that and have no problem with stopping the video and going to different points on the video. I got W10 MSI GTX1060 6G 16gig Soundblaster ex card. So I think your has to do with how your system is configure that caused this more then a FF issue.

more options

Starting/Stopping/Jumping was not the issue. The audioeffects of my Sound Card do not take any effect after these actions.

Keep in mind that you will only be able to reproduce it, if you have any effects on the sound card, like the equalizer, active.

more options

I've kept mine at default settings with Sound Ambiance as the only change and my youtube has no issue from FF56 to FF58. I still think something went wrong with the drivers.

more options

Hi wengaCH, Let's try something simple, like clearing your cache and cookies.

  1. Click the Library button 57 library icon and choose History.
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.
more options

Chris Ilias said

Hi wengaCH, Let's try something simple, like clearing your cache and cookies.
  1. Click the Library button 57 library icon and choose History.
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.

Did all of that, cleared all of the cache, cookies, settings and history. Yet it did not help. I can still reproduce the sound issue.

more options

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Chris Ilias said

Try Firefox Safe Mode to see if the problem goes away. (...)

Hi Chris. Just did that. I can still reproduce the issue. So no add-ons are affecting it.

more options
more options

Chris Ilias said

Let's try resetting Firefox: Reset Firefox preferences to troubleshoot and fix problems

Did not fix the problem.

more options

Update:

Can be reproduced on Vimeo as well. So it's probably a HTML5 media issue

more options

Unless someone else has another suggestion, the only other thing I can think of is to make sure your drivers are up to date. If they are up to date, it looks like a bug. :(

more options

Chosen Solution

So I finally managed to update all drivers and the system itself. It did not fix the issue, but it seems, that Firefox is not the problem. I was able to reproduce it in IE Edge on Netflix. Seems like Windows 10 hast issues with HTML5 streams in certain situations.

Modified by wengaCH

more options

Thanks for letting us know. :)