X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Why by default Firefox uses so much RAM?

Posted

I tried to use Firefox in three different computers but only in the one with over 4 GB of ram is usable. Why it uses so much RAM and renders so slow? Specially the scroll is really laggy.

I tried clean installations but they do not fix the issue.

When opening Firefox and Chrome and playing a video in YouTube, Firefox uses over 500 MB while Chrome uses less than 300 MB. Both with the same single addon.

Is there something that can be done to use Firefox in computers with less than 4 gb of RAM?

I tried to use Firefox in three different computers but only in the one with over 4 GB of ram is usable. Why it uses so much RAM and renders so slow? Specially the scroll is really laggy. I tried clean installations but they do not fix the issue. When opening Firefox and Chrome and playing a video in YouTube, Firefox uses over 500 MB while Chrome uses less than 300 MB. Both with the same single addon. Is there something that can be done to use Firefox in computers with less than 4 gb of RAM?

Chosen solution

Hi, yes there's a couple of things to try: You can try reducing the number of Multiprocesses: Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1 or 2. See - Firefox's performance settings, and Startup, home page, tabs, and download settings.

Whilst in the 3-bar menu, you can also go to Options (Privacy & Security) - Permissions, and tick/check 'Prevent accessibility services from accessing your browser' then restart Firefox. More - What is the Accessibility Service Indicator?

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

Scribe 728 solutions 3470 answers

Chosen Solution

Hi, yes there's a couple of things to try: You can try reducing the number of Multiprocesses: Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1 or 2. See - Firefox's performance settings, and Startup, home page, tabs, and download settings.

Whilst in the 3-bar menu, you can also go to Options (Privacy & Security) - Permissions, and tick/check 'Prevent accessibility services from accessing your browser' then restart Firefox. More - What is the Accessibility Service Indicator?

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Hi, yes there's a couple of things to try: You can try reducing the number of Multiprocesses: Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1 or 2. See - [[Firefox's performance settings]], and [[Startup, home page, tabs, and download settings]]. Whilst in the 3-bar menu, you can also go to Options (Privacy & Security) - Permissions, and tick/check 'Prevent accessibility services from accessing your browser' then restart Firefox. More - [[What is the Accessibility Service Indicator?]] ''If your question is resolved by this or another answer, please take a minute to let us know. Thank you!''

Question owner

It kind of lowers the usage but still using about 400 MB with the settings set at 1 process with a single YouTube tab open, far from the Chrome performance.

Is not that I want to compare both browsers, but I have to choose one that works well on those computers.

Anyway, thank you.

It kind of lowers the usage but still using about 400 MB with the settings set at 1 process with a single YouTube tab open, far from the Chrome performance. Is not that I want to compare both browsers, but I have to choose one that works well on those computers. Anyway, thank you.
R3drang3r 0 solutions 5 answers

Helpful Reply

Using windows 10 and I am using the latest version 58.0.2 and after using it for a brief time it consumes over 50% of my 6 gig of Ram. I've applied all of the suggested fixes with no resolution. CPU usage is up also.

Using windows 10 and I am using the latest version 58.0.2 and after using it for a brief time it consumes over 50% of my 6 gig of Ram. I've applied all of the suggested fixes with no resolution. CPU usage is up also.

Modified by R3drang3r

neil64 1 solutions 19 answers

I have the same problem with Windows 10 and 58.0.2. Under task manger, FF will be using 5gb after a few minutes of use and multiple (3-5) tabs open. FF slows Windows down to a crawl. Eventually I close FF with task manger. After the memory clears, I restart FF . When FF restarts it uses around 550mb with the same tabs open and can most often run most of the day with no further issues.

I have the same problem with Windows 10 and 58.0.2. Under task manger, FF will be using 5gb after a few minutes of use and multiple (3-5) tabs open. FF slows Windows down to a crawl. Eventually I close FF with task manger. After the memory clears, I restart FF . When FF restarts it uses around 550mb with the same tabs open and can most often run most of the day with no further issues.
R3drang3r 0 solutions 5 answers

Thanks for the suggestion. It didn't really help me. I have noticed for a long time Firefox has 4 processes running in task manager. I just came across this fix for multiple processes running. It fixed my problems. Now I see only one process running and my memory usage is down.

Here's the fix: To disable e10s/multiprocess go to about:config by typing it in your URL bar. Search for browser.tabs.remote.autostart using the search box on about:config. There may be multiple results. Set them all to false and restart the browser.

Thanks for the suggestion. It didn't really help me. I have noticed for a long time Firefox has 4 processes running in task manager. I just came across this fix for multiple processes running. It fixed my problems. Now I see only one process running and my memory usage is down. Here's the fix: To disable e10s/multiprocess go to about:config by typing it in your URL bar. Search for browser.tabs.remote.autostart using the search box on about:config. There may be multiple results. Set them all to false and restart the browser.
neil64 1 solutions 19 answers

Did the above with some positive results. Memory usage decreased to 4-5gb. When it goes that high, it brings Win 10 to a crawl.

What is interesting is the problem goes away if I kill FF using taskmanager and restart it a few minutes later. Then FF will hover under 1gb for hours of use.

Thoughts?

Also having problems with back (previous page) not working correctly on various websites.

Did the above with some positive results. Memory usage decreased to 4-5gb. When it goes that high, it brings Win 10 to a crawl. What is interesting is the problem goes away if I kill FF using taskmanager and restart it a few minutes later. Then FF will hover under 1gb for hours of use. Thoughts? Also having problems with back (previous page) not working correctly on various websites.
R3drang3r 0 solutions 5 answers

Helpful Reply

I've done everything suggested with no real resolve. I even uninstalled Firefox and wiped out every trace of it from my entire system. I saved the three file Key4.db, logins.json, places.sqlite in another location. I entered "about:config" and searched for "browser.tabs.remote.autostart". I had the problem of multiple processes running in task manager. I toggled it false as recommended. Now Firefox 58.2.0 stills uses too much memory as I surf the web. The crazy thing is now sometimes Firefox completely disappears when viewing processes in task manager. Memory usage is running close to 50% but the firefox process is invisible. I have 6gig of Ram. The latest version of Firefox is using too many resources. Cpu and Memory are both constantly too high. Windows 10 becomes slow and even laggy at times.

I've done everything suggested with no real resolve. I even uninstalled Firefox and wiped out every trace of it from my entire system. I saved the three file Key4.db, logins.json, places.sqlite in another location. I entered "about:config" and searched for "browser.tabs.remote.autostart". I had the problem of multiple processes running in task manager. I toggled it false as recommended. Now Firefox 58.2.0 stills uses too much memory as I surf the web. The crazy thing is now sometimes Firefox completely disappears when viewing processes in task manager. Memory usage is running close to 50% but the firefox process is invisible. I have 6gig of Ram. The latest version of Firefox is using too many resources. Cpu and Memory are both constantly too high. Windows 10 becomes slow and even laggy at times.
neil64 1 solutions 19 answers

Can anyone help with this?

Can anyone help with this?
CrazyGuy 0 solutions 6 answers

I'm having the same problem. Just installed firefox yesterday. Super high CPU usage also. With only one tab open at fullscreen playing plinga game. Just updated graphics drivers. Maybe I'll go back to Chrome at this point.

I'm having the same problem. Just installed firefox yesterday. Super high CPU usage also. With only one tab open at fullscreen playing plinga game. Just updated graphics drivers. Maybe I'll go back to Chrome at this point.
R3drang3r 0 solutions 5 answers

I've given up on Mozilla after many years of use. I'm using Microsoft Edge and find it superior to Firefox. It uses far less resources and is much quicker browsing.

I've given up on Mozilla after many years of use. I'm using Microsoft Edge and find it superior to Firefox. It uses far less resources and is much quicker browsing.
neil64 1 solutions 19 answers

Avoided upgrading to 59.0.2. Finally bit the bullet and upgraded. 59.0.2 is marvelous. I have had zero problems with it and it is fast.

I did not change any settings that were changed trying to get 58.0.2 to work correctly.

I encourage everyone to upgrade to 59.0.2. It works great.

Avoided upgrading to 59.0.2. Finally bit the bullet and upgraded. 59.0.2 is marvelous. I have had zero problems with it and it is fast. I did not change any settings that were changed trying to get 58.0.2 to work correctly. I encourage everyone to upgrade to 59.0.2. It works great.
Oscar71 0 solutions 5 answers

neil64 said

Avoided upgrading to 59.0.2. Finally bit the bullet and upgraded. 59.0.2 is marvelous. I have had zero problems with it and it is fast. I did not change any settings that were changed trying to get 58.0.2 to work correctly. I encourage everyone to upgrade to 59.0.2. It works great.

Not for me. FF now slowest it's been for months. Noticed the increase in resource use after 59.0.1 now 59.0.2 is here I'm finding FF unbearable. Just when I thought FF was redeeming itself.

Going to go back to 58 build - that was acceptable - just.

''neil64 [[#answer-1097544|said]]'' <blockquote> Avoided upgrading to 59.0.2. Finally bit the bullet and upgraded. 59.0.2 is marvelous. I have had zero problems with it and it is fast. I did not change any settings that were changed trying to get 58.0.2 to work correctly. I encourage everyone to upgrade to 59.0.2. It works great. </blockquote> Not for me. FF now slowest it's been for months. Noticed the increase in resource use after 59.0.1 now 59.0.2 is here I'm finding FF unbearable. Just when I thought FF was redeeming itself. Going to go back to 58 build - that was acceptable - just.
neil64 1 solutions 19 answers

Sorry to hear that. I've upgrade 2 machines to 59.0.2 that have all of the above so called fixes for 59.0.1. Both are running FF well now.

Sorry to hear that. I've upgrade 2 machines to 59.0.2 that have all of the above so called fixes for 59.0.1. Both are running FF well now.
CrazyGuy 0 solutions 6 answers

Yep I gave up on firefox. Chrome sorta works.

Yep I gave up on firefox. Chrome sorta works.
Oscar71 0 solutions 5 answers

FF with 1 tab open (this page) 3 instances of FF in processes list, 1 at 41% (peaking at over 60%) CPU 214,000K the others at 175,000K and 72,000K Changing the Multi Processes via the menu options doesn't work.

One day maybe a decent browser will exist, but I ain't holding my breath!

FF with 1 tab open (this page) 3 instances of FF in processes list, 1 at 41% (peaking at over 60%) CPU 214,000K the others at 175,000K and 72,000K Changing the Multi Processes via the menu options doesn't work. One day maybe a decent browser will exist, but I ain't holding my breath!
Aerath 0 solutions 1 answers

The problem may not be with Firefox itself, as I have been using it for years without encountering it (FF 17 to 60, Win7 to 10, and Linux 3 to 4). Even with dozens of tabs I never reached more than 1.5G. And when idle (for example while writing this), the CPU usage is always under 4%. You may be using too many extensions, maybe some unwanted (even hidden) ones. You should try an extension remover to check for these.

The problem may not be with Firefox itself, as I have been using it for years without encountering it (FF 17 to 60, Win7 to 10, and Linux 3 to 4). Even with dozens of tabs I never reached more than 1.5G. And when idle (for example while writing this), the CPU usage is always under 4%. You may be using too many extensions, maybe some unwanted (even hidden) ones. You should try an extension remover to check for these.

Modified by Aerath

Question owner

Hello, yes that is the first thing I tried. I had also FF for many years in different computers (windows and Linux). So far I have only one extension installed (an ad-blocker) everything else is just a clean installation.

I didn't notice this issue until I had to install FF in computers with only 2G of RAM, at first I thought that nowadays 2G is kind of short but what surprised me is that Chrome (with the same extension) was running well using much less RAM and CPU in the same computers.

I use (and will keep using) FF in my main computer but it has 8G of RAM so I never addressed this issue until I had to setup those 2G laptops.

Hello, yes that is the first thing I tried. I had also FF for many years in different computers (windows and Linux). So far I have only one extension installed (an ad-blocker) everything else is just a clean installation. I didn't notice this issue until I had to install FF in computers with only 2G of RAM, at first I thought that nowadays 2G is kind of short but what surprised me is that Chrome (with the same extension) was running well using much less RAM and CPU in the same computers. I use (and will keep using) FF in my main computer but it has 8G of RAM so I never addressed this issue until I had to setup those 2G laptops.
itsbroke 0 solutions 1 answers

Now using Firefox 60, had same problem, found this solution:

goto: about:config

find all instances of: browser.tabs.remote.autostart

set all to false, restart browser

Now Firefox says no multiprocessor support, actually only runs one process seems to run faster and does not use up all my memory!!

Now using Firefox 60, had same problem, found this solution: goto: about:config find all instances of: browser.tabs.remote.autostart set all to false, restart browser Now Firefox says no multiprocessor support, actually only runs one process seems to run faster and does not use up all my memory!!
CrazyGuy 0 solutions 6 answers

itsbroke said

Now using Firefox 60, had same problem, found this solution: goto: about:config find all instances of: browser.tabs.remote.autostart set all to false, restart browser Now Firefox says no multiprocessor support, actually only runs one process seems to run faster and does not use up all my memory!!

No way I'm gonna be messing it like that. Firefox can't make a browser that isn't a resource hog, it's not my job to fix it for them. I'm using Opera now for my main browser. Also have Slimjet installed, both are superior to Firefox.

''itsbroke [[#answer-1117408|said]]'' <blockquote> Now using Firefox 60, had same problem, found this solution: goto: about:config find all instances of: browser.tabs.remote.autostart set all to false, restart browser Now Firefox says no multiprocessor support, actually only runs one process seems to run faster and does not use up all my memory!! </blockquote> No way I'm gonna be messing it like that. Firefox can't make a browser that isn't a resource hog, it's not my job to fix it for them. I'm using Opera now for my main browser. Also have Slimjet installed, both are superior to Firefox.
CrazyGuy 0 solutions 6 answers

delavaca said

Hello, yes that is the first thing I tried. I had also FF for many years in different computers (windows and Linux). So far I have only one extension installed (an ad-blocker) everything else is just a clean installation. I didn't notice this issue until I had to install FF in computers with only 2G of RAM, at first I thought that nowadays 2G is kind of short but what surprised me is that Chrome (with the same extension) was running well using much less RAM and CPU in the same computers. I use (and will keep using) FF in my main computer but it has 8G of RAM so I never addressed this issue until I had to setup those 2G laptops.

Browsers shouldn't use a lot of resources. The fact is you shouldn't need a new pc with a ton of RAM to use a browser comfortably. Having a new computer with 8GB+ of ram isn't an excuse for Mozillia to code a browser that uses more resources. With that mentality we will never get to a point where an application is "light weight" anymore. You should be able to use any browser on an old obsolete pc.

''delavaca [[#answer-1113012|said]]'' <blockquote> Hello, yes that is the first thing I tried. I had also FF for many years in different computers (windows and Linux). So far I have only one extension installed (an ad-blocker) everything else is just a clean installation. I didn't notice this issue until I had to install FF in computers with only 2G of RAM, at first I thought that nowadays 2G is kind of short but what surprised me is that Chrome (with the same extension) was running well using much less RAM and CPU in the same computers. I use (and will keep using) FF in my main computer but it has 8G of RAM so I never addressed this issue until I had to setup those 2G laptops. </blockquote> Browsers shouldn't use a lot of resources. The fact is you shouldn't need a new pc with a ton of RAM to use a browser comfortably. Having a new computer with 8GB+ of ram isn't an excuse for Mozillia to code a browser that uses more resources. With that mentality we will never get to a point where an application is "light weight" anymore. You should be able to use any browser on an old obsolete pc.