Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I disable auto direct to https and allow http?

  • 8 replies
  • 20 have this problem
  • 19203 views
  • Last reply by slreagan

more options

Since the latest Firefox update I am no longer able to use a particular website that I use quite frequently. Having tried it in another browser (Chrome), which directs to http (not https), there is no problem. Firefox will not work and I use Firefox as my default browser and would prefer to keep it that way.

thank you

Chosen solution

Thanks WestEnd - I did contact the site Admin and that is how I found out about the http vs https (and have also let him know what I did to fix it). This site was working with no problems just prior to this last FF update (of the other day) so it had to be that. Once I was able to gain access to the Exception page, everything is fine...I just wish it had been easier to get to that point!  :) If there is a straight-forward way to do this in Options, I could not find it.

Read this answer in context 👍 0

All Replies (8)

more options

Hi slreagan, do you get this error page: "Your connection is not secure" ?

That page often has an indication about whether the site requires HTTPS. Does it state that you cannot add an exception for that reason?

If the site does not REQUIRE a secure connection, hmm, I wonder why Firefox changes the address.

Does it help to follow a link to the HTTP address of the site, or a bookmark for the HTTP address of the site, instead of using the address bar?

Do you use any add-ons which try to upgrade insecure connections to secure ones, such as HTTPS Everywhere? If you have an extension like that, see whether you can make an exception for the site.

more options

Hi jscher2000 - thanks for the reply. I get the message "Secure Connection Failed". I was getting "No Object Found" then for some reason it switched. I have no idea why Firefox is switching to https. On this particular site, when I first go in, it is http, no problem in accessing; I then go to Lectures, again no problem, then go to Search Archive, again no problem in accessing. All of these steps remain at http. But it is when I actually type in a search term (does not matter what it is) that it then switches to https. I have been in touch with the webmaster and he says it should NOT be https, it should be http. When I use Chrome to go thru these exact same steps, no issues whatsoever, it remains at http all the way thru the search term. I have tried switching search engines (I am not sure but think this site uses its own search engine internally) but it makes no difference (I am and have been for a year using DDG; switched back to Google as a test and results the same).

All of this has happened just since the last Firefox update. I was using this site with not issues previously. Oh, and I get the same issue when I try to link into this site from outside, i.e. when someone provides a directly URL link, I get the same access error.

And no add-ons re: security.

I'm certainly no tech person but am rather lost on this...

more options

What security software do you have?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

After several tries I FINALLY got the message "Connection not Secure" so that I could get to the point of excepting this website - it seems to be working ok now. I wish it were easier to get to this point in Firefox if it is going to force you into https.

thank you!

more options

FF only goes to https based on the site security it doesn't create this on it's own. If there is a problem then you need to contact the site and tell them about it.

more options

Chosen Solution

Thanks WestEnd - I did contact the site Admin and that is how I found out about the http vs https (and have also let him know what I did to fix it). This site was working with no problems just prior to this last FF update (of the other day) so it had to be that. Once I was able to gain access to the Exception page, everything is fine...I just wish it had been easier to get to that point!  :) If there is a straight-forward way to do this in Options, I could not find it.

more options

slreagan said

Once I was able to gain access to the Exception page, everything is fine...I just wish it had been easier to get to that point!  :) If there is a straight-forward way to do this in Options, I could not find it.

You should not need to make exceptions for well run sites. If this affects any sites that handle sensitive or personal information, we are happy to help you investigate why Firefox considers your connection to the site suspicious. If security is not important for that site, then it may not be worth further investigation.

more options

Hi jscher2000 - no this site is for research purposes, contains translated lectures of a person long ago dead, one doesn't even have to login to gain access, so no private information is given. And it is pretty much run by a single individual so I'm sure he has issues 'keeping up' with everything. Thanks for the concern - and I certainly DO want security on any site that does require me to give even just my name.