Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hyperlinks in Outlook.com emails do not work after recent Firevox update.

  • 31 replies
  • 65 have this problem
  • 6135 views
  • Last reply by cor-el

more options

Firefox updated. and ever since, hyperlinks in Outlook.com emails do not work. I cleared cache/cookies and rebooted my machine. I then log into my Outlook.com emails and if I open an email with a hyperlink, it will work, but if I try a second email with a hyperlink, it stops working. I have to refresh my browser to be able to click on each hyperlinks. Also, I am not able to highlight any text with my cursor. Help please

Chosen solution

This issue has been fixed with the Firefox 58.0.2 release.

Read this answer in context 👍 2

All Replies (20)

more options

Did you confirm the hyperlink worked or was correct?

more options

Yes, the hyperlinks are correct. For my work, I receive emails with hyperlinks daily from different senders. I am discovering that if I take my cursor and scan over the hyperlink, I will eventually find the spot where the hyperlink is clickable. In other words, a hyperlink should be active at any point that is underlined, but now it appears there is only a small part of the hyperlink that is actually active. This happens within every email, and only started happening today after Firefox updated. This does not happen in Chrome or IE.

more options

I am having this issue as well. Started with the latest update. Every time I click a hyperlink in my Outlook/hotmail it just goes right back to my email inbox. It's maddening! Please help me with a fix and yes, the hyperlink is good!

more options

Patricia5555 said

I am having this issue as well. Started with the latest update. Every time I click a hyperlink in my Outlook/hotmail it just goes right back to my email inbox. It's maddening! Please help me with a fix and yes, the hyperlink is good!

I did discover that the entire hyperlink is not active, but if you use your cursor, and you slowly hover around the hyperlink, you will eventually find a small active clickable part to the hyperlink. Not a great fix, but at least I can get the hyperlink to function. Yes...I know what you mean about the email jumping in and out of messages if the click doesn't work. Very annoying. And I can no longer use my scroll button on my mouse. I have to click on the scroll bar and manually scan an email. Another email issue since the last FF update earlier this week.

more options

Is this with a plain text editor like on this forum or with a rich text editor that allows HTML code?

Can you check the code in the Inspector to see what it looks like?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

If you do not see the Firefox context menu then temporarily set dom.event.contextmenu.enabled to false on the about:config page.

more options

Plain text. Microsoft Outlook/hotmail, using a fairly new MacBook Pro. Afraid I don't know anything about what you are describing. "Inspector"? I'm just, and have always, just used the web to check my mail. I don't use a specific mail program.

more options

I hope you don’t consider this a hijack of this question, if so I’ll move it. I have the same exact issue with Outlook since the latest update. In addition when a reply window is opened up in email the same thing happens when typing is attempted in the message space. In other words when attempting a reply when you try to type text you get blasted back out to the list of emails. So far the reply ends up in drafts and is not completely lost. This deposit of the reply into the drafts folder is useful since the problem with the reply is random and can happen after a lot of text has been typed.

more options

pjd813 said

I hope you don’t consider this a hijack of this question, if so I’ll move it. I have the same exact issue with Outlook since the latest update. In addition when a reply window is opened up in email the same thing happens when typing is attempted in the message space. In other words when attempting a reply when you try to type text you get blasted back out to the list of emails. So far the reply ends up in drafts and is not completely lost. This deposit of the reply into the drafts folder is useful since the problem with the reply is random and can happen after a lot of text has been typed.

Same thing here. The last FF update messed up how Outlook.com emails function.

more options

cor-el said

Is this with a plain text editor like on this forum or with a rich text editor that allows HTML code? Can you check the code in the Inspector to see what it looks like? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. If you do not see the Firefox context menu then temporarily set dom.event.contextmenu.enabled to false on the about:config page.

This answer is way out of my league. I'm not sure how to implement any of these instructions. Most of us on this forum are just average users of the FF browser. The latest FF update affected how Outlook.com (hotmail) operates, and hyperlinks within emails are not active. Sometimes, if you hover over the hyperlink you can find a small portion of the underlined link that is clickable. Other times, the hyperlink is dead and not clickable. Good example, I am receiving emailed updates about this thread, but the hyperlinks will not work to be directed to this forum. I have to find the forum in a separate tab to view the comments and reply. Ugh

more options

This issue as I understand it does not involve an external editor. This problem occurs within Hotmail/Outlook using the normal link clicks within emails and reply message functions within Outlook.

more options

ORIGINAL POST

Outlook has a "Reading Pane" you can show on the right side of the Inbox. In that case, when you click a message, it displays on the side. (Example screenshot attached.)

If you hide the Reading Pane, then the message appears in front of the Inbox.

In Firefox 58, there is some strange problem with links that appear in front of text in the Inbox list. A click in that area (on a link or even on the message background) seems to "pass through" to the Inbox and select a different message instead of being received by the currently displayed message. It doesn't happen on every message, but once it starts happening, it seems to keep happening. I don't know why.

When I switch to the "beta" Outlook design, I cannot replicate this problem. It seems to work fine.

Two thoughts:

(1) If you have a wide display, you could try using the Reading pane on the right. However, if your display is not wide enough, there will be an inconvenient amount of horizontal scrolling. Also, you see a smaller section of your Inbox.

(2) You could try sliding the "Try the beta" switch that appears above the Inbox and see whether that works better for you.

Do either of those workarounds help?


UPDATE

This problem should be fixed in the next Firefox 58 update -- mid- to late February. Here is another workaround -- it uses older layout code for the outlook.live.com site:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste stylo and pause while the list is filtered

(C) Double-click the layout.css.stylo-blocklist.enabled preference to switch the value from false to true

(D) Double-click the layout.css.stylo-blocklist.blocked_domains preference and set the value to live.com and click OK. (In the unlikely event that you already had one or more sites listed add ,live.com to the list.)

Then exit/quit Firefox and start it up again to make the change effective.

Modified by jscher2000

more options

Thanks for the info, but #1 doesn't work for me because it's not a large enough viewing area.

  1. 2 -- not sure about beta testing. I just wish that FF would fix what they broke in hotmail/outlook, and go back to the way it was...which was working. :(
more options

Hi lisapar, I filed a formal bug report, but I don't know how soon they'll figure out the precise thing that needs to be changed.

Two other things that might help for now:

(1) If you are reading messages consecutively, instead of closing and re-opening, use the up and down arrows above the current message.

(2) When you notice the problem in the current message, use zoom (for example, Ctrl+ then Ctrl- or hold down Ctrl and ease the mouse scroll wheel forward or back one click) to fix the click/scroll behavior for the current message. It only lasts until you close the message, but using the up and down arrows will extend the effect.

more options

I have the same problem with the links within a Outlook.com email. The links are good but the entire length of the link is not responding. Also sometimes when clicking on a link or a preview picture attachment it sends me back to the inbox. Scrolling using mouse wheel within the emails is intermittent too. These problems happen in private and non private FF browser modes. I noticed when removing the bookmark sidebar all mentioned problems disappear. By changing the zoom - + seems to fix the problem too. ,There are no issues using the Chrome browser. Hope this aids in the fix. v58.0 (64bit).

Modified by jorb

more options

See also comment 8 and comment 9:

  • bug 1433591#c8 - Links and text selection in Outlook messages broken, mouse action received by Inbox behind open message

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Hello all

I am using Windows 8.1 -- with all upgrades -

AND I also have the same problems as listed by people above --Since about Jan 25, 2018, after a week-ago Firefox automatic update

In trying to open hyperlinks on incoming (Outlook-MSN) emails takes me back to either my inbox page or to (opens up) a completely unrelated earlier different unrelated email.

Same thing for trying to open or SAVE a photo on the email -- the drop down menu-choices panel does not show up and I get diverted back to emails inbox page !. What a royal P I T A !!

AND the cursor can't highlight or copy any text on the new email.

This does NOT happen in my Outlook Mail on my latest versions of Internet Explorer --- or Google Chrome where my Outlook mail is saved as a favorite LINK (just as it is saved as a Favorite LINK in Firefox)

So what is NOW going wrong with Firefox - always something - usually AFTER a new upgrade arrives.

more options

pjd813 stated: -- ........... "I hope you don’t consider this a hijack of this question, if so I’ll move it. I have the same exact issue with Outlook since the latest update. In addition when a reply window is opened up in email the same thing happens when typing is attempted in the message space. In other words when attempting a reply when you try to type text you get blasted back out to the list of emails. So far the reply ends up in drafts and is not completely lost. This deposit of the reply into the drafts folder is useful since the problem with the reply is random and can happen after a lot of text has been typed....."


And I am also likewise having the same that pjd813 stated above, in addition to the other listed above

HEY - FIREFOX STAFF -- most of us posting problem-related-issues here are NOT highly skilled cyber system repair technicians regarding some of the geek speak provided here for "how to fix" -- so how about FIREFOX ITSELF correcting the problems that their NEW updates cause us !! I think most of us here agree with that !

Modified by Joseph_Frank

more options

Ok Readers

A few minutes after i posted my problem issues above, I did the following:

Here is what I did -- and any of you can do the same step by step -- AND this "seems" to have FIXED the Outlook issues. -- I AM however, holding my breath, tho (heh!) -- but so far so good now.

(1) -- Open a new TAB on your Firefox Browser

(2) -- type into the address bar at page top the words about:config

(3) -- click the ENTER key on your keyboard

(4) -- a page now comes up with " THIS MIGHT VOID YOUR WARRANTY ! "

(5) -- CLICK on to the BLUE PANEL stating " I ACCEPT THE RISK "

(6) -- a Firefox "about:config' page now comes up with a huge volume of files, all in ALPHABETICAL order at left under the heading at their top PREFERENCE NAME

(7) -- scroll down until you get to the files staring with " d " and SLOWLY move to the section with files starting with " dom" and find the 38th file line down under "dom" that reads ...

dom.event.context.menu

(8) --You see 3 columns at right -- the last column likely shows the word " true ". If it does, RIGHT-CLICK your mouse with it's CURSOR OVER the over the word " true " on the program file name

(9) -- You should get a small popup box panel which has at top, the word TOGGLE

(10) -- Now, with your mouse CURSOR over the word " true " , you then LEFT CLICK your mouse

(11) -- The word " true" should change to " false"

(12) -- close (depart from) that " about:config" page -- and go to RESTART your computer.

That is what I did, in that order, and after my computer re-started and I went to Firefox and opened my Outlook Mail, all my problem issues in Outlook Mail in FIREFOX browser -- (yeah, I did extensive check-testing on emails in Outlook) seem to be ALL FIXED (holding my breath anyway).

So -- please try this 12 step by step process CAREFULLY -- it should work for you. Let me / us know here how you make out.

Regards - Joe F

Modified by Joseph_Frank

more options

Hello ALL AGAIN

Well, it was TOO GOOD to be TRUE -- but ......

....after about 10 minutes or so of working fine, my OUTLOOK MAIL problems on Firefox Browser (like all other experiences, listed above) RETURNED -- even after the 12 steps I took as I outlined above.

Occasional random and rare intermittent spurts of working properly, then mostly back to not working properly at all.

So FIREFOX TECH PEOPLE (owners, whomever) -- Its your responsibility and YOUR BALLGAME to fix this problem. Its way above the abilities of the majority of your customer base users.

I will just have to start more regularly using the more reliable GOOGLE Chrome - and Internet Explorer - to avoid these OUTLOOK Mail nuisance issues on Firefox.

Modified by Joseph_Frank

more options

Though it seems like a small problem in the scheme of "things", I don't have a lot of time on my hands, nor tech savvy to fix this. My solution was to download the latest version of Google Chrome. Thanks for all the hints here, peeps. Moving on.

  1. 1
  2. 2