Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No sound on Youtube only with Firefox browser - problem started today. Other browsers are OK.

  • 5 replies
  • 8 have this problem
  • 7799 views
  • Last reply by Pj

more options

Starting today when I bring up any video on Youtube there is no sound. This problem is ONLY on Youtube. Audio is fine on all other sights. When I finally got the Yahoo Browser up, audio on Youtube is OK. Only on Firefox is there no audio on Youtube ONLY. All else has audio on Firefox as normal.

Starting today when I bring up any video on Youtube there is no sound. This problem is ONLY on Youtube. Audio is fine on all other sights. When I finally got the Yahoo Browser up, audio on Youtube is OK. Only on Firefox is there no audio on Youtube ONLY. All else has audio on Firefox as normal.

Chosen solution

Hello,

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Read this answer in context 👍 1

All Replies (5)

more options

What FF vesion and the link to the video? That way other can test if the problem is a isolate problem or something else. And I have FF57.0.4x64 and can run and watch youtubbes on IE11, Edge, Chrome, and last FF without problems.

more options

Chosen Solution

Hello,

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

For the most part I left default settings and had no issues with youtubbers video from any of the Browers. It also could be due to a corrupt FF install since a x86 can't access as much ram as a x64 isn't Ram restricted. But knowing what O/S if x86 or x64 and if they have a GPU dedicate or not would help to narrow where the problem is coming from. But I have W10 FCU x64 with FF57.0.4x64 and Chrome and IE11, Edge and those have no problem with audio or video. So unless we can get more settings specs I don't think it is from FF. But also if your Audio is on-board rather then dedicate Audio Card and having more RAM helps apps work better as well. I got 16gb of DDR4.

more options

I tried the solution above to "no sound in YouTube" that you proposed, but it did not work. No change. I am running FF 57.0.4 on an iMac running OS x 10.10.4. I first experienced the "no sound in YouTube" problem in my previous version (not sure which), which caused me to upgrade to 57.0.4. Sounds in Safari work fine.

more options

MIDIGerbil said

.

I had this problem also, months ago, but only once. A FF shutdown and restart fixed it. Haven't had a repeat of the problem yet.

-Pj