Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Developer Edition cannot use the profile “default” because it is in use.

  • 6 replies
  • 1 has this problem
  • 20 views
  • Last reply by cor-el

more options

I have configured firefox (dev edition 58.0b14 (64-bit) on windows) to use multiple profiles, so now when launching firefox it asks which profile I want to use. It generally works good but I have an issue when I click on some link outside browser (like in battle.net, visual studio, etc.). After I click the link it presents me with "Choose User Profile" window to select the profile with which to open link. If I click on the profile that I am currently using I get an error "Firefox Developer Edition cannot use the profile “default” because it is in use. To continue, close the running instance of Firefox Developer Edition or choose a different profile." and I get back too "Choose User Profile" window. The behavior I expect is that after choosing the profile a new tab would open in selected "instance" of firefox like it does if only a single profile exists.

All Replies (6)

more options

Hi, go to about:preferences and check the option that says 'Allow Developer Edition to Run Alongside Firefox' -- This will stop this from happening again.

Modified by Mkll

more options

Hi Mkll, "Allow Firefox Developer Edition and Firefox to run at the same time" is already checked.

more options

Make sure you use dev-edition-default as the profile for Developer Edition!

more options

I have tried to reproduce this on other machine and I think this happens because I am launching firefox with -no-remote flag. So, the exact step to reproduce this behavior: 1. Create two profiles named A and B. 2. Launch firefox with -no-remote flag and open firefox with profile A (might need to use -P flag to see profile select window). 3. Click on a link somewhere outside the browser (pdf file, outlook and so on). This should open profile select window again. 4. Select profile A and click on start firefox. This should throw "Firefox Developer Edition cannot use the profile “profileA” because it is in use. To continue, close the running instance of Firefox Developer Edition or choose a different profile."

Again, the result that I expect: after choosing the profile, link should be opened in the new tab of selected profile (in this case in profileA).

I guess the issue is the -no-remote flag and removing it would fix the issue. I am using this flag so that I would be able to run multiple firefox instances at the same time and that each instance could use a different profile. I am not sure if this is the best way to do that but it is the only one I found. I need to be able to do that, so I can't just remove -no-remote flag, but not being able to open links with a running profile is really annoying.

more options

Any ideas?

more options

You can't open external links in a Firefox instance started with the -no-remote switch. You have to omit this switch from the profile you want to open external links in and only use -no-remote to open extra profiles. That is how -no-remote works: it makes the Firefox instance invisible. You can drag a link to such an instance (e.g. to the new tab + button) as a workaround.