X
Tap here to go to the mobile version of the site.

Support Forum

how do i disable the developer tools in firefox 57

Posted

every time i use the shift button for anything / at any and all websites, the scratchpad pops up-- and i cannot continue whatever i was doing. i would like to know how to disable these developer tools as i have no use for them ... please help. this bug is driving me to think of just giving up on firefox completely. i can't post, write properly, even punctuation is affected. which is why this is written all in lower case 'exclamation point'

every time i use the shift button for anything / at any and all websites, the scratchpad pops up-- and i cannot continue whatever i was doing. i would like to know how to disable these developer tools as i have no use for them ... please help. this bug is driving me to think of just giving up on firefox completely. i can't post, write properly, even punctuation is affected. which is why this is written all in lower case 'exclamation point'

Chosen solution

Hi, try: Type about:config into the address bar, press Enter, accept the warning, scroll down to devtools.scratchpad.enabled and double click on it to change 'Value' from True to False, then restart Firefox.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Scribe 683 solutions 3292 answers

Chosen Solution

Hi, try: Type about:config into the address bar, press Enter, accept the warning, scroll down to devtools.scratchpad.enabled and double click on it to change 'Value' from True to False, then restart Firefox.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Hi, try: Type '''about:config''' into the address bar, press Enter, accept the warning, scroll down to '''devtools.scratchpad.enabled''' and double click on it to change 'Value' from True to False, then restart Firefox. ''If your question is resolved by this or another answer, please take a minute to let us know. Thank you!''
cor-el
  • Top 10 Contributor
  • Moderator
16395 solutions 147930 answers

The Scratchpad opens with the Ctrl+F4 shortcut. If in your case Shift is sufficient then it sounds that you have a problem with your keyboard and have a sticky F4 key or use some macro software that emulates F4. Is some cases it helps to press affected keys that appear sticky a few time to see if that reset the key down state. If that doesn't help then close and restart Firefox or reboot.

The Scratchpad opens with the Ctrl+F4 shortcut. If in your case Shift is sufficient then it sounds that you have a problem with your keyboard and have a sticky F4 key or use some macro software that emulates F4. Is some cases it helps to press affected keys that appear sticky a few time to see if that reset the key down state. If that doesn't help then close and restart Firefox or reboot.