Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook newsfeed not working correctly

  • 4 replies
  • 34 have this problem
  • 4857 views
  • Last reply by jscher2000

more options

I noticed this morning that Firefox updated. My facebook feed today has been very odd: It flashes all the stories by without stopping, no matter if I choose "Top" or "Most Recent." Eventually I get a blank/empty feed. If I go to my "home" it's normal. Any suggestions? Doesn’t happen in Safari—Facebook is normal there.

Chosen solution

Update: There is a fix for uBlock Origin filters to address this problem if yours is caused by that extension. See: https://www.reddit.com/r/uBlockOrigin/comments/7mxddl/facebook_newsfeed_going_crazy_when_ublock_on/drxioqo/


I wonder if you have tried "the usual":

If a site is generally known to work in Firefox, these are general suggestions to try when it stops working correctly:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Command+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Read this answer in context 👍 2

All Replies (4)

more options

Please Refresh but do this 1st:

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Please let us know if this solved your issue or if need further assistance.

more options

Chosen Solution

Update: There is a fix for uBlock Origin filters to address this problem if yours is caused by that extension. See: https://www.reddit.com/r/uBlockOrigin/comments/7mxddl/facebook_newsfeed_going_crazy_when_ublock_on/drxioqo/


I wonder if you have tried "the usual":

If a site is generally known to work in Firefox, these are general suggestions to try when it stops working correctly:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Command+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Modified by jscher2000

more options

I rebooted Firefox to Safe mode. That solved the Facebook issue. So I figured I'd check my extensions one by one (only had 3). The culprit turned out to be the uBlock ad blocker. I reckon I'll need a different ad blocker. Thank you!

more options

The developer of uBlock Origin is very attentive to user issues. Maybe keep an eye on this reddit thread for updates:

Facebook newsfeed going crazy when uBlock On