Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox tries to resolve DNS before using /etc/hosts

  • 3 replies
  • 12 have this problem
  • 2875 views
  • Last reply by qshan

more options

entries in /etc/hosts that are not real (e.g. notrealsubdomain.example.com) work. If I try to point e.g. example.com to 127.0.0.1 it is ignored and the "real" resolution is used. Entries in /etc/hosts should have the highest priority. Also, I've tried every recommended solution by modifying settings in about:config.

Modified by qshan

Chosen solution

It started working for me, I'm not really sure why. Thank you for the detailed responses!

Read this answer in context 👍 0

All Replies (3)

more options

No idea what you have done : I've tried every recommended solution by modifying settings in about:config.

Refresh and make a new Profile, contact back before playing in about : config please if still have issues.

Please Refresh but do this 1st:

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Please let us know if this solved your issue or if need further assistance.

more options

It should work.

Did you clear Firefox's cache between changes?

You can use the steps in this article: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Command+r to check progress.

Do you use a proxy that may change the normal DNS resolution behavior?

You can check that here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your OS setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?

Past Threads

These may be one-offs, but in case they're helpful:

more options

Chosen Solution

It started working for me, I'm not really sure why. Thank you for the detailed responses!