Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When launching Firefox, it no longer automatically opens with tabs from the previous session - how do I fix that?

  • 2 replies
  • 3 have this problem
  • 1 view
  • Last reply by cor-el

more options

I've read and tried some of the suggested posts on this topic. When I launch Firefox after it's been shut down, it still opens with only one tab, the Firefox default search page (instead of my home page which I've already posted regarding), instead of automatically loading tabs from the previous session. I know I can manually do a "restore previous session" but don't want the hassle of having to do that every time I launch Firefox.

  Any suggestions?
  Thanks!

Chosen solution

Did you check the startup setting?

You can check the startup setting.

  • Options/Preferences -> General -> Startup: "When Firefox starts":
    "Show my windows and tabs from last time"
    "Show my home page"
    "Show a blank page"
Read this answer in context 👍 0

All Replies (2)

more options

Please Refresh but do this 1st:

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Please update your Flash, it is a Security Risk. Flash Player Version: 28.0.0.126 Current Version

Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Please let us know if this solved your issue or if need further assistance.

more options

Chosen Solution

Did you check the startup setting?

You can check the startup setting.

  • Options/Preferences -> General -> Startup: "When Firefox starts":
    "Show my windows and tabs from last time"
    "Show my home page"
    "Show a blank page"