X
Tap here to go to the mobile version of the site.

Support Forum

How Do I Remove Application from Mailto Options List

Posted

There is an application listed in the list of launch application option for mailto that I would like to remove. I've tried the following:

Options, General, Applicaton, mailto then Select application to remove. Select application details. Select Remove Select Okay

The application appear to be removed, but the next time the launch mailto application dialog is called up, the removed application remains in options list. How do I remove this application from the list?

There is an application listed in the list of launch application option for mailto that I would like to remove. I've tried the following: Options, General, Applicaton, mailto then Select application to remove. Select application details. Select Remove Select Okay The application appear to be removed, but the next time the launch mailto application dialog is called up, the removed application remains in options list. How do I remove this application from the list?

Chosen solution

Okay, the following rather convoluted process finally worked for me.

about:preferences Applications, mailto: Select the unwanted application from the Action dropdown list. Select the Action dropdown again, but this time choose "Application Details..." Select "Remove" on the details popup. Select "Ok"

This is where I expected to be done in the past, but that didn't work, so keep going. At this point, my Action dropdown shows 'Always Ask'.

Select the Action dropdown again, and select another specific application, (not 'Always Ask'). Close about:preferences Restart Firefox

Finally the undesired application is removed, though interestingly the just selected application above is replaced again by 'Always Ask'.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

RichardInEngland 11 solutions 66 answers

Helpful Reply

Hi @rsf64. I have just been trying different things with the mailto "Content Type" and agree that an application that you have removed can come back again (although not in every case, it seems).

What I did was add a new program for the "Action", actually Thunderbird, which I had to browse for the executable file for. I then deleted the other ones, Yahoo! Mail and Windows Live Mail and restarted Firefox. I then deleted Thunderbird too (leaving the "Action" as "Always ask") and restarted Firefox again. When looking at the "Action" list again, I have these options:

  • Always ask <--- this was still set as the "Action"
  • Use Windows Live Mail (default)
  • Use Thunderbird
  • Use other...

I can understand how the Windows Live Mail magically re-appears as an option, as it is currently set as the default program for main under my Windows 10. As far as I am concerned, the Thunderbird should not re-appear after I have deleted it via the Application Detail... and Remove buttons.

It does look like a bug, but may I ask, why in particular are you wishing to delete a particular application/program from the list?

As long as you have selected the correct program for Use <whatever>, or are happy to use the Always ask option, it should do what you want, as I have seen no evidence that Firefox changes what you have set (even if it does not remove the erroneous options).

Yes, I could report the problem as a bug, but is there something that you are not able to do at the moment (other than deleting an unwanted program from the options)?

Hi @rsf64. I have just been trying different things with the mailto "Content Type" and agree that an application that you have removed can come back again (although not in every case, it seems). What I did was add a new program for the "'''Action'''", actually '''Thunderbird''', which I had to browse for the executable file for. I then deleted the other ones, '''Yahoo! Mail '''and '''Windows Live Mail '''and restarted Firefox. I then deleted '''Thunderbird '''too (leaving the "Action" as "'''Always ask'''") and restarted Firefox again. When looking at the "Action" list again, I have these options: * Always ask <--- this was still set as the "Action" * Use Windows Live Mail (default) * Use Thunderbird * Use other... I can understand how the '''Windows Live Mail '''magically re-appears as an option, as it is currently set as the default program for main under my Windows 10. As far as I am concerned, the '''Thunderbird '''should not re-appear after I have deleted it via the '''Application Detail... '''and '''Remove '''buttons. It does look like a bug, but may I ask, why in particular are you wishing to delete a particular application/program from the list? As long as you have selected the correct program for '''Use <whatever>''', or are happy to use the '''Always ask '''option, it should do what you want, as I have seen no evidence that Firefox changes what you have set (even if it does not remove the erroneous options). Yes, I could report the problem as a bug, but is there something that you are not able to do at the moment (other than deleting an unwanted program from the options)?

Question owner

Richard, thanks for looking into this. The added application is not a mail application so is simply not appropriate for the list. As you noted, it does not cause any real problem, but it would be nice to have the bug fixed so the list can be cleaned up. Thanks again for checking.

Richard, thanks for looking into this. The added application is not a mail application so is simply not appropriate for the list. As you noted, it does not cause any real problem, but it would be nice to have the bug fixed so the list can be cleaned up. Thanks again for checking.
RichardInEngland 11 solutions 66 answers

Hi again. I have been rooting around all kinds of things including looking at mailto bugs listed in Mozilla's Bugzilla. I did not find anything related to this issue.

I am using a different PC from my testing last night and tried again to reproduce the problem, but failed. In my last post I said:

As far as I am concerned, the Thunderbird should not re-appear after I have deleted it via the Application Detail... and Remove buttons.

From my repetitive testing again today, I have found that if I just use the Remove button in the Application details dialog box, the displayed application does disappear, but then:

  1. If I then either X out of the dialog box, or click Cancel, then check the drop-down list again, the application is still there.
  2. If I click the OK button to close the dialog box, then check the drop-down list again, the application has gone.

This is the expected result, so no bug found. I thought that I had clicked the OK button yesterday after doing the remove, but perhaps I did not?

Your original report states "Select Remove Select Okay", so you obviously thought you had clicked the OK button too, so it is all very strange. I wonder if you would mind trying again?

If it turns out to be an intermittent problem, then it would be a lot harder to track what is going wrong if it is not consistently reproducible.

I am not happy about the way that the Application details dialog box works anyway, as when you first bring it up and it lists an application, there is no method to select a different one. In my testing, I added Notepad as an application, but I then could not delete it without deleting my entry for Thunderbird first, then deleting the Notepad entry, which meant that I had to use the Use other.. action again to browse to the executable and add Thunderbird back. This could possibly be considered poor functionality, rather than a bug, but still...

Thanks... Richard.

Hi again. I have been rooting around all kinds of things including looking at '''mailto '''bugs listed in Mozilla's Bugzilla. I did not find anything related to this issue. I am using a different PC from my testing last night and tried again to reproduce the problem, but failed. In my last post I said: <blockquote> As far as I am concerned, the Thunderbird should not re-appear after I have deleted it via the Application Detail... and Remove buttons. </blockquote> From my repetitive testing again today, I have found that if I just use the '''Remove '''button in the '''Application details '''dialog box, the displayed application does disappear, but then: # If I then either '''X out '''of the dialog box, or click '''Cancel''', then check the drop-down list again, ''the application is still there.'' # If I click the '''OK '''button to close the dialog box, then check the drop-down list again, ''the application has gone''. This is the expected result, so no bug found. I ''thought ''that I had clicked the OK button yesterday after doing the remove, but perhaps I did not? Your original report states "''Select Remove Select Okay''", so you obviously thought you had clicked the OK button too, so it is all very strange. I wonder if you would mind trying again? If it turns out to be an intermittent problem, then it would be a lot harder to track what is going wrong if it is not consistently reproducible. I am not happy about the way that the '''Application details '''dialog box works anyway, as when you first bring it up and it lists an application, there is no method to select a different one. In my testing, I added '''Notepad '''as an application, but I then could not delete it without deleting my entry for '''Thunderbird '''first, then deleting the '''Notepad '''entry, which meant that I had to use the '''Use other.. '''action again to browse to the executable and add '''Thunderbird''' back. This could possibly be considered poor functionality, rather than a bug, but still... Thanks... Richard.
cor-el
  • Top 10 Contributor
  • Moderator
16564 solutions 149546 answers

Try to rename/remove handlers.json file and remove the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Try to rename/remove handlers.json file and remove the mimeTypes.rdf file in the Firefox profile folder to reset all file actions. *http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

@Richard: I did try again and definitely selected "OK" after "Remove" but the application still appears in the list.

@cor-el: Thanks for the suggestion. I followed all the steps in your first link but the application still appears in the list.

@Richard: I did try again and definitely selected "OK" after "Remove" but the application still appears in the list. @cor-el: Thanks for the suggestion. I followed all the steps in your first link but the application still appears in the list.
cor-el
  • Top 10 Contributor
  • Moderator
16564 solutions 149546 answers

Maybe check the gecko.handlerService.schemes.mailto.* prefs on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Maybe check the <b>gecko.handlerService.schemes.mailto.*</b> prefs on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config

Question owner

@cor-el, I checked gecko.handlerService.schemes.mailto.* and found two recognizable entries. For two more entries though, both the .name and .uriTemplate have values of: "chrome://browser-region/locale/region.properties". Does this refer to a file in some location I can inspect?

@cor-el, I checked gecko.handlerService.schemes.mailto.* and found two recognizable entries. For two more entries though, both the .name and .uriTemplate have values of: "chrome://browser-region/locale/region.properties". Does this refer to a file in some location I can inspect?
cor-el
  • Top 10 Contributor
  • Moderator
16564 solutions 149546 answers

Helpful Reply

The "chrome://browser-region/locale/region.properties" value indicate that the pref is a complex pref that can be localized depending in what region you live. Firefox normally doesn't show this specific text, but a pref like browser.startup.homepage is another example.

This is a builtin file and you can inspect it via the location/address bar.

  • view-source:chrome://browser-region/locale/region.properties

Firefox uses the "chrome://" protocol to access its own internal files and also access files from extensions (no relation with Google Chrome).

The "chrome://browser-region/locale/region.properties" value indicate that the pref is a complex pref that can be localized depending in what region you live. Firefox normally doesn't show this specific text, but a pref like browser.startup.homepage is another example. This is a builtin file and you can inspect it via the location/address bar. *view-source:chrome://browser-region/locale/region.properties Firefox uses the "chrome://" protocol to access its own internal files and also access files from extensions (no relation with Google Chrome).

Question owner

@cor-el, Thanks. Very helpful info on how to view the file. Interestingly though, the file only lists the two recognizable entries for the mailto handler in about:config gecko.handlerService.schemes.mailto.*. The file does not list any additional entries which I had sort of expected to see corresponding to the two additional, unidentified entries in about:config gecko.handlerService.schemes.mailto.*. My only thought is to delete those two extra (?) entries in about:config gecko.handlerService.schemes.mailto.*, but I'm hesitant to do that without being certain of exactly what I would be deleting. As discussed with RichardInEngland, the issue is not causing problems; it is just kind of annoying. I certainly don't want to break something else for a mere annoyance. Still, it sounds like a possible bug, so I hope it will get fixed at some point.

@cor-el, Thanks. Very helpful info on how to view the file. Interestingly though, the file only lists the two recognizable entries for the mailto handler in about:config gecko.handlerService.schemes.mailto.*. The file does not list any additional entries which I had sort of expected to see corresponding to the two additional, unidentified entries in about:config gecko.handlerService.schemes.mailto.*. My only thought is to delete those two extra (?) entries in about:config gecko.handlerService.schemes.mailto.*, but I'm hesitant to do that without being certain of exactly what I would be deleting. As discussed with RichardInEngland, the issue is not causing problems; it is just kind of annoying. I certainly don't want to break something else for a mere annoyance. Still, it sounds like a possible bug, so I hope it will get fixed at some point.

Chosen Solution

Okay, the following rather convoluted process finally worked for me.

about:preferences Applications, mailto: Select the unwanted application from the Action dropdown list. Select the Action dropdown again, but this time choose "Application Details..." Select "Remove" on the details popup. Select "Ok"

This is where I expected to be done in the past, but that didn't work, so keep going. At this point, my Action dropdown shows 'Always Ask'.

Select the Action dropdown again, and select another specific application, (not 'Always Ask'). Close about:preferences Restart Firefox

Finally the undesired application is removed, though interestingly the just selected application above is replaced again by 'Always Ask'.

Okay, the following rather convoluted process finally worked for me. about:preferences Applications, mailto: Select the unwanted application from the Action dropdown list. Select the Action dropdown again, but this time choose "Application Details..." Select "Remove" on the details popup. Select "Ok" This is where I expected to be done in the past, but that didn't work, so keep going. At this point, my Action dropdown shows 'Always Ask'. Select the Action dropdown again, and select another specific application, (not 'Always Ask'). Close about:preferences Restart Firefox Finally the undesired application is removed, though interestingly the just selected application above is replaced again by 'Always Ask'.