Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Webnotifications are OFF in about:config, but still getting requests

  • 3 replies
  • 1 has this problem
  • 4 views
  • Last reply by Shadow110

more options

I have dom.webnotifications.enabled set to false. I still see requests for web notifications. These are BEYOND annoying. How do I turn them off? See attached image.

(Typical sequence for opening an article at a news site - 1. Close request for email address for newsletter subscription. 2. Close request of for push notifications. 3. read article. At least turning off autoplay for all videos works.)

Attached screenshots

All Replies (3)

more options

Not so sure those work any more as can tell.

Copy/Paste about:preferences#privacy into the Address Bar then Enter. Go down to Permissions. Block everything listed under those headings when they open. Best to block instead of delete or possibly be doing this again.

Please let us know if this solved your issue or if need further assistance.

more options

Preferences do not work. The whitelist of permitted websites only says who is allowed. If they are not in the whitelist they ASK. Every. Time. And new sites ask the first time they come up.

"Do Not Disturb" use is per session. Which means I have to update the permission Every. Time. I. Use. Firefox.

The about:config settings should be reinstated.

Let me be clear.

I never will allow a website to send push notifications. Whoever thought this was good idea probably works for a marketing company.

Modified by DebraBk

more options

Think you had a bad update that caused this as I never get notifications or once or so did for awhile and told it never. Not seen since.

Try this please : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note should be run weekly & Pinned) Then run it again and click the button that says Cleanup System Files. ( if never run the Cleanup System Files before you will have 100's of gigs to delete, may take awhile or seem like it is locked up and if is a old system it can sometimes do that.) Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Reinstall with Current Release Firefox 57.0.1 with a Full Version Installer https://www.mozilla.org/firefox/all/

If still have issues then it is in your Profile : https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles and https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile

Please let us know if this solved your issue or if need further assistance.