Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox shows up in processes, but wont open even after fresh install. What to do?

more options

after my pc restarted abruptly, I tried opening Firefox but it just will not open. It shows up in processes but never opens. I have fresh installed, I have downloaded the newest verison, ran it as an admin and still nothing. I was wondering if anyone could help me with this?

All Replies (2)

more options

Hi PeterDanklage

  1. Just to be 100% clear, what version of Firefox are you using? Is it Firefox 57 Quantum that you did a fresh install on?
  2. What operating system are you using? Windows 10?
  3. Have you tried disabling all your Firefox add-ons? In Tools->Add-ons
  4. If that doesn't work please try Firefox safe mode. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
  5. If that doesn't work, please let us know what you did, what you expected, what happened in more detail (e.g. posting a screenshot of the Windows task manager or the OSX activity manager always helps when firefox crashes or hangs! and if it's a crash, posting the crashes in about:crashes would help)
more options

1. Yes, Quantum 57 2. Windows 10 3. I cant because I cant open firefox 4. Firefox wont open at all so I cant do it. 5. It never crashes, it just loads the process in the task manager and never loads the actual application. I have ran it as an admin before reinstall but nothing happened and I have fresh installed and ran as admin and nothing still happened.