X
Tap here to go to the mobile version of the site.

Support Forum

Several Google fonts not working in Firefox 57

Posted

Having a problem with several Google fonts not loading in Firefox 57, when they worked in 56. Tried importing the font into the style sheet and calling external stylesheet in head. Same result. No errors in Web Console to indicate a problem loading.

However, it does seem isolated to specific fonts because some don't work, and others do work.

Any ideas? I'm on Windows 7 64bit, with Firefox 57.

Having a problem with several Google fonts not loading in Firefox 57, when they worked in 56. Tried importing the font into the style sheet and calling external stylesheet in head. Same result. No errors in Web Console to indicate a problem loading. However, it does seem isolated to specific fonts because some don't work, and others do work. Any ideas? I'm on Windows 7 64bit, with Firefox 57.

Chosen solution

This problem was solved by adjusting the Firefox config.

--- If locally installed fonts aren't working then this is likely a sandbox security issue. You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. --

As discussed [https://support.mozilla.org/en-US/que.../1187672]

Read this answer in context 11

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Question owner

Well, turns out it is because I have the same font installed locally on my system. Some of the Google fonts don't work as Web fonts in Firefox 57 when installed on the system.

I never had this problem in Firefox 56. Must be something about how Firefox handles fonts? Same font's work fine in other browsers.

Maybe this will help someone else. Thanks

Well, turns out it is because I have the same font installed locally on my system. Some of the Google fonts don't work as Web fonts in Firefox 57 when installed on the system. I never had this problem in Firefox 56. Must be something about how Firefox handles fonts? Same font's work fine in other browsers. Maybe this will help someone else. Thanks

Chosen Solution

This problem was solved by adjusting the Firefox config.

--- If locally installed fonts aren't working then this is likely a sandbox security issue. You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. --

As discussed [https://support.mozilla.org/en-US/que.../1187672]

This problem was solved by adjusting the Firefox config. --- If locally installed fonts aren't working then this is likely a sandbox security issue. You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting. * security.sandbox.content.level = 1 * close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. -- As discussed [[https://support.mozilla.org/en-US/questions/1187672]]

Modified by cor-el

cor-el
  • Top 10 Contributor
  • Moderator
16789 solutions 151720 answers

What sandbox setting worked for you?

Was the '2' setting sufficient?

What sandbox setting worked for you? Was the '2' setting sufficient?

Helpful Reply

Forgot to mention that.

I set it to '2' (from '3') and that fixed the problem completely with all Google fonts.

Thanks for your help.

Forgot to mention that. I set it to '2' (from '3') and that fixed the problem completely with all Google fonts. Thanks for your help.
cor-el
  • Top 10 Contributor
  • Moderator
16789 solutions 151720 answers

You're welcome and thanks for confirming that 2 works.

You're welcome and thanks for confirming that 2 works.
LMH77 0 solutions 12 answers

Helpful Reply

This is fine for an individual to change their settings when they notice pages aren't displaying correctly (if they realize something is wrong and the page isn't just designed terrible) but it has a big effect as a developer, we can't tell people to go change their firefox settings so they will see our page as it was designed to be.

This is fine for an individual to change their settings when they notice pages aren't displaying correctly (if they realize something is wrong and the page isn't just designed terrible) but it has a big effect as a developer, we can't tell people to go change their firefox settings so they will see our page as it was designed to be.

Question owner

I completely agree with LMH77. Most people wouldn't know there is a problem and wouldn't know to configure their browser.

But after mentioning this problem on Mozilla and Google Font forums, this the only answer I got that worked.

The only alternative I can see is choosing one of the select Google fonts that still works when not changing Firefox configuration. Or that most people don't have the Google font installed locally, so they will see it correctly.

All I know is it worked fine Firefox 56, can we go back to that configuration on the next update? :) .. Quantum leap to using Chrome instead.

I completely agree with LMH77. Most people wouldn't know there is a problem and wouldn't know to configure their browser. But after mentioning this problem on Mozilla and Google Font forums, this the only answer I got that worked. The only alternative I can see is choosing one of the select Google fonts that still works when not changing Firefox configuration. Or that most people don't have the Google font installed locally, so they will see it correctly. All I know is it worked fine Firefox 56, can we go back to that configuration on the next update? :) .. Quantum leap to using Chrome instead.
mtbksouth 0 solutions 3 answers

Still an issue. I had to set my sandbox to 1 before it worked. Had question-marks instead of characters on numerous websites, including gmail. Had to use chrome until I found this thread.

Still an issue. I had to set my sandbox to 1 before it worked. Had question-marks instead of characters on numerous websites, including gmail. Had to use chrome until I found this thread.