Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

You recent updates have ruined this browser!!!

  • 3 replies
  • 3 have this problem
  • 2 views
  • Last reply by FredMcD

more options

This has become a bloated pile of dung..Very disappointed that you now have multiple processes that dont dump and slow everything to a snails pace..must I now go to I>E> because your not any better???!!!

This has become a bloated pile of dung..Very disappointed that you now have multiple processes that dont dump and slow everything to a snails pace..must I now go to I>E> because your not any better???!!!

All Replies (3)

more options

First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update.

v57+; Type about:preferences#general<enter> in the address bar. Select Update.

Check the settings.

Also turn off Use a background service to install updates


Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

more options

Ridiculous to have 6-7 processes running for 2 tabs!!! BLOATED SOFTWARE NOW!!!

more options

That would depend on what those processes are doing.

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.