X
Tap here to go to the mobile version of the site.

Support Forum

Touchscreen functionality on surface pro 4 is now terrible in Quantum, but was great in previous version.

Posted

I had been using regular firefox, and with the add-ons I had for saving photos and movies, my browsing experience was basically perfect on my Surface Pro 4. Now Quantum comes and the touchscreen is terrible to use. It seems to randomly be interacting with the sites, it will click things when I do not mean to click them, and holding to use the context menu barely works. Everything used to be usable with a finger, but I frequently find myself having to use the stylus to even get it to recognize input at all.

There does not seem to be any way that I see to calibrate this to make it better.

I had been using regular firefox, and with the add-ons I had for saving photos and movies, my browsing experience was basically perfect on my Surface Pro 4. Now Quantum comes and the touchscreen is terrible to use. It seems to randomly be interacting with the sites, it will click things when I do not mean to click them, and holding to use the context menu barely works. Everything used to be usable with a finger, but I frequently find myself having to use the stylus to even get it to recognize input at all. There does not seem to be any way that I see to calibrate this to make it better.

Chosen solution

hi, thanks for reporting this to us. could you please test if the following step improves the situation?: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5324 solutions 23511 answers

Chosen Solution

hi, thanks for reporting this to us. could you please test if the following step improves the situation?: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

hi, thanks for reporting this to us. could you please test if the following step improves the situation?: go to the firefox ''menu ≡ > options > privacy & security'' panel and under permissions check the setting to '''prevent accessibility services from accessing your browser'''.

Question owner

At first test this has at least helped greatly, if not solved the problem completely. Thank you very much for the response.

At first test this has at least helped greatly, if not solved the problem completely. Thank you very much for the response.