X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 57 hangs when opening new tab

Posted

Hi,

I upgraded to new firefox 57 and in starting it worked fine but after few hours of use, when I tried to open new tab then firefox would freeze for 4-5 seconds. After 4-5 seconds the new tab would open. I only have 2 extensions i.e Adblock and StickyPassword.

Thanks.

Hi, I upgraded to new firefox 57 and in starting it worked fine but after few hours of use, when I tried to open new tab then firefox would freeze for 4-5 seconds. After 4-5 seconds the new tab would open. I only have 2 extensions i.e Adblock and StickyPassword. Thanks.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Mkll 314 solutions 1978 answers

Let's try a refresh!

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

Let's try a refresh! The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. '''''Note:''' When you use this feature, you will lose any extensions, toolbar customizations, and some preferences.'' See the [[Refresh Firefox - reset add-ons and settings]] article for more information. To Refresh Firefox: # Open the Troubleshooting Information page using one of these methods: #*Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. A new tab containing your troubleshooting information should open. #*If you're unable to access the Help menu, type '''about:support''' in your address bar to bring up the Troubleshooting Information page. #At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it. #Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported. #Click Finish and Firefox will reopen. Did this fix the problem? Please report back to us! Thank you.

Question owner

Hi,

Sorry I selected answer too quickly but after using FF 3-4 times the same problem has started again. What to do ? :(

Thanks.

Hi, Sorry I selected answer too quickly but after using FF 3-4 times the same problem has started again. What to do ? :( Thanks.

Modified by tbhanot

Mkll 314 solutions 1978 answers

Try a clean re-install:

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your Firefox profile data (such as bookmarks and passwords), since that information is stored in a different location.

To do a clean reinstall of Firefox, please follow these steps: Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org (or choose the download for your operating system and language from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29 ).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

Try a clean re-install: Certain Firefox problems can be solved by performing a ''Clean reinstall''. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your [[Profiles - Where Firefox stores your bookmarks, passwords and other user data|Firefox profile]] data (such as bookmarks and passwords), since that information is stored in a different location. To do a clean reinstall of Firefox, please follow these steps: '''Note:''' You might want to print these steps or view them in another browser. #Download the latest Desktop version of Firefox from [https://www.mozilla.org mozilla.org] (or choose the download for your operating system and language from [https://www.mozilla.org/firefox/all/ this page]) and save the setup file to your computer. #After the download finishes, close all Firefox windows (or open the Firefox menu [[Image:New Fx Menu]] and click the close button [[Image:Close 29]]). #Delete the Firefox installation folder, which is located in one of these locations, by default: #*'''Windows:''' #**C:\Program Files\Mozilla Firefox #**C:\Program Files (x86)\Mozilla Firefox #*'''Mac:''' Delete Firefox from the Applications folder. #*'''Linux:''' If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see [[Installing Firefox on Linux]]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page], simply remove the folder ''firefox'' in your home directory. #Now, go ahead and reinstall Firefox: ##Double-click the downloaded installation file and go through the steps of the installation wizard. ##Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. More information about reinstalling Firefox can be found [[Troubleshoot and diagnose Firefox problems#w_5-reinstall-firefox|here]]. <b>WARNING:</b> Do not use a third party uninstaller as part of this process. Doing so could permanently delete your [[Profiles|Firefox profile]] data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. <u>These cannot be easily recovered unless they have been backed up to an external device!</u> See [[Back up and restore information in Firefox profiles]]. <!-- Starting in Firefox 31, the Firefox uninstaller no longer lets you remove user profile data.Ref: Bug 432017 and https://support.mozilla.org/kb/uninstall-firefox-from-your-computer/discuss/5279 [Fx31] Windows uninstaller will no longer offer the option to remove personal data --> Please report back to say if this helped you! Thank you.

Question owner

Hi,

I re-installed windows (fresh install) and then re-installed firefox (total clean hard drive) but it still hangs. I have now only 1 extension i.e StickyPassword, also I am on SSD with 16 GB RAM. Weird. Thanks.

Hi, I re-installed windows (fresh install) and then re-installed firefox (total clean hard drive) but it still hangs. I have now only 1 extension i.e StickyPassword, also I am on SSD with 16 GB RAM. Weird. Thanks.

Question owner

After disabling all extensions, and doing a cleanest of the install, it now hangs even more. Becomes totally unresponsive at random things. I have reverted back to Chrome. :(

After disabling all extensions, and doing a cleanest of the install, it now hangs even more. Becomes totally unresponsive at random things. I have reverted back to Chrome. :(
scratch69 0 solutions 3 answers

Helpful Reply

Reset does not work and reinstall does not work tried it. Just take on your responsibilities and fix your problem which also occurred in beta.

Reset does not work and reinstall does not work tried it. Just take on your responsibilities and fix your problem which also occurred in beta.
scratch69 0 solutions 3 answers

scratch69 said

Reset does not work and reinstall does not work tried it. Just take on your responsibilities and fix your problem which also occurred in beta.

So is this going to be looked at or what? It's getting very aggravating.

''scratch69 [[#answer-1031378|said]]'' <blockquote> Reset does not work and reinstall does not work tried it. Just take on your responsibilities and fix your problem which also occurred in beta. </blockquote> So is this going to be looked at or what? It's getting very aggravating.

Modified by scratch69

dariopuerot 0 solutions 1 answers

Found a good tip in this link: https://atomicsupermen.wordpress.com/2017/11/15/a-fix-for-trippy-youtube-playback-with-firefox-quantum-57/

"Then go to Options (hamburger icon at far upper right side or ALT key-> Tools menu -> Options). Scroll down in General (which should be the default view) to Performance and uncheck Use Recommended Performance Settings. That will reveal Use Hardware Acceleration When Available, which will probably be checked. Uncheck it."

Found a good tip in this link: https://atomicsupermen.wordpress.com/2017/11/15/a-fix-for-trippy-youtube-playback-with-firefox-quantum-57/ "Then go to Options (hamburger icon at far upper right side or ALT key-> Tools menu -> Options). Scroll down in General (which should be the default view) to Performance and uncheck Use Recommended Performance Settings. That will reveal Use Hardware Acceleration When Available, which will probably be checked. Uncheck it."

Question owner

dariopuerot said

Found a good tip in this link: https://atomicsupermen.wordpress.com/2017/11/15/a-fix-for-trippy-youtube-playback-with-firefox-quantum-57/ "Then go to Options (hamburger icon at far upper right side or ALT key-> Tools menu -> Options). Scroll down in General (which should be the default view) to Performance and uncheck Use Recommended Performance Settings. That will reveal Use Hardware Acceleration When Available, which will probably be checked. Uncheck it."


Sorry this is not helping either. Thanks.

''dariopuerot [[#answer-1032269|said]]'' <blockquote> Found a good tip in this link: https://atomicsupermen.wordpress.com/2017/11/15/a-fix-for-trippy-youtube-playback-with-firefox-quantum-57/ "Then go to Options (hamburger icon at far upper right side or ALT key-> Tools menu -> Options). Scroll down in General (which should be the default view) to Performance and uncheck Use Recommended Performance Settings. That will reveal Use Hardware Acceleration When Available, which will probably be checked. Uncheck it." </blockquote> Sorry this is not helping either. Thanks.
scratch69 0 solutions 3 answers

What I did was update my display driver (Intel(R) HD Graphics 4600) and it seems to be working.


No it doesn't work.

What I did was update my display driver (Intel(R) HD Graphics 4600) and it seems to be working. No it doesn't work.

Modified by scratch69

jhondoe 1 solutions 2 answers

Helpful Reply

The following worked for me: Options -> Privacy & Security -> Prevent accessibility services from accessing your browser

The following worked for me: Options -> Privacy & Security -> Prevent accessibility services from accessing your browser
martingz 1 solutions 17 answers

jhondoe said

The following worked for me: Options -> Privacy & Security -> Prevent accessibility services from accessing your browser

Just to note, I was having the same issue after upgrading to FFv57. This fix seems to have corrected the issue... so far (thanks for posting).

''jhondoe [[#answer-1033118|said]]'' <blockquote> The following worked for me: Options -> Privacy & Security -> Prevent accessibility services from accessing your browser </blockquote> Just to note, I was having the same issue after upgrading to FFv57. This fix seems to have corrected the issue... so far (thanks for posting).
DeadLink 0 solutions 3 answers

Setting the content process limit to 1 worked for me. I suspect it is when a new thread is created (opening a new tab while under the thread limit).

Setting the content process limit to 1 worked for me. I suspect it is when a new thread is created (opening a new tab while under the thread limit).
Bill18441 0 solutions 2 answers

Beginning around Firefox 57, each time I opened a new tab, the new tab displayed tiles of content related to my recent browsing history, along with new suggested stuff I had no interest in, and my CPU simultaneously got stuck at 25% for 15-60 sec, apparently from something creating all the tiles/suggestions.

After googling how to adjust firefox new tab content, I found a new tab content knob was recently removed. Suggested fix was to install the "New Tab Override" addon. I installed that and selected, within its options, "blank page" for new tab content. PRESTO!!! Nice, blank new tabs w/ NO MORE DELAYS!!!

Beginning around Firefox 57, each time I opened a new tab, the new tab displayed tiles of content related to my recent browsing history, along with new suggested stuff I had no interest in, and my CPU simultaneously got stuck at 25% for 15-60 sec, apparently from something creating all the tiles/suggestions. After googling how to adjust firefox new tab content, I found a new tab content knob was recently removed. Suggested fix was to install the "New Tab Override" addon. I installed that and selected, within its options, "blank page" for new tab content. PRESTO!!! Nice, blank new tabs w/ NO MORE DELAYS!!!
ficje 0 solutions 3 answers

I 'Upgraded' Firefox 57 to 51. All problems solved!

I 'Upgraded' Firefox 57 to 51. All problems solved!