Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox doesn't start

  • 9 replies
  • 6 have this problem
  • 3 views
  • Last reply by FredMcD

more options

When I click on firefox to start the firefox window doesn't open. The firefox.exe process appears in my process tab in the taksmanager for about 15 seconds and then it's gone. I've tried the create a new profile solution, but the profile manager won't start either. I've already tried uninstalling and reinstalling it a couple of times, but it doesn't help. Does anyone here know what I can do to make firefox work again?

When I click on firefox to start the firefox window doesn't open. The firefox.exe process appears in my process tab in the taksmanager for about 15 seconds and then it's gone. I've tried the create a new profile solution, but the profile manager won't start either. I've already tried uninstalling and reinstalling it a couple of times, but it doesn't help. Does anyone here know what I can do to make firefox work again?

Chosen solution

All right, seems it was a dual problem. First of all my security software, which is Avast Premier, since recent update sees firefox as a potential threat. So I had to add the file path to the exclusion list. Second problem was indeed the new 64bit version of firefox which gave me a lot off issues as well. Installing the 32bit version solved the last of my problems. A thank you to all who helped me here!

Read this answer in context 👍 0

All Replies (9)

more options

I take it you didn't ask for help on the 'sick' computer.

What's your computer system and Firefox version? If Windows, are you using the 64 or 32 bit program?


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

FredMcD said

I take it you didn't ask for help on the 'sick' computer. What's your computer system and Firefox version? If Windows, are you using the 64 or 32 bit program?

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

I did ask for help from the same computer as my firefox is installed if that's what you mean. I'm currently just using a different browser because my firefox isn't working anymore. And firefox in safe mode doesn't work either. It's the same problem. I had tried this before as well. I'm currently using a windows 7 ultimate 64bit. So firefox is a 64bit version as well en it the 56.0.2.6506 version of the program.

Modified by Nielsdd

more options

cor-el said

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

I started my computer in Safe mode with networking and there my firefox works fine. When I then booted my computer normally firefox suddenly did start, but gave an error message(which I'm adding to this post). But it didn't load any websites. And when I closed it and tried to start it again, I have the same original problem again. So something weird is definitely going on.

more options

There are two possibilities.

1) Something is blocking Firefox from the web This could be your Firewall or your protection program.

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

2) Something is wrong with the program itself.

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder if there is one.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

more options

Another possibility;

Nielsdd said

firefox is a 64bit version as well en it the 56.0.2.6506 version of the program.

Many have reported issues using the 64bit Firefox. Install the 32bit version from; Download Firefox For All languages And Systems {web link}

more options

Chosen Solution

All right, seems it was a dual problem. First of all my security software, which is Avast Premier, since recent update sees firefox as a potential threat. So I had to add the file path to the exclusion list. Second problem was indeed the new 64bit version of firefox which gave me a lot off issues as well. Installing the 32bit version solved the last of my problems. A thank you to all who helped me here!

more options

That was very good work. Well done.