X
Tap here to go to the mobile version of the site.

Support Forum

Photos don't load on Ebay. This just started tonight. Photos are fine on all other websites. Photos also are fine on Internet Explorer

Posted

Suddenly this evening photos don't show on Ebay. Just a message for each one saying image not available. Photos load on all other websites - for now, anyway, and everything works fine on internet explorer. This problem is just with firefox and Ebay.

Suddenly this evening photos don't show on Ebay. Just a message for each one saying image not available. Photos load on all other websites - for now, anyway, and everything works fine on internet explorer. This problem is just with firefox and Ebay.

Chosen solution

jscher2000 said

If you are a regular eBayer, I suggest sending them a support request or trouble ticket.

Disabling the stapling fixed it. Thank you for that! I am a regular ebayer (I run a business that sells regularly). I'll file a request, but I'm also a regular enough ebayer to know that their software team will probably just say to leave the OCSP stapling off if that's what fixes it.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 17.12.20093
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.141.2 for Mozilla browsers
  • Shockwave Flash 27.0 r0
  • 5.1.50907.0
  • VLC media player Web Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

billybob884 2 solutions 7 answers

Having the same problem. eBay work just fine on Chrome...

Flash updated for me today, maybe that has something to do with it?

Having the same problem. eBay work just fine on Chrome... Flash updated for me today, maybe that has something to do with it?
jscher2000
  • Top 10 Contributor
8693 solutions 71065 answers

Do either of you use any add-ons that might block content in eBay pages? That would include ad blockers, script blockers, tracking blockers, etc. How about external filters such as security software that intercepts all your browsing, or parental control software?

If you click a direct link to an image, does it display or give an error? For example:

https://i.ebayimg.com/images/g/ZhgAAOSwOfBZ3X-S/s-l1600.jpg

Do either of you use any add-ons that might block content in eBay pages? That would include ad blockers, script blockers, tracking blockers, etc. How about external filters such as security software that intercepts all your browsing, or parental control software? If you click a direct link to an image, does it display or give an error? For example: https://i.ebayimg.com/images/g/ZhgAAOSwOfBZ3X-S/s-l1600.jpg
billybob884 2 solutions 7 answers

I use adblock plus and NoScript (I have for several years), but I have already tried restarting with addons disabled and still have this problem.

Your link generates the following error: Secure Connection Failed

An error occurred during a connection to i.ebayimg.com. Invalid OCSP signing certificate in OCSP response. Error code: SEC_ERROR_OCSP_INVALID_SIGNING_CERT

- The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. - Please contact the website owners to inform them of this problem.

I use adblock plus and NoScript (I have for several years), but I have already tried restarting with addons disabled and still have this problem. Your link generates the following error: Secure Connection Failed An error occurred during a connection to i.ebayimg.com. Invalid OCSP signing certificate in OCSP response. Error code: SEC_ERROR_OCSP_INVALID_SIGNING_CERT - The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. - Please contact the website owners to inform them of this problem.
Cambreaker 1 solutions 3 answers

Helpful Reply

First off - WHY is it so hard to create an account on Mozilla Support? Jeez! I am having this eBay image issue all of a sudden this evening as well, worked fine earlier this afternoon. Images work fine on Chrome, as well as any other site on FF. -I have cleared cookies & cache. -I have created new FF profiles. -I have run FF in safe mode. -I have checked that images load automatically.

When I click the link in jscher2000's comment, I get "Secure Connection Failed An error occurred during a connection to i.ebayimg.com. Invalid OCSP signing certificate in OCSP response. Error code: SEC_ERROR_OCSP_INVALID_SIGNING_CERT

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem."

Is this a security cert issue on eBay's end (I wouldn't be surprised, for a multi-billion dollar corporation, eBay is amateurish at best)? If so, why is FF the only browser picking up on it?

I hope to get this fixed ASAP. I'm not into Chrome due to their sketchy privacy policies.

First off - WHY is it so hard to create an account on Mozilla Support? Jeez! I am having this eBay image issue all of a sudden this evening as well, worked fine earlier this afternoon. Images work fine on Chrome, as well as any other site on FF. -I have cleared cookies & cache. -I have created new FF profiles. -I have run FF in safe mode. -I have checked that images load automatically. When I click the link in jscher2000's comment, I get "Secure Connection Failed An error occurred during a connection to i.ebayimg.com. Invalid OCSP signing certificate in OCSP response. Error code: SEC_ERROR_OCSP_INVALID_SIGNING_CERT The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem." Is this a security cert issue on eBay's end (I wouldn't be surprised, for a multi-billion dollar corporation, eBay is amateurish at best)? If so, why is FF the only browser picking up on it? I hope to get this fixed ASAP. I'm not into Chrome due to their sketchy privacy policies.
jscher2000
  • Top 10 Contributor
8693 solutions 71065 answers

billybob884 said

Your link generates the following error:
Secure Connection Failed
An error occurred during a connection to i.ebayimg.com. Invalid OCSP signing certificate in OCSP response. Error code: SEC_ERROR_OCSP_INVALID_SIGNING_CERT

That's interesting. I don't get that. Perhaps eBay is serving us from different servers for some reason?

As a possible workaround, you can temporarily disable OCSP stapling. With that change, instead of Firefox expecting sites to provide an OCSP certificate -- called OCSP "stapling" -- Firefox will query the service provider that signed the certificate. This is good for security but not the best arrangement for privacy, because the service provider knows a computer at your IP address is checking out that site. So after you finish using eBay, you can switch the setting back. Or you can just use a different browser until the site fixes this, probably soon if people complain.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste ocsp and pause while the list is filtered

(3) Double-click the security.ssl.enable_ocsp_stapling preference to switch the value from true to false

Does that work?

''billybob884 [[#answer-1017254|said]]'' <blockquote> Your link generates the following error:<br> Secure Connection Failed<br> An error occurred during a connection to i.ebayimg.com. Invalid OCSP signing certificate in OCSP response. Error code: SEC_ERROR_OCSP_INVALID_SIGNING_CERT </blockquote> That's interesting. I don't get that. Perhaps eBay is serving us from different servers for some reason? As a possible workaround, you can temporarily disable OCSP stapling. With that change, instead of Firefox expecting sites to provide an OCSP certificate -- called OCSP "stapling" -- Firefox will query the service provider that signed the certificate. This is good for security but not the best arrangement for privacy, because the service provider knows a computer at your IP address is checking out that site. So after you finish using eBay, you can switch the setting back. Or you can just use a different browser until the site fixes this, probably soon if people complain. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''ocsp''' and pause while the list is filtered (3) Double-click the '''security.ssl.enable_ocsp_stapling''' preference to switch the value from true to false Does that work?
billybob884 2 solutions 7 answers

That worked for me, but I probably won't use it for security concerns. Thank you though, hopefully this will be fixed soon.

That worked for me, but I probably won't use it for security concerns. Thank you though, hopefully this will be fixed soon.
jscher2000
  • Top 10 Contributor
8693 solutions 71065 answers

Cambreaker said

Is this a security cert issue on eBay's end (I wouldn't be surprised, for a multi-billion dollar corporation, eBay is amateurish at best)? If so, why is FF the only browser picking up on it?

Chrome uses a different system for confirming that certificates have not been revoked by their issuers. Possibly humans filter out false positives or the CRL (certificate revocation list) is not updated very often so transient problems are ignored.

''Cambreaker [[#answer-1017255|said]]'' <blockquote>Is this a security cert issue on eBay's end (I wouldn't be surprised, for a multi-billion dollar corporation, eBay is amateurish at best)? If so, why is FF the only browser picking up on it? </blockquote> Chrome uses a different system for confirming that certificates have not been revoked by their issuers. Possibly humans filter out false positives or the CRL (certificate revocation list) is not updated very often so transient problems are ignored.
jscher2000
  • Top 10 Contributor
8693 solutions 71065 answers

Okay, I also get the error now, so something is disconnected somewhere.

billybob884 said

That worked for me, but I probably won't use it for security concerns. Thank you though, hopefully this will be fixed soon.

If you are a regular eBayer, I suggest sending them a support request or trouble ticket.

Okay, I also get the error now, so something is disconnected somewhere. ''billybob884 [[#answer-1017261|said]]'' <blockquote> That worked for me, but I probably won't use it for security concerns. Thank you though, hopefully this will be fixed soon. </blockquote> If you are a regular eBayer, I suggest sending them a support request or trouble ticket.
Cambreaker 1 solutions 3 answers

Chosen Solution

jscher2000 said

If you are a regular eBayer, I suggest sending them a support request or trouble ticket.

Disabling the stapling fixed it. Thank you for that! I am a regular ebayer (I run a business that sells regularly). I'll file a request, but I'm also a regular enough ebayer to know that their software team will probably just say to leave the OCSP stapling off if that's what fixes it.

''jscher2000 [[#answer-1017265|said]]'' <blockquote> If you are a regular eBayer, I suggest sending them a support request or trouble ticket. </blockquote> Disabling the stapling fixed it. Thank you for that! I ''am'' a regular ebayer (I run a business that sells regularly). I'll file a request, but I'm also a regular enough ebayer to know that their software team will probably just say to leave the OCSP stapling off if that's what fixes it.

Modified by Cambreaker

Question owner

Thank you so much to all..I will try to file a request w/ eabay and then try some of the other tech solutions, but as that will take time and confuse me I'm sure, I think for at least the next day or two I'm going to use Internet Explorer. Thanks again to all and have a good night.

Thank you so much to all..I will try to file a request w/ eabay and then try some of the other tech solutions, but as that will take time and confuse me I'm sure, I think for at least the next day or two I'm going to use Internet Explorer. Thanks again to all and have a good night.
Blutengel_Fan 0 solutions 3 answers

I just started having this problem a few minutes ago myself with eBay and Firefox. Internet explorer and Chrome allow images to display just fine, so it's only with Firefox. I cleared my cache, browsing history, etc, but the issue still exists and I don't want to lose more time finding solutions that don't work. Firefox is as updated as it can get, so I don't know what to do since I'm not immensely technically savvy.

I just started having this problem a few minutes ago myself with eBay and Firefox. Internet explorer and Chrome allow images to display just fine, so it's only with Firefox. I cleared my cache, browsing history, etc, but the issue still exists and I don't want to lose more time finding solutions that don't work. Firefox is as updated as it can get, so I don't know what to do since I'm not immensely technically savvy.
jscher2000
  • Top 10 Contributor
8693 solutions 71065 answers

Hi Blutengel_Fan, if you click this link to a random eBay product photo:

https://i.ebayimg.com/images/g/ZhgAAOSwOfBZ3X-S/s-l1600.jpg

Do you get this error:

An error occurred during a connection to i.ebayimg.com. Invalid OCSP signing certificate in OCSP response. Error code: SEC_ERROR_OCSP_INVALID_SIGNING_CERT

If so, that's the same issue discussed in other posts in this thread. There is a temporary workaround here you can try, or you can use a different browser for tonight and see whether this clears up tomorrow.

Hi Blutengel_Fan, if you click this link to a random eBay product photo: https://i.ebayimg.com/images/g/ZhgAAOSwOfBZ3X-S/s-l1600.jpg Do you get this error: An error occurred during a connection to i.ebayimg.com. Invalid OCSP signing certificate in OCSP response. Error code: '''SEC_ERROR_OCSP_INVALID_SIGNING_CERT''' If so, that's the same issue discussed in other posts in this thread. There is a temporary workaround here you can try, or you can use a different browser for tonight and see whether this clears up tomorrow.
Blutengel_Fan 0 solutions 3 answers

Yes, that's the error message I see when I click the link. I haven't rebooted my computer since my eBay image problem started, so I wonder if that would help or if I need to do something else...

Yes, that's the error message I see when I click the link. I haven't rebooted my computer since my eBay image problem started, so I wonder if that would help or if I need to do something else...
jscher2000
  • Top 10 Contributor
8693 solutions 71065 answers

Helpful Reply

Hi Blutengel_Fan, as a temporary workaround, you can disable OCSP "stapling." With that change, instead of Firefox expecting sites to provide an OCSP certificate -- a verification that its certificate has not been revoked -- Firefox will query the service provider that signed the certificate. This is good for security but not the best arrangement for privacy, because the service provider knows a computer at your IP address is checking out that site. So after you finish using eBay, you can switch the setting back, or you could use a different browser for the time being.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste ocsp and pause while the list is filtered

(3) Double-click the security.ssl.enable_ocsp_stapling preference to switch the value from true to false

Success?

Hi Blutengel_Fan, as a temporary workaround, you can disable OCSP "stapling." With that change, instead of Firefox expecting sites to provide an OCSP certificate -- a verification that its certificate has not been revoked -- Firefox will query the service provider that signed the certificate. This is good for security but not the best arrangement for privacy, because the service provider knows a computer at your IP address is checking out that site. So after you finish using eBay, you can switch the setting back, or you could use a different browser for the time being. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''ocsp''' and pause while the list is filtered (3) Double-click the '''security.ssl.enable_ocsp_stapling''' preference to switch the value from true to false Success?
mkando 0 solutions 3 answers

ebay working with images now 8.04 GMT

ebay working with images now 8.04 GMT
Blutengel_Fan 0 solutions 3 answers

jscher2000 said

Hi Blutengel_Fan, as a temporary workaround, you can disable OCSP "stapling." With that change, instead of Firefox expecting sites to provide an OCSP certificate -- a verification that its certificate has not been revoked -- Firefox will query the service provider that signed the certificate. This is good for security but not the best arrangement for privacy, because the service provider knows a computer at your IP address is checking out that site. So after you finish using eBay, you can switch the setting back, or you could use a different browser for the time being. (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste ocsp and pause while the list is filtered (3) Double-click the security.ssl.enable_ocsp_stapling preference to switch the value from true to false Success?

Beautiful! Thank you so much! Your fix did the trick for me! :)

Firefox is my preferred browser, where I've got all my bookmarks, so it's just more comfortable for me to keep working with it.

''jscher2000 [[#answer-1017301|said]]'' <blockquote> Hi Blutengel_Fan, as a temporary workaround, you can disable OCSP "stapling." With that change, instead of Firefox expecting sites to provide an OCSP certificate -- a verification that its certificate has not been revoked -- Firefox will query the service provider that signed the certificate. This is good for security but not the best arrangement for privacy, because the service provider knows a computer at your IP address is checking out that site. So after you finish using eBay, you can switch the setting back, or you could use a different browser for the time being. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''ocsp''' and pause while the list is filtered (3) Double-click the '''security.ssl.enable_ocsp_stapling''' preference to switch the value from true to false Success? </blockquote> Beautiful! Thank you so much! Your fix did the trick for me! :) Firefox is my preferred browser, where I've got all my bookmarks, so it's just more comfortable for me to keep working with it.
cor-el
  • Top 10 Contributor
  • Moderator
17473 solutions 157934 answers

Note that it is best to reset this pref via the right-click context menu to true once you are done with accessing an affected website since this is a security feature.

See also:

Note that it is best to reset this pref via the right-click context menu to <b>true</b> once you are done with accessing an affected website since this is a security feature. See also: *https://en.wikipedia.org/wiki/OCSP_Stapling *https://blog.mozilla.org/security/2013/07/29/ocsp-stapling-in-firefox/
Cambreaker 1 solutions 3 answers

To all who had this problem, I re-enabled the setting that jscher2000 used to work around this issue this morning. Ebay seem to have gotten their OCSP certificate back in order... record time! Please remember to turn the setting back ASAP, as it may otherwise pose a security and privacy risk, and I suspect many of us use Firefox in part because of their greater respect for user privacy!

To all who had this problem, I re-enabled the setting that jscher2000 used to work around this issue this morning. Ebay seem to have gotten their OCSP certificate back in order... record time! Please remember to turn the setting back ASAP, as it may otherwise pose a security and privacy risk, and I suspect many of us use Firefox in part because of their greater respect for user privacy!