X
Tap here to go to the mobile version of the site.

Support Forum

How do I get Firefox to stop adding +1 to my phone # in Autofill

Posted

I like the Autofill feature in Firefox, but FF keeps adding a +1 to my phone number. I enter my phone as 10 digits, no dashes or spaces, area code + number. I change it and the +1 reappears. +1xxx-xxx-xxxx is not a format accepted by most web forms.

I like the Autofill feature in Firefox, but FF keeps adding a +1 to my phone number. I enter my phone as 10 digits, no dashes or spaces, area code + number. I change it and the +1 reappears. +1xxx-xxx-xxxx is not a format accepted by most web forms.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

FredMcD
  • Top 10 Contributor
3160 solutions 42645 answers

Many phone companies need the +1 for long distance calls. Would it be a long distance call for wherever the number is going?

Note: Some web pages will add the +1 because of their scripts.

Many phone companies need the +1 for long distance calls. Would it be a long distance call for wherever the number is going? Note: Some web pages will add the +1 because of their scripts.
Was this helpful to you? 0
Quote

Helpful Reply

Most people know that you need to dial a 1 before dialing a number outside of your home area code, but I've never seen a web form or sweepstakes form that has you type a +1 before the number.

Most only accept 10 digits unless they want you to include the hyphens. Firefox autofill works good on a lot of forms, but when it fills in the ph# with a +1 I always have to edit it.

Maybe this should be in the options, or an about:config parameter

Most people know that you need to dial a 1 before dialing a number outside of your home area code, but I've never seen a web form or sweepstakes form that has you type a +1 before the number. Most only accept 10 digits unless they want you to include the hyphens. Firefox autofill works good on a lot of forms, but when it fills in the ph# with a +1 I always have to edit it. Maybe this should be in the options, or an about:config parameter
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15577 solutions 141049 answers

Helpful Reply

See:

  • bug 1405486 - Form Autofill] Allow me to specify the format for phone numbers

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

You can vote for a bug to show your interest
https://bugzilla.mozilla.org/page.cgi?id=voting.html

See: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1405486 bug 1405486] - Form Autofill] Allow me to specify the format for phone numbers Please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html You can vote for a bug to show your interest<br>https://bugzilla.mozilla.org/page.cgi?id=voting.html
Was this helpful to you? 2
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.