X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop the "Firefox prevented this page from automatically . . .

Posted

To stop this message from displaying, you're supposed to be able to go to General>Advanced and uncheck the "Warn me" box. However, I don't see an Advanced tab under Options>General. Did that disappear in Firefox 56.0?

The message is "Firefox prevented this page from automatically redirecting to another page." I get that far too often on standard sites I visit and need to be able to turn that message off.

How do I stop that message? Yes, I know it's there for a reason, but I have other ways of blocking unwanted redirects.

To stop this message from displaying, you're supposed to be able to go to General>Advanced and uncheck the "Warn me" box. However, I don't see an Advanced tab under Options>General. Did that disappear in Firefox 56.0? The message is "Firefox prevented this page from automatically redirecting to another page." I get that far too often on standard sites I visit and need to be able to turn that message off. How do I stop that message? Yes, I know it's there for a reason, but I have other ways of blocking unwanted redirects.

Modified by klgrube

Chosen solution

When I looked at the setting it was already set to False. I set it to true and then back to false and the redirects stopped. It looks to me that on upgrading to version 56 that the accessibility.blockautorefresh setting is actually set to true even though it says it is set to false.

When I first saw the problem I did the usual refresh/reset firefox and it did not help the problem. It seems to be a problem with the initial upgrade from Version 55 to 56.0 and 56.0.1. The best solution would be to put the setting back into the options page.
Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0

More Information

jscher2000
  • Top 10 Contributor
6728 solutions 55029 answers

Helpful Reply

Hi, the Options page was reorganized in Firefox 56 and that checkbox is no longer included. There is another way to change the setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste access and pause while the list is filtered

(3) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

Success?

Hi, the Options page was reorganized in Firefox 56 and that checkbox is no longer included. There is another way to change the setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''access''' and pause while the list is filtered (3) If the '''accessibility.blockautorefresh''' preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false Success?
Was this helpful to you? 11
Quote

Helpful Reply

Thank you. I just made this change and will stop back in a while to let you know if the problem is finally fully resolved.

Thank you. I just made this change and will stop back in a while to let you know if the problem is finally fully resolved.
Was this helpful to you? 2
Quote
yessongs1 1 solutions 5 answers

Chosen Solution

When I looked at the setting it was already set to False. I set it to true and then back to false and the redirects stopped. It looks to me that on upgrading to version 56 that the accessibility.blockautorefresh setting is actually set to true even though it says it is set to false.

When I first saw the problem I did the usual refresh/reset firefox and it did not help the problem. It seems to be a problem with the initial upgrade from Version 55 to 56.0 and 56.0.1. The best solution would be to put the setting back into the options page.
When I looked at the setting it was already set to False. I set it to true and then back to false and the redirects stopped. It looks to me that on upgrading to version 56 that the accessibility.blockautorefresh setting is actually set to true even though it says it is set to false. When I first saw the problem I did the usual refresh/reset firefox and it did not help the problem. It seems to be a problem with the initial upgrade from Version 55 to 56.0 and 56.0.1. The best solution would be to put the setting back into the options page.
Was this helpful to you?
Quote
yessongs1 1 solutions 5 answers

It turns out that changing the state of the accessibility.blockautorefresh flag from true to false only works for the current session. As soon as I closed the page and reopened it I get the same Redirect Notice again even though the flag is set to False for the accessibility.blockautorefresh setting. The setting is not working in version 56 and 56.0.1.

I've already tried safe mode and resetting and deleting the current profile. None of these solutions help at all. Please put the selection back as it was in the Advanced section prior to Version 56. Or...fix version 56 so that it actually works correctly. Thank you, Yessongs1

It turns out that changing the state of the accessibility.blockautorefresh flag from true to false only works for the current session. As soon as I closed the page and reopened it I get the same Redirect Notice again even though the flag is set to False for the accessibility.blockautorefresh setting. The setting is not working in version 56 and 56.0.1. I've already tried safe mode and resetting and deleting the current profile. None of these solutions help at all. Please put the selection back as it was in the Advanced section prior to Version 56. Or...fix version 56 so that it actually works correctly. Thank you, Yessongs1
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
6728 solutions 55029 answers

I'm having trouble understanding what could cause that. As far as I know, that's the only setting in Firefox which can generate that toolbar. If double-switch it (double-click to true, double-click to false), does that make any difference?

Oh, I just remembered you can switch the layout of the page back (at least in Firefox 56):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste oldorg and pause while the list is filtered

(3) Double-click the browser.preferences.useOldOrganization preference to switch the value from false to true

I'm having trouble understanding what could cause that. As far as I know, that's the only setting in Firefox which can generate that toolbar. If double-switch it (double-click to true, double-click to false), does that make any difference? Oh, I just remembered you can switch the layout of the page back (at least in Firefox 56): (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''oldorg''' and pause while the list is filtered (3) Double-click the '''browser.preferences.useOldOrganization''' preference to switch the value from false to true
Was this helpful to you? 1
Quote
FedupwithScripterrors 0 solutions 5 answers

I really cannot comprehend why this is not more obvious in Firefox options. My bank and several serious websites that I use keep getting this pop up. What I really want is that the pop-up gave me a choice to always allow this page to redirect, but continue to warn me. Disabling seems dangerous.

I really cannot comprehend why this is not more obvious in Firefox options. My bank and several serious websites that I use keep getting this pop up. What I really want is that the pop-up gave me a choice to always allow this page to redirect, but continue to warn me. Disabling seems dangerous.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
6728 solutions 55029 answers

FedupwithScripterrors said

I really cannot comprehend why this is not more obvious in Firefox options. My bank and several serious websites that I use keep getting this pop up. What I really want is that the pop-up gave me a choice to always allow this page to redirect, but continue to warn me. Disabling seems dangerous.

This ancient feature was designed in a more innocent time to help prevent users of assistive software such as screen readers from losing their place. It was never intended as a security feature and has not been updated to accounts for the myriad ways that modern websites work.

Maybe someone will step forward and rewrite this part of Firefox in a future version, but until then, it's broken on many sites and you either need to turn it off or live with its problems.

''FedupwithScripterrors [[#answer-1025030|said]]'' <blockquote> I really cannot comprehend why this is not more obvious in Firefox options. My bank and several serious websites that I use keep getting this pop up. What I really want is that the pop-up gave me a choice to always allow this page to redirect, but continue to warn me. Disabling seems dangerous. </blockquote> This ancient feature was designed in a more innocent time to help prevent users of assistive software such as screen readers from losing their place. It was never intended as a security feature and has not been updated to accounts for the myriad ways that modern websites work. Maybe someone will step forward and rewrite this part of Firefox in a future version, but until then, it's broken on many sites and you either need to turn it off or live with its problems.
Was this helpful to you? 2
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.