X
Tap here to go to the mobile version of the site.

Support Forum

Firefox doesn't autofill all bookmarks in URL bar

cj
Posted

My Firefox 56.0 (64bit) has problem with autofill in urlbar. Only few bookmarks are autocompleting. In Firefox's privacy options there are bookmarks suggestions option checked of course. In about:config there is 2 entries named: browser.urlbar.autofill and browser.urlbar.autoFill. Both set as true. PLS help

My Firefox 56.0 (64bit) has problem with autofill in urlbar. Only few bookmarks are autocompleting. In Firefox's privacy options there are bookmarks suggestions option checked of course. In about:config there is 2 entries named: browser.urlbar.autofill and browser.urlbar.autoFill. Both set as true. PLS help

Chosen solution

I deleted a user.js file and change browser.urlbar.autofill.typed to false. Looks like it works. Thanks so much.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

More Information

Tonnes
  • Top 25 Contributor
  • Locale Leader
200 solutions 1197 answers

Helpful Reply

Does the same happen when you right-click and Reset the browser.urlbar.autofill preference, and then restart Firefox? That one is not default, only browser.urlbar.autoFill is and hence should not display in bold / as "modified".

Does the same happen when you right-click and Reset the ''browser.urlbar.autofill'' preference, and then restart Firefox? That one is not default, only browser.urlbar.auto'''F'''ill is and hence should ''not'' display in bold / as "modified".
Was this helpful to you? 1
Quote

Question owner

1. reset settings to not modified 2. restart firefox 3. browser.urlbar.autofill still bold

(
1. reset settings to not modified 2. restart firefox 3. browser.urlbar.autofill still bold :(
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15847 solutions 143356 answers

Helpful Reply

There should be:

  • browser.urlbar.autoFill
  • browser.urlbar.autoFill.typed

Note that pref names are case sensitive and if you reset a non existing pref then you should see an empty string pref and the pref should be removed on the next start. If that isn't happening then you probably have a user.js file in the profile folder that sets this pref.

There should be: *browser.urlbar.autoFill *browser.urlbar.autoFill.typed Note that pref names are case sensitive and if you reset a non existing pref then you should see an empty string pref and the pref should be removed on the next start. If that isn't happening then you probably have a user.js file in the profile folder that sets this pref. *http://kb.mozillazine.org/user.js_file
Was this helpful to you? 1
Quote
Tonnes
  • Top 25 Contributor
  • Locale Leader
200 solutions 1197 answers

This may indicate the browser.urlbar.autofill preference is added by an Add-on or configured in an external file in your profile path, such as user.js or, prefs.js.moztmp. If you are not aware of it, an add-on can put it there and may keep doing so after removing it.

Try to find a file named user.js or prefs.js.moztmp: open Help (press Alt when needed or use the menu button) > Troubleshooting Information and click Open Folder - this is the profile folder. If you see such a file there, close Firefox, then move the file elsewhere, restart Firefox and check its behavior and whether the file gets restored or not (possibly after closing Firefox).

However if you reset the preference like you did and run Firefox in its Safe Mode (hold down Shift for a few seconds or choose Restart with add-ons disabled in the (Alt + ) Tools menu), any preference should not be added because add-ons are disabled and URL bar behavior should be fine. Can you verify?

Also see: How to fix preferences that won't save Reset Firefox preferences to troubleshoot and fix problems

(...) Actually, and specific to behavior: by default, Firefox only searches bookmarks for the URL bar that you typed once and leaves out others by design. In order to avoid that, set browser.urlbar.autoFill.typed to false. Also see this question.

This may indicate the browser.urlbar.auto'''f'''ill preference is added by an Add-on or configured in an external file in your [[Use the Profile Manager to create and remove Firefox profiles|profile]] path, such as user.js or, prefs.js.moztmp. If you are not aware of it, an add-on can put it there and may keep doing so after removing it. Try to find a file named user.js or prefs.js.moztmp: open ''Help'' (press Alt when needed or use the menu button) > ''Troubleshooting Information'' and click ''Open Folder'' - this is the profile folder. If you see such a file there, close Firefox, then move the file elsewhere, restart Firefox and check its behavior and whether the file gets restored or not (possibly after closing Firefox). However if you reset the preference like you did and run Firefox in its Safe Mode (hold down Shift for a few seconds or choose ''Restart with add-ons disabled'' in the (Alt + ) Tools menu), any preference should not be added because add-ons are disabled and URL bar behavior should be fine. Can you verify? Also see: [[How to fix preferences that won't save]] [[Reset Firefox preferences to troubleshoot and fix problems]] (...) Actually, and specific to behavior: by default, Firefox only searches bookmarks for the URL bar that you ''typed'' once and leaves out others by design. In order to avoid that, set '''browser.urlbar.autoFill.typed''' to ''false''. Also see [/questions/937709 this question].
Was this helpful to you? 1
Quote

Chosen Solution

I deleted a user.js file and change browser.urlbar.autofill.typed to false. Looks like it works. Thanks so much.

I deleted a user.js file and change browser.urlbar.autofill.typed to false. Looks like it works. Thanks so much.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.