Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox slowing down because of "Performing TLS Handshake"

  • 2 replies
  • 55 have this problem
  • 15848 views
  • Last reply by jessopelli

more options

Over the last 2 or 3 days Firefox is suddenly plagued by the "Performing TLS Handshake" delay which makes it near impossible to use. I can go directly to some pages just fine like say, Facebook, but if I want to check notifications or go to a link from there it gets stuck on "Performing TLS Handshake" and eventually gives up. Some pages never load at all like the Roblox site my kids love. Tried to research it and I tried getting a new profile, starting up FF in safe mode, refreshing FF, refreshing without add-ons and nothing seems to work. I don't know much about computers so any advice will be helpful. I don't have this problem on Chrome or Edge but I really don't want to have to switch. I'm currently using version 55.0.3. Thanks!

Chosen solution

You can try to disable IPv6 (check for other possible causes as well).

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Read this answer in context 👍 6

All Replies (2)

more options

Chosen Solution

You can try to disable IPv6 (check for other possible causes as well).

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

I tried the IPv6 option and it didn't seem to do anything. I restarted FF and I still had the problem. So I rebooted in safe mode but couldn't figure out how to do that and keep the network so I couldn't test it in safe mode. When I restarted in normal mode it suddenly started working. I have no idea what it was-maybe the IPv6 worked after I restarted? So I'm not sure if it will last but for now it's back to normal and I don't have to keep using Chrome. Thank you for your help!