Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube video Purple and Green

  • 12 replies
  • 502 have this problem
  • 35367 views
  • Last reply by James

more options

Youtube started last night playing videos purple and green. I have updated everything. It plays fine on safe mode.

Chosen solution

hi, we are currently aware about this on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue.

otherwise you can do the following to work around the problem: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.use-nv12-format. double-click it and change its value to false.

Read this answer in context 👍 70

All Replies (12)

more options

Hey, can you do me a favor and try this Chosen Solution; https://support.mozilla.org/en-US/questions/1078076

It seems to be relative to your incident.

more options

.....

Modified by Cranidos

more options

Zachary_ said

Hey, can you do me a favor and try this Chosen Solution; https://support.mozilla.org/en-US/questions/1078076 It seems to be relative to your incident.

I did try that, but it didn't help.

more options

You've updated flash players, drivers etc? Is this for all Youtube videos? and can you please provide a screen shot of the applied video please. Just to see the exact locates.

more options

Zachary_ said

You've updated flash players, drivers etc? Is this for all Youtube videos? and can you please provide a screen shot of the applied video please. Just to see the exact locates.

Yes, this morning I ran updates on everything to make sure. It happens to every video. its only happening in Firefox

I.E and Chrome are fine.
more options

Have you tried downloading and testing the 32-bit version of Firefox (if you aren't currently using it)? I didn't have this problem until I updated Firefox 55.0.3 to 64-bit, and changing back to 32-bit fixed this issue for me even though I run a 64-bit system with 16 gigs of RAM.

more options

same problem for me -- tuesday 11-14-2017 -- a new firefox update today screwed up my you tube - even tho i am signed into firefox and you tube -- i get the same purple & green colors for video display as in the images poster grandios provided. google and internet explorer are fine and display you tube videos correctly with no issues.

its a firefox problem -- so how does firefox expect us to fix something caused by a firefox update which corrupted you tube displays -- why do i have to update drivers or flash when they work perfectly with google and internet explorer ???!!!

Modified by Joseph_Frank

more options

You Tube Video PROBLEM SOLVED NOW for me -- see below:

I am running WIN 8.1 - 1 Terrabyte Storage / 8GB Ram, 64 bit system

OK -- I called MSN Support tonite 11-14-2017 and had my MSN "Assure" techs ( an annual paid support program I have) enter my computer on line (shared assist program) -- and after the tech viewed the problem and situation, he then did an UNINSTALL of Firefox and a new RE-INSTALL of Firefox latest browser. That DID NOT fix the purple & green You Tube videos on Firefox.

However, as I stated previous, videos previously and still now, played properly on Internet Explorer and Google Chrome.

Next the Tech support agent installed the newest version of my AMD Radeon Graphics Card program -- and restarted my computer --- and VOILA !! THAT FIXED the You Tube Video performance on Firefox --- all works well now. The You Tube videos play properly on Firefox now.

Perhaps this info will help those with the issue.

========================================================

UPDATE NOTE: WHILE THIS fixed the problem with purple-green videos - it CAUSED ANOTHER PROBLEM

========

The 3d Format (3D to 2D) on google maps aerial image views was now gone -- with a notation at page bottom "3D is not avail;able with this browser" -- So I had to have the AMD Graphics Card changed to a newer version -- and that fixes the problem

THEN, the Videos purple-green came back --- so I went to the steps in the message below (pasted as follows)

QUOTE: otherwise you can do the following to work around the problem: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.use-nv12-format. double-click it and change its value to false.

I took these steps and now videos playback is fixed and operating properly !!

Modified by Joseph_Frank

more options

Chosen Solution

hi, we are currently aware about this on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue.

otherwise you can do the following to work around the problem: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.use-nv12-format. double-click it and change its value to false.

more options

Hello ALL

I tried this fix -- typing about.config in Firefox address bar and going thru the steps.

When I changed the media.windows-media --(etc etc) from TRUE to FALSE -- and left the page --- my videos work fine.

more options

I have Windows 10, Nvidia GPU with drivers updated just yesterday to the newest version.

This issue of video playback exists in every site that has video for playback that I normally view.

This has been a long ongoing issue for over a year. It gets better, then it starts up again. It's fine for the first video after a reboot. Sometimes I found if I pause playback, jump forward then resume playback it goes away. Sometimes I just give up and copy the link into Chrome... one should not have to do that...

more options

https://www.mozilla.org/firefox/57.0.1/releasenotes/

Firefox 57.0.1 has a fix for those using AMD graphics.