Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

why are online videos green and purple since the latest Firefox update?

  • 13 replies
  • 62 have this problem
  • 8786 views
  • Last reply by Happy112

more options

YouTube, ESPN, and other website videos all play back in green and purple. Were playing fine earlier today before the latest Firefox update.

Chosen solution

hi, we are currently aware about this on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue.

otherwise you can do the following to work around the problem: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.use-nv12-format. double-click it and change its value to false.

Read this answer in context 👍 8

All Replies (13)

more options

See if you can get any better Video Card Rivers for your AMD Radeon HD 8400 driverDate: 9-25-2013 a couple errors I see. https://support.amd.com/en-us/download/auto-detect-tool

Also new engine takes pages and turns to CSS then out puts as pixels.

57 maybe too much for your video card drivers.

You may want to consider going to the ESR Version 52.4.1it gets Security updates. https://www.mozilla.org/en-US/firefox/organizations/all/

Please let us know if this solved your issue or if need further assistance.

more options

My video driver is up to date. I am an individual, so I don't see ESR being applicable to me ("Firefox ESR is intended for...large organizations"). My computer is not that old, so it should be able to handle software upgrades without having to invest in new hardware. Seems that Mozilla needs to fix a bug in their newest version of Firefox,

more options

It just says " intended for...large organizations" because companies don't like dealing with sudden big changes, so a version that goes through slower changes is best for them. Nothing stops you from using it as a single human being at your home.

more options

Some people have reported un-clicking - use hardware acceleration when available - has solved this problem. Learn how at this link. Remember to re-start Firefox after making the change.

https://support.mozilla.org/en-US/kb/performance-settings?as=u&utm_source=inproduct

more options

Since yesterday I have had this problem. I may just have to stop using Firefo altogether. it seems that each update makes it more and more unusable. Do you change things just to change things? It's certainly not making it better.

more options

Yes, nymormon, that was my next thought. Having no problems with Google Chrome. Maybe I'll check Firefox next week to see if they have fixed their new version to work for normal people.

more options

Chosen Solution

hi, we are currently aware about this on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue.

otherwise you can do the following to work around the problem: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.use-nv12-format. double-click it and change its value to false.

more options

That seems to have solved the problem. Thanks!

more options

steve7u said

That seems to have solved the problem. Thanks!

Hi  !

Could you let us know what exactly it was that did it  ?

Was it changing the preference in 'about:config'  ?

more options

Yes, it was changing the value to "false" in 'about:config' that fixed mine.

more options

I don't have a preference named media.windows-media-foundation.use-nv12-format. Do I just create it?

more options

steve7u schrieb

YouTube, ESPN, and other website videos all play back in green and purple. Were playing fine earlier today before the latest Firefox update.

The solution that worked for me was under about:config changing media.hardware-video-decoding.failed to the value: true.

I also didn't have media.windows-media-foundation.use-nv12-format.

more options

Allan said

I don't have a preference named media.windows-media-foundation.use-nv12-format. Do I just create it?

That preference now is : media.wmf.dxva.d3d11.enabled

(and set its value to false)