Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This address is restricted: how to access any port?

  • 1 reply
  • 2 have this problem
  • 3 views
  • Last reply by cor-el

more options

I am trying to get to a specific port and Firefox blocks the access, https://x.x.x.x:xxxxx. This is the message:

This address uses a network port which is normally used for purposes other than Web browsing. Firefox has canceled the request for your protection.

How can I allow a specific port? I have searched for the answer and the suggested solution everywhere: "network.security.ports.banned.override" does not exist in about:config, Please don't close this question on account of it being already answered, because even the solution suggested by the kb is out of date and doesn't work. What I need is an answer that works on modern firefox. (why do I use unusual ports? I develop some remote telemetry for embedded systems using REST and a browser is a quick and simple way to verify external connectivity, and no, not every service can use 80 or 443).

I am trying to get to a specific port and Firefox blocks the access, https://x.x.x.x:xxxxx. This is the message: This address uses a network port which is normally used for purposes other than Web browsing. Firefox has canceled the request for your protection. How can I allow a specific port? I have searched for the answer and the suggested solution everywhere: "network.security.ports.banned.override" does not exist in about:config, Please don't close this question on account of it being already answered, because even the solution suggested by the kb is out of date and doesn't work. What I need is an answer that works on modern firefox. (why do I use unusual ports? I develop some remote telemetry for embedded systems using REST and a browser is a quick and simple way to verify external connectivity, and no, not every service can use 80 or 443).

All Replies (1)

more options

You need to create a new String pref named network.security.ports.banned.override since this pref doesn't exist by default.