Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website is displayed properly in private browsing mode, but not in regular Firefox mode

  • 2 replies
  • 1 has this problem
  • 3135 views
  • Last reply by Duke0486

more options

Hello,

When visiting my business website in Firefox, I encounter some issues in how it's displayed. However, the issues go away when I visit my site in Firefox private browsing mode. The issues are only visible when not in private browsing mode. Furthermore, these issues are only occurring in Firefox, not Chrome or Microsoft Edge.

I thought it might be a cookies or cache issue, so I cleared those, but it didn't help. Any idea what could be causing this and how to fix?

Thanks! Scott

Chosen solution

When you are in Private Browsing mode then the disk cache isn't used and you have a separate cookie jar.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

When you are in Private Browsing mode then the disk cache isn't used and you have a separate cookie jar.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Thank you!