Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

connection not secure

  • 11 replies
  • 1 has this problem
  • 8 views
  • Last reply by richie70

more options

I use a private VPN called IPVanish and Firefox gives me "your connection is not secure". If I stop the VPN then Firefox allows the connection.

  How can I use my VPN and not have a conflict with Firefox? If I use Chrome I don't have this issue. 
see attachment.  
 Hope someone has a good answer.
I use a private VPN called IPVanish and Firefox gives me "your connection is not secure". If I stop the VPN then Firefox allows the connection. How can I use my VPN and not have a conflict with Firefox? If I use Chrome I don't have this issue. see attachment. Hope someone has a good answer.
Attached screenshots

All Replies (11)

more options

Could you click the Advanced button on that error page? That should display a little more technical detail and a CODE_IN_ALL_CAPS. That information is helpful in tracking down specific solutions, so please paste it all here. Thanks.

more options

Maybe also check the certificate chain in another browser that works (Google Chrome) to see how this browser handles this VPN.

more options

Attached is the screen shot after clicking on Advanced. I will check Chrome for Certificate Chain.

 Thanks
more options

It seems that Chrome, 59, has made it very difficult to see the certificate chain and you must have to be a programmer to even understand it.

 I have found a solution to disable the function that sends this warning by going into about:config and changing
" security.insecure_field_warning.contextual.enabled to false" but am reluctant to do this.
more options

Thanks for the screenshot. Can you click that blue code, then copy/paste the encoded version of the doubtful certificate into a reply? The line of dashes may change to a horizontal bar, don't worry about that.

On the preference you mentioned, that is a different thing only for HTTP addresses, not HTTPS addresses. See: Insecure connection password warning in Firefox.

more options

Note that in Google Chrome you can click the padlock on the location/address bar and go to the Connection tab. There you see a link to show the Certificate Information.

more options

Here are screen shots of the latest connection not secure.

 As for chrome IT WORKS OK. The issue is with Firefox.
more options

I see you selected (blue highlight) the coded version of the certificate, but in order for us to be able to decode it, we need you to paste it as text (not an image) into a reply. Otherwise, it's waaaaaaay too much typing.

more options

https://citicards.citi.com/usc/crs/searscard/home.htm?JFP_TOKEN=3APTI1ZK

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: false HTTP Public Key Pinning: false

Certificate chain:


BEGIN CERTIFICATE-----

MIIELTCCAxWgAwIBAgIJAK8KlrO+YplQMA0GCSqGSIb3DQEBCwUAMFQxITAfBgNV BAMMGFVudHJ1c3RlZCBCaXRkZWZlbmRlciBDQTEMMAoGA1UECwwDSURTMRQwEgYD VQQKDAtCaXRkZWZlbmRlcjELMAkGA1UEBhMCVVMwHhcNMTYxMjAzMDAwMDAwWhcN MTgwNDIwMjM1OTU5WjCCARsxEzARBgsrBgEEAYI3PAIBAxMCVVMxGTAXBgsrBgEE AYI3PAIBAgwIRGVsYXdhcmUxHTAbBgNVBA8TFFByaXZhdGUgT3JnYW5pemF0aW9u MRAwDgYDVQQFEwcyMTU0MjU0MQswCQYDVQQGEwJVUzEOMAwGA1UEEQwFMTAwNDMx ETAPBgNVBAgMCE5ldyBZb3JrMREwDwYDVQQHDAhOZXcgWW9yazEYMBYGA1UECQwP Mzk5IFBhcmsgQXZlbnVlMRcwFQYDVQQKDA5DaXRpZ3JvdXAgSW5jLjElMCMGA1UE CwwcQ2l0aSBDYXJkcyBJbnRlcm5ldCBTZXJ2aWNlczEbMBkGA1UEAwwSY2l0aWNh cmRzLmNpdGkuY29tMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA1XJG SERN8Yposk7hgZTW3pQ1piuLyphfihs4KjTRycPpMiaVrUCz8cqiDH2KlRO9RpnJ KwntPsh5fyohGvLvzD0DJEmpm0+ON4hJEnWQvn6IAfR0tVne6XJlSzHflsRlLd+y cLrc+KotKomqDkk+Vje0PAMuPxHaFFF77vxhZ0DIjnieBGa2t/8NG89VuDJi15cw urmmflKu0hWLFFbw7J2MudwXtU7fc+bA2q8/FpQ0x7oe1/B7zyGcbh5LFn1GfPZN Ghfc8EKef8zYhfuw/cccWGlxLeri63scjT6Ugy5lUq3L8XGWZTC27TROa0GestYB bBdaofpG4ky9cH5CDwIDAQABozkwNzA1BgNVHREELjAsghZ3d3cuY2l0aWNhcmRz LmNpdGkuY29tghJjaXRpY2FyZHMuY2l0aS5jb20wDQYJKoZIhvcNAQELBQADggEB AKrAXeijmWDiIh/qRRZtcR6WIktx79WjP8yXJQqsohkU4/3pI31rxzJ6JQxWR9LO Xoj0HmVt4RkzZMuIcExPmfVxHOnzvi6bYwqbYcZnGVhe97apwmt2WvK8W+hzJvWa eyiypA+KGFNq4Hl2dEI9+mJQ7AkrFRfwTl4xQ9NghwId15LN21Ae/ExwwXX36ic9 +kFvzT0iuUP+BbJuoTMfhTrf+YOrG3COntTzrJKOFlotwe30GY9Al3LU6ebf/NLh tPpgDqdmgUtmpfs/hwyC69nUrVNKLj30rsdmRByBpRhl5d9fgAoTCoouxE9DAvyG sXvMsecRwqThYWT2qgOxVu8=


END CERTIFICATE-----

I also have it as a word doc if needed.

more options

The issuer is reported as follows:

Issuer O = Bitdefender, CN = Untrusted Bitdefender CA

Is there a connection between your VPN provider and Bitdefender proxying (filtering) your browsing through the VPN?

Info on Bitdefender filter in this article: How to troubleshoot security error codes on secure websites.

more options

I toggled off "Scan SSL". Will see what happens moving forward.

 Thanks