Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Buffer full video or make buffer bigger

  • 11 replies
  • 12 have this problem
  • 29164 views
  • Last reply by Unrealshade

more options

Hi all, so since a few versions I have noticed a difference in video buffering. Firefox now buffers a very small amount of a video, like it does when mediasource extensions are turned on. I did turn them off however so videos were usually downloaded automatically all the way, which was very convenient for me, instead of just when you play the video the next few seconds. This doesn't work anymore as if I enabled mediasource extensions and every video used it.

Is there some way to revert that behaviour? I guess it was done out of performance reasons. How can I change it back, e.g. make the video buffer bigger?

Thanks a lot

Chosen solution

There is an easy fix for it just increase media.cache_readhead_limit to 9999 and media.cache_resume_treshold also to 9999. This was also puzzling me since firefox 54 would buffer till the end of the video but firefox 55 wouldn't, so I went trough the about:config and found those two lines once I chagned their values from (60, 30) to those above every single video I opened in firefox so far buffered till the end, you don't even need to restart the firefox just refresh the page for changes to take the effect. Hope this helped.

Read this answer in context 👍 12

All Replies (11)

more options
more options

Hello Pkshadow, thanks for your reply! I'm on GNU+Linux Firefox 55 beta 11, but the problem has been there since a few versions already.

The articles you provided help with general issues if it doesn't work for example, but it works for me. I just want to make the buffer bigger. Deleting the cache didn't help either. I'm trying to find a general solution, so not just youtube and without an addon would be nice. It did work previously, so it should be possible to make it work again.

more options

Ok, \Little confused. Do you want to make the buffer bigger or. You have a confusing statement in your question. Could you please clarify it.

more options

Sure, what statement do you find confusing?

I want to make the video buffer bigger. So right now, every video gets buffered automatically like 2 minutes. Firefox version 40 (or something) actually buffered the whole video. This was convenient for me and I want that behaviour back, so always buffer the whole video or at least 30 minutes. I'm guessing there is a restriction setting for that somewhere, but I can't find it.

more options

Could you check this URL out please, about 1/2 way down the page for Firefox. https://beebom.com/how-force-youtube-fully-buffer-video-chrome-firefox/

You can check where I found this for other information that may help : https://www.google.ca/search?q=firefox+2017+increase+video+buffer&ie=utf-8&oe=utf-8&gws_rd=cr&ei=2d93Wf_bFMaV0wKG9JioDQ

I do not know what video card your using but can you make sure the drivers are update and if are can you uninstall and reinstall them please in-case anything is corrupted. Also please check your video card documentation regarding this issue along with the cards forums. Thanks.

Please let us know if this solved your issue or if need further assistance.

more options

Thanks, I also found this site, but it only suggests what I already did: disabling mediasource extensions. I found no other useful websites through my search, so I hoped to find experts here.

It worked with the same video card and driver before, so I don't think this is the problem.

However you gave me the idea to try it on another device and it did work there. I just found out that it also works correctly on my device when I use version 54 stable instead of 55 beta. So I think I found a bug or a change that I don't want to happen. I think I'll report it on Bugzilla. Thanks for your help.

Modified by Unrealshade

more options
more options

Chosen Solution

There is an easy fix for it just increase media.cache_readhead_limit to 9999 and media.cache_resume_treshold also to 9999. This was also puzzling me since firefox 54 would buffer till the end of the video but firefox 55 wouldn't, so I went trough the about:config and found those two lines once I chagned their values from (60, 30) to those above every single video I opened in firefox so far buffered till the end, you don't even need to restart the firefox just refresh the page for changes to take the effect. Hope this helped.

more options

Thanks so much Oloferno :-) I also thought there was a setting for this in about:config but I didn't think it'd be easy to find. Smart!

You are missing an a in media.cache_readahead_limit btw. Also it's enough to make this one bigger. Don't know what media.cache_resume_threshold does. Everything's as it was before, nice!

more options

Oloferno said

There is an easy fix for it just increase media.cache_readhead_limit to 9999 and media.cache_resume_treshold also to 9999. This was also puzzling me since firefox 54 would buffer till the end of the video but firefox 55 wouldn't, so I went trough the about:config and found those two lines once I chagned their values from (60, 30) to those above every single video I opened in firefox so far buffered till the end, you don't even need to restart the firefox just refresh the page for changes to take the effect. Hope this helped.

You legend, was also having this exact same issue, with youtube and other sites i use and this fixed it.

more options

Hey siggy, very happy to have helped you :D Best regards