Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The URL bar is not working: the 'Enter' key doesn't result in anything happening, neither does clicking the arrow: no going to the address & no searching

  • 5 replies
  • 40 have this problem
  • 685 views
  • Last reply by jscher2000

more options

pretty much what I've said above. there is no error message simply nothing happens the only way I can go to a website (or do a search), is use the 'Search' box, then click the URL I was looking for in the search results. Even entering a known and correct url in the url bar does nothing... the cursor just sits flashing at the end of the last character I entered before hitting 'Enter'

All Replies (5)

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

See also:

more options

The above solution does not work. It has nothing to do with plug-ins or add-ons, most of which are disabled by the latest update anyway.

the problem is in the privacy settings. When I restarted FF this morning, I noticed the settings HAD BEEN CHANGED ON THEIR OWN. The location bar was autocompleting, which I hate. The "enter" key worked fine as long as ALL THREE auto-complete settings were checked: History, Bookmarks, & Open Tabs.

When I unchecked these, the enter key stopped working in the search bar. So here is your problem. This feature in the settings must be repaired in order to restore functionality to the "enter" key in the address bar when "suggestions" are all unchecked.

more options

Try to set browser.urlbar.maxRichResults to 0 instead and leave browser.urlbar.autocomplete.enabled set to true by at least enabling one suggestion (e.g. open tabs) in "Options/Preferences -> Privacy".

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

If you have tried all these and is still not working then you try the steps below-

1) Go to the root folder where Firefox is installed it is generally installed in "C:\Program Files\Mozilla Firefox)" 2) Right-click Firefox- properties-details tab and click on Remove properties and personal information-just click ok 3) now a new firefox - Copy.exe is created

   use the new one as your default browser

I hope this helps

Modified by ram

more options

Hi ram, when you find that program.exe doesn't work but renaming to program1.exe does work, this can indicate a malware infection. You might also want to review: Troubleshoot Firefox issues caused by malware.