X
Tap here to go to the mobile version of the site.

Support Forum

Firefox and Adobe Flash CONFLICT

Posted

Firefox is my favorite browser by far, but the Firefox issues with Adobe Flash are a major nuisance that goes on and on.

If under the plugins section of the Firefox Add-ons Manager I chose the "Always Activate" option for Shockwave Flash, then YouTube videos play automatically - I do not want YouTube videos to play automatically. But if I chose the Ask to Activate option in the Add-ons Manager, YouTube doesn't auto play as I prefer, but at other sites I'm forever being asked if I want to activate flash, then if I say yes, the box pops up asking, Allow Now or Allow and Remember? A continual pain. What is the solution? Thank you for any help. I'm using the latest Firefox edition, 54.0.1 (64 bit).

Firefox is my favorite browser by far, but the Firefox issues with Adobe Flash are a major nuisance that goes on and on. If under the plugins section of the Firefox Add-ons Manager I chose the "Always Activate" option for Shockwave Flash, then YouTube videos play automatically - I do not want YouTube videos to play automatically. But if I chose the Ask to Activate option in the Add-ons Manager, YouTube doesn't auto play as I prefer, but at other sites I'm forever being asked if I want to activate flash, then if I say yes, the box pops up asking, Allow Now or Allow and Remember? A continual pain. What is the solution? Thank you for any help. I'm using the latest Firefox edition, 54.0.1 (64 bit).

Chosen solution

One solution would be to remove Flash Player entirely, but I think you want to keep it for websites that still require it.

The reason for these repetitive questions is those permissions can be overridden per page/domain. Since you may want to "block" the Flash plugin from being used on YouTube only, did you try opening the Page permissions and change them for YouTube?

You would need to:

  1. Set Flash to Ask to Activate
  2. Visit any YouTube page
  3. Right-click the page, choose View Page Info
  4. Click the Permissions panel
  5. In the top entry for Activate Plugins, select Block

See the Firefox Page Info window article.

However, if you don’t want to have YouTube videos to play automatically, that may be unrelated to actvating Flash since they will play by default using the HTML5 player even when blocking Flash. For that purpose, you can set the media.autoplay.enabled preference to false in about:config by double-clicking it. There is also the FlashStopper add-on, but a) I don’t think you need it, and b) it suffers some issues currently, though they will probably be fixed soon.

Does this help?

Read this answer in context 3
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • Firefox 54.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
  • Support URL: https://support.mozilla.org/1/firefox/54.0.1/WINNT/en-US/

Extensions

  • (ESCapeFromThemGIFs) 0.1.1-signed.1-signed (escapefromthemgifs@ishotandywarhol.com)
  • Adblock Plus 2.9.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AdBlocker for YouTube™ 0.2.5 (jid1-q4sG8pYhq8KGHs@jetpack)
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Custom New Tab 3.2 (CNT@ednovak.net)
  • Cut, copy and paste Tabs 1.0.4.1-signed.1-signed (ccptabs@vovcacik.addons.mozilla.org)
  • deskCut 0.6.0.3.1-signed.1-signed ({9125C9CB-BE2B-4389-A0C7-46A4BDD46AEA})
  • Download YouTube Videos as MP4 1.8.10 ({b9bfaf1c-a63f-47cd-8b9a-29526ced9060})
  • Duplicate in Tab Context Menu 3.0.1 (DuplicateInTabContext@schuzak.jp)
  • Element Hiding Helper for Adblock Plus 1.4 (elemhidehelper@adblockplus.org)
  • Firefox Screenshots 6.6.0 (screenshots@mozilla.org)
  • Ghostery 7.2.2 (firefox@ghostery.com)
  • h264ify 1.0.5 (jid1-TSgSxBhncsPBWQ@jetpack)
  • Menu Wizard 5.08 (s3menu@wizard)
  • Multi-process staged rollout 1.50 (e10srollout@mozilla.org)
  • New Tab Homepage 0.5.3 ({66E978CD-981F-47DF-AC42-E3CF417C1467})
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Show my Password 2.0.1-signed.1-signed ({cd617372-6743-4ee4-bac4-fbf60f35719e})
  • Stylish 2.0.7 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • UnMHT 8.3.2 ({f759ca51-3a91-4dd1-ae78-9db5eee9ebf0})
  • URL Fixer 4.1.2 ({0fa2149e-bb2c-4ac2-a8d3-479599819475})
  • Web Compat 1.1 (webcompat@mozilla.org)
  • YesScript 2.2 (yesscript@userstyles.org)
  • YouTube No Buffer 0.1.6 (jid0-zxGf4jM5hHg1dJ5Gf1H7NfFfe76@jetpack)
  • Youtube's Annotations No More 0.3 (jid1-ss6kLNCbNz6u0g@jetpack)
  • uBlock Origin 1.13.4 (uBlock0@raymondhill.net) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0042
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 304a103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 1-10-2012
  • driverDate2:
  • driverVersion: 8.15.10.2622
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'disabled', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'default'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • webgl1DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_pack_reverse_row_order GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_frag_depth GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_fence GL_NV_pack_subimage GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic MOZ_debug_get OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.2a250c8a0e15)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 00000000000077cc) EGL_VERSION: 1.4 (ANGLE 2.1.0.2a250c8a0e15) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Tonnes
  • Top 25 Contributor
  • Locale Leader
184 solutions 1064 answers

Chosen Solution

One solution would be to remove Flash Player entirely, but I think you want to keep it for websites that still require it.

The reason for these repetitive questions is those permissions can be overridden per page/domain. Since you may want to "block" the Flash plugin from being used on YouTube only, did you try opening the Page permissions and change them for YouTube?

You would need to:

  1. Set Flash to Ask to Activate
  2. Visit any YouTube page
  3. Right-click the page, choose View Page Info
  4. Click the Permissions panel
  5. In the top entry for Activate Plugins, select Block

See the Firefox Page Info window article.

However, if you don’t want to have YouTube videos to play automatically, that may be unrelated to actvating Flash since they will play by default using the HTML5 player even when blocking Flash. For that purpose, you can set the media.autoplay.enabled preference to false in about:config by double-clicking it. There is also the FlashStopper add-on, but a) I don’t think you need it, and b) it suffers some issues currently, though they will probably be fixed soon.

Does this help?

One solution would be to remove Flash Player entirely, but I think you want to keep it for websites that still require it. The reason for these repetitive questions is those permissions can be overridden per page/domain. Since you may want to "block" the Flash plugin from being used on YouTube only, did you try opening the Page permissions and change them for YouTube? You would need to: # Set Flash to Ask to Activate # Visit any YouTube page # Right-click the page, choose View Page Info # Click the Permissions panel # In the top entry for Activate Plugins, select ''Block'' See the [[Page Info window - View technical details about the page you are on]] article. However, if you don’t want to have YouTube videos to play automatically, that may be unrelated to actvating Flash since they will play by default using the HTML5 player even when blocking Flash. For that purpose, you can set the '''media.autoplay.enabled''' preference to ''false'' in about:config by double-clicking it. There is also the [https://addons.mozilla.org/firefox/addon/flashstopper/ FlashStopper add-on], but a) I don’t think you need it, and b) it suffers some issues currently, though they will probably be fixed soon. Does this help?
Was this helpful to you? 3
Quote

Question owner

Tonnes, you are a very knowledgeable and a great help! Thank you!!

Tonnes, you are a very knowledgeable and a great help! Thank you!!
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.