X
Tap here to go to the mobile version of the site.

Support Forum

Cursor turns into hand over link, link cannot be clicked

Posted

This is clearly a Firefox problem b/c it is not an issue in other browsers. I have tried refreshing and restarting my computer. Once the arrow goes away and the hand appears, all is lost. the link is useless. This has happened several times in the last few months but this time it is happening on NPR when I try to listen to the broadcast. If I use Safari, it works fine. I have been loyal to Firefox though thick and thin but this is taking me to the point of reconsidering - too many useless links that I have to use another browser for.

This is clearly a Firefox problem b/c it is not an issue in other browsers. I have tried refreshing and restarting my computer. Once the arrow goes away and the hand appears, all is lost. the link is useless. This has happened several times in the last few months but this time it is happening on NPR when I try to listen to the broadcast. If I use Safari, it works fine. I have been loyal to Firefox though thick and thin but this is taking me to the point of reconsidering - too many useless links that I have to use another browser for.

Chosen solution

Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

To try Firefox in Safe Mode:

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

If you notice what's causing your issues, please let us know. It might help others with the same problem.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_5) AppleWebKit/603.2.4 (KHTML, like Gecko) Version/10.1.1 Safari/603.2.4

More Information

bygabyga 15 solutions 171 answers

Hi

Does it also happen in safe mode?

Are you using an up to date release of Firefox?

Could you post websites of where this happens?

Thank you

Hi Does it also happen in [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode safe mode]? Are you using an up to date release of Firefox? Could you post websites of where this happens? Thank you

Question owner

Hi,

Never tried in safe mode- do not know how get to that. Yes, using an up to date release of Firefox. As I mentioned in my post, it is currently happening on NPR- http://www.npr.org. The last time it happened it was on https://www.seizethedeal.com/cities/augusta-waterville.

Thank you.

Hi, Never tried in safe mode- do not know how get to that. Yes, using an up to date release of Firefox. As I mentioned in my post, it is currently happening on NPR- http://www.npr.org. The last time it happened it was on https://www.seizethedeal.com/cities/augusta-waterville. Thank you.
bygabyga 15 solutions 171 answers

Chosen Solution

Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

To try Firefox in Safe Mode:

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

If you notice what's causing your issues, please let us know. It might help others with the same problem.

[[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). To try Firefox in Safe Mode: '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' If you notice what's causing your issues, please let us know. It might help others with the same problem.

Question owner

It did not happen in safe mode, so I followed the instructions to troubleshoot in the link you sent- thank you. I identified an extension that seemed to be the issue, but after I disabled it (and it worked), I enabled it again and it worked again. I'm glad for this b/c it's an extension I'm not willing to live without- it would have meant giving up FIrefox, which I really prefer not to do. Now I will know what to try the next time this happens.

Thank you.

It did not happen in safe mode, so I followed the instructions to troubleshoot in the link you sent- thank you. I identified an extension that seemed to be the issue, but after I disabled it (and it worked), I enabled it again and it worked again. I'm glad for this b/c it's an extension I'm not willing to live without- it would have meant giving up FIrefox, which I really prefer not to do. Now I will know what to try the next time this happens. Thank you.
Happy112 561 solutions 5694 answers

@jkarcher1 :

You inadvertently marked your own post as   'Chosen Solution'   ..... Would you be a dear and mark   bygabyga's   post as such   ?

Thank you in advance   !

@jkarcher1 :<BR> You inadvertently marked your own post as &nbsp; 'Chosen Solution' &nbsp; ..... Would you be a dear and mark &nbsp; bygabyga's &nbsp; post as such &nbsp; ? Thank you in advance &nbsp; !