X
Tap here to go to the mobile version of the site.

Support Forum

Why don't my bookmarks show Favicons?

Posted

The title should explain it sufficiently, but the behavior that I expected was for Firefox to automatically pull favicons from websites or at least allow that to be done manually. It appears that this does not happen. Has this been a feature that was removed, a bug, something on my computer, or something else? Basic Google searches didn't reveal much but a couple of addons that can do this process manually, but I am hoping to avoid this (and some of them no longer work).

Visiting websites doesn't cause the favicons to reload, and deleting and readding the bookmark doesn't work.

Yes, the addresses for the bookmarks are correct including the http(s):// prefix

Attached full info about my browser, but it's on Win 10 running Firefox 53.0.3 64 bit version with some extensions.

Any help is greatly appreciated.

The title should explain it sufficiently, but the behavior that I expected was for Firefox to automatically pull favicons from websites or at least allow that to be done manually. It appears that this does not happen. Has this been a feature that was removed, a bug, something on my computer, or something else? Basic Google searches didn't reveal much but a couple of addons that can do this process manually, but I am hoping to avoid this (and some of them no longer work). Visiting websites doesn't cause the favicons to reload, and deleting and readding the bookmark doesn't work. Yes, the addresses for the bookmarks are correct including the http(s):// prefix Attached full info about my browser, but it's on Win 10 running Firefox 53.0.3 64 bit version with some extensions. Any help is greatly appreciated.
Attached screenshots

Chosen solution

moz_favicons shouldn't be empty.

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

See also:

If the Places Maintenance extension can't repair the places.sqlite database then remove all places.sqlite file(s) in the Firefox profile folder to make Firefox rebuild the places.sqlite database from the most recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Read this answer in context 1
Quote

Additional System Details

Application

  • Firefox 53.0.3
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
  • Support URL: https://support.mozilla.org/1/firefox/53.0.3/WINNT/en-US/

Extensions

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Checker Plus for Gmail 20.1.1.2 (checkerplusforgmail@jasonsavard.com)
  • Checker Plus for Google Calendar™ 21.1.4.2 (checkerplusforgooglecalendar@jasonsavard.com)
  • Disconnect 5.18.21 (2.0@disconnect.me)
  • Follow-on Search Telemetry 0.8.0 (followonsearch@mozilla.com)
  • Grammarly for Firefox 8.765.918 (87677a2c52b84ad3a151a4a72f5bd3c4@jetpack)
  • HTTPS Everywhere 5.2.18 (https-everywhere-eff@eff.org)
  • Ink for Google™ 7.8.2 (ink-for-google@carlosjeurissen.com)
  • LastPass: Free Password Manager 4.1.53a (support@lastpass.com)
  • Multi-process staged rollout 1.14 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Shield Recipe Client 1.0.0 (shield-recipe-client@mozilla.org)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Adguard AdBlocker 2.5.11 (adguardadblocker@adguard.com) (Inactive)
  • NoScript 5.0.5 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 960
  • adapterDescription2:
  • adapterDeviceID: 0x1401
  • adapterDeviceID2:
  • adapterDrivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_a2b0acab06663645\nvldumd.dll
  • adapterDrivers2:
  • adapterRAM: 4096
  • adapterRAM2:
  • adapterSubsysID: 39623842
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.15063.0
  • driverDate: 5-1-2017
  • driverDate2:
  • driverVersion: 22.21.13.8205
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'skia', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webgl2Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 960 Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 960 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Fiz 13 solutions 106 answers

In previous versions of Firefox there was an addon called FavIcon Reloader that could do this for you. This worked up until version 48. Unfortunately, there isn't a way to automatically update the FavIcon for new releases of Firefox using e10s. The only way now, I'm aware of, is to visit the website.

In previous versions of Firefox there was an addon called FavIcon Reloader that could do this for you. This worked up until version 48. Unfortunately, there isn't a way to automatically update the FavIcon for new releases of Firefox using e10s. The only way now, I'm aware of, is to visit the website.
Was this helpful to you? 1
Quote

Question owner

I appreciate the response, but visiting the website doesn't refresh the favicon, every single one is empty currently.

I appreciate the response, but visiting the website doesn't refresh the favicon, every single one is empty currently.
Was this helpful to you? 0
Quote
Fiz 13 solutions 106 answers

This support request might be related. Check it out and let us know what you find.

https://support.mozilla.org/en-US/questions/1145126

Try launching Firefox in Safe Mode and see if you can get them to appear.

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode#w_how-to-start-firefox-in-safe-mode

This support request might be related. Check it out and let us know what you find. https://support.mozilla.org/en-US/questions/1145126 Try launching Firefox in Safe Mode and see if you can get them to appear. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode#w_how-to-start-firefox-in-safe-mode
Was this helpful to you? 0
Quote

Question owner

Thanks for finding that for me.

Tried in safe mode, no change.

According to that solution, I don't have a chrome folder, so it doesn't seem to be an issue.

If you have any other tricks up your sleeve, that would be great. Thanks for your help so far!

Thanks for finding that for me. Tried in safe mode, no change. According to that solution, I don't have a chrome folder, so it doesn't seem to be an issue. If you have any other tricks up your sleeve, that would be great. Thanks for your help so far!
Was this helpful to you?
Quote
Fiz 13 solutions 106 answers

Next we can check to see if your favicons are being saved properly in the places.sqlite database file.

Probably best not modify the contents of this database, and probably best to close Firefox beforehand

  1. Download and install http://sqlitebrowser.org/ for win64
  2. Launch DB Browser
  3. Click Open Database
  4. Copy/paste %APPDATA%\Mozilla\Firefox\Profiles\ into the file name box and hit enter
  5. Open the directory listed there
  6. Select and open places.sqlite
  7. Click the 'Browse Data' tab
  8. Select moz_favicons from the table dropdown
  9. Select one of the 'Blob' entries under the 'data' column
  10. Change the 'Mode' drop down on the top right from text to image and see any images appear when you click the cells listed in the 'data' column

Let me know if you get something like what I've attached.

Next we can check to see if your favicons are being saved properly in the places.sqlite database file. '''Probably best not modify the contents of this database, and probably best to close Firefox beforehand''' # Download and install http://sqlitebrowser.org/ for win64 # Launch DB Browser # Click Open Database # Copy/paste %APPDATA%\Mozilla\Firefox\Profiles\ into the file name box and hit enter # Open the directory listed there # Select and open places.sqlite # Click the 'Browse Data' tab # Select moz_favicons from the table dropdown # Select one of the 'Blob' entries under the 'data' column # Change the 'Mode' drop down on the top right from text to image and see any images appear when you click the cells listed in the 'data' column Let me know if you get something like what I've attached.

Modified by Fiz

Was this helpful to you? 1
Quote
Fiz 13 solutions 106 answers

I left out a step, I updated it above

I left out a step, I updated it above
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15462 solutions 140015 answers

Do you at least get the favicon on the tab bar if you open a bookmark in a tab?

You can check the browser.chrome prefs on the about:config page and make sure they have the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Do you at least get the favicon on the tab bar if you open a bookmark in a tab? You can check the <b>browser.chrome</b> prefs on the <b>about:config</b> page and make sure they have the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you?
Quote

Question owner

Fiz, I followed your steps and I don't have a single entry under moz_favicons. Screenshot attached.

Cor-el, I do get favicons in the left of the tab when the tab is open, has no effect on bookmarks.

Fiz, I followed your steps and I don't have a single entry under moz_favicons. Screenshot attached. Cor-el, I do get favicons in the left of the tab when the tab is open, has no effect on bookmarks.
Was this helpful to you?
Quote

Question owner

Cor-el, the browser.chorme prefs are all default

Cor-el, the browser.chorme prefs are all default
Was this helpful to you?
Quote
John99
  • Moderator
971 solutions 13138 answers

Quick comment. Maybe we have been misunderstanding the problem you see.

In fact I note on this Linux ESR install Fx49 Fx45.9 I have default favicons in the bookmarks library and the bookmark dropdown menu, but favicons on the left of the browser tabs.

Quick comment. Maybe we have been misunderstanding the problem you see. In fact I note on this Linux ESR install <s>Fx49</s> ''Fx45.9'' I have default favicons in the bookmarks library and the bookmark dropdown menu, but favicons on the left of the browser tabs.

Modified by John99

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15462 solutions 140015 answers

Chosen Solution

moz_favicons shouldn't be empty.

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

See also:

If the Places Maintenance extension can't repair the places.sqlite database then remove all places.sqlite file(s) in the Firefox profile folder to make Firefox rebuild the places.sqlite database from the most recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

moz_favicons shouldn't be empty. You can check for problems with the <b>places.sqlite</b> database (bookmarks and history) in the Firefox profile folder. *https://addons.mozilla.org/firefox/addon/places-maintenance/ See also: *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/en-US/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file If the Places Maintenance extension can't repair the places.sqlite database then remove all places.sqlite file(s) in the Firefox profile folder to make Firefox rebuild the places.sqlite database from the most recent JSON backup in the bookmarkbackups folder. *keep a backup copy of places.sqlite in case a new places.sqlite database has to be created *http://kb.mozillazine.org/Unable_to_process_the_backup_file_-_Firefox You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Was this helpful to you? 1
Quote

Question owner

The above post solved it. I still have to visit the websites to force the favicon to load, but I have confirmed with SQLitebwoser that the favicons are loading properly now.

I noticed that the favicons don't load if the bookmark URL isn't exact. For example, one of my bookmarks didn't have the www. but it still took me to the page. I didn't get the favicon to load until I edited the bookmark to include the www. This was also true for nuances such as http:// vs https://. If you know of any ways to force the favicons to load without visiting the websites and/or without changing the previously mentioned nuances in the bookmarks, that would be great (but obviously I'm just happy that it works).

Thank you cor-el (and the rest who piched in) for your prompt and courteous support. I just moved over to Firefox and this really encourages me to stick with it.

EDIT: To be more specific, I had to delete/rename places.sqlite to get it to work again.

The above post solved it. I still have to visit the websites to force the favicon to load, but I have confirmed with SQLitebwoser that the favicons are loading properly now. I noticed that the favicons don't load if the bookmark URL isn't exact. For example, one of my bookmarks didn't have the www. but it still took me to the page. I didn't get the favicon to load until I edited the bookmark to include the www. This was also true for nuances such as http:// vs https://. If you know of any ways to force the favicons to load without visiting the websites and/or without changing the previously mentioned nuances in the bookmarks, that would be great (but obviously I'm just happy that it works). Thank you cor-el (and the rest who piched in) for your prompt and courteous support. I just moved over to Firefox and this really encourages me to stick with it. EDIT: To be more specific, I had to delete/rename places.sqlite to get it to work again.

Modified by chanceh

Was this helpful to you?
Quote
John99
  • Moderator
971 solutions 13138 answers

Glad it worked, & thanks for posting back, but the solution is a bit drastic because that causes you to lose the History Firefox stores.

That may not seem important in some instances, but the History helps you get the suggestions in the addressbar that match somewhere you visited previously. So if you have a site you want to find again but it was not bookmarked, the addressbar will now no longer be able to propose it as a suggestion. See also


Renaming profile files instead of deleting them can be a good idea as it allows you a chance to use them again if things do not work out as expected.

Glad it worked, & thanks for posting back, but the solution is a bit drastic because that causes you to lose the History Firefox stores. That may not seem important in some instances, but the History helps you get the suggestions in the addressbar that match somewhere you visited previously. So if you have a site you want to find again but it was not bookmarked, the addressbar will now no longer be able to propose it as a suggestion. See also * [[Awesome Bar - Search your Firefox bookmarks, history and tabs from the address bar]] ** And for anyone typing in to the addressbar look at the section [[Awesome Bar - Search your Firefox bookmarks, history and tabs from the address bar#w_changing-results-on-the-fly|_changing-results-on-the-fly]] Renaming profile files instead of deleting them can be a good idea as it allows you a chance to use them again if things do not work out as expected.
Was this helpful to you?
Quote
john327 0 solutions 1 answers

Fiz said

Next we can check to see if your favicons are being saved properly in the places.sqlite database file. Probably best not modify the contents of this database, and probably best to close Firefox beforehand
  1. Download and install http://sqlitebrowser.org/ for win64
  2. Launch DB Browser
  3. Click Open Database
  4. Copy/paste %APPDATA%\Mozilla\Firefox\Profiles\ into the file name box and hit enter
  5. Open the directory listed there
  6. Select and open places.sqlite
  7. Click the 'Browse Data' tab
  8. Select moz_favicons from the table dropdown
  9. Select one of the 'Blob' entries under the 'data' column
  10. Change the 'Mode' drop down on the top right from text to image and see any images appear when you click the cells listed in the 'data' column
Let me know if you get something like what I've attached.

In step 5 there were four directories, I picked the most recent. Step 9 I do not see a 'Blob' entry. Did I take a wrong turn?

''Fiz [[#answer-976692|said]]'' <blockquote> Next we can check to see if your favicons are being saved properly in the places.sqlite database file. '''Probably best not modify the contents of this database, and probably best to close Firefox beforehand''' # Download and install http://sqlitebrowser.org/ for win64 # Launch DB Browser # Click Open Database # Copy/paste %APPDATA%\Mozilla\Firefox\Profiles\ into the file name box and hit enter # Open the directory listed there # Select and open places.sqlite # Click the 'Browse Data' tab # Select moz_favicons from the table dropdown # Select one of the 'Blob' entries under the 'data' column # Change the 'Mode' drop down on the top right from text to image and see any images appear when you click the cells listed in the 'data' column Let me know if you get something like what I've attached. </blockquote> In step 5 there were four directories, I picked the most recent. Step 9 I do not see a 'Blob' entry. Did I take a wrong turn?

Modified by john327

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15462 solutions 140015 answers

Helpful Reply

Firefox 55+ no longer stores favicons in places.sqlite, but uses favicons.sqlite

Firefox 55+ no longer stores favicons in places.sqlite, but uses favicons.sqlite
Was this helpful to you? 3
Quote
DJBoshh 0 solutions 2 answers

Helpful Reply

Try turning ON remember history in Firefox settings. It worked for me, but i should also add that i did refresh firefox first which didn't initially help, but i'm unsure if that step was needed or not.

Try turning ON remember history in Firefox settings. It worked for me, but i should also add that i did refresh firefox first which didn't initially help, but i'm unsure if that step was needed or not.
Was this helpful to you? 1
Quote
kw217 0 solutions 1 answers

In Firefox 56 on Windows I was able to refresh just a specific bookmark favicon by using sqlite3 (sqlite-tools) to modify favicons.sqlite directly. See https://stackoverflow.com/a/46789939/8789816

In Firefox 56 on Windows I was able to refresh just a specific bookmark favicon by using sqlite3 (sqlite-tools) to modify favicons.sqlite directly. See https://stackoverflow.com/a/46789939/8789816
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.