X
Tap here to go to the mobile version of the site.

Support Forum

Come on, Mozilla, help us with Firefox Flash on Ubuntu.

Posted

I posted this merely to get some attention on this issue. Why can't Ubuntu, Mozilla, and Adobe get their respective acts together and solve this?

So-called experts telling everyone to stop trying to view Flash videos is NOT helpful. Many websites are still building them. Also, what about older videos that retain value to view? Mozilla telling everyone that they no longer support Flash plugin and have a replacement in latest Firefox is NOT helpful, since Ubuntu makes it impossible to install it because of their proprietary extensions. Adobe providing an up-to-date Linux version of the plugin is NOT helpful, since Mozilla has blocked them in all Firefox's that come with Ubuntu releases. Ubuntu seemingly ignoring the issue is NOT helpful. So, what's a user to do, go back to Windows?

I will post this everyplace that I can find on the Web until something is done!!

I posted this merely to get some attention on this issue. Why can't Ubuntu, Mozilla, and Adobe get their respective acts together and solve this? So-called experts telling everyone to stop trying to view Flash videos is NOT helpful. Many websites are still building them. Also, what about older videos that retain value to view? Mozilla telling everyone that they no longer support Flash plugin and have a replacement in latest Firefox is NOT helpful, since Ubuntu makes it impossible to install it because of their proprietary extensions. Adobe providing an up-to-date Linux version of the plugin is NOT helpful, since Mozilla has blocked them in all Firefox's that come with Ubuntu releases. Ubuntu seemingly ignoring the issue is NOT helpful. So, what's a user to do, go back to Windows? I will post this everyplace that I can find on the Web until something is done!!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157861 answers

Flash is the only plugin that is supported in current Firefox releases and it shouldn't be a problem on Linux. Adobe even started supporting Flash again on Linux, so you can have the latest Shockwave Flash plugin version (25.0.0.171).

You can download the latest Flash player versions for Firefox on this page:

Flash is the only plugin that is supported in current Firefox releases and it shouldn't be a problem on Linux. Adobe even started supporting Flash again on Linux, so you can have the latest Shockwave Flash plugin version (25.0.0.171). You can download the latest Flash player versions for Firefox on this page: *https://get.adobe.com/flashplayer/otherversions/