Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SSL_ERROR_ACCESS_DENIED_ALERT

  • 3 replies
  • 57 have this problem
  • 21022 views
  • Last reply by CortJstr

more options

This morning I started getting this error on the gmail site this morning. GMail is working fine in Chrome and in the app on my phone so I'm thinking this is a Firefox issue not a GMail one.

I'm only able to test on one computer right now.

Firefox 53.0.3 on Windows7 I'm also using GMail Notifier 0.7.4

An error occurred during a connection to mail.google.com. Peer received a valid certificate, but access was denied. Error code: SSL_ERROR_ACCESS_DENIED_ALERT

Chosen solution

Try to rename/remove the SiteSecurityServiceState.txt file in the Firefox profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.


Read this answer in context 👍 3

All Replies (3)

more options

Restarting in Safe Mode fixes this problem, but manually disabling all extensions and restarting doesn't. I also tried refreshing Firefox and reinstalling my extensions but it's still not working.

I also discovered that Pushbullet isn't working and reinstalling it throws up the same error when I try to sign in again.

more options

Chosen Solution

Try to rename/remove the SiteSecurityServiceState.txt file in the Firefox profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.


more options

cor-el's steps, in combination with uninstalling the Pushbullet Add-on fixed my problem. Just doing one or the other didn't seem to work but both combined did the trick. When i have more time I'll try re-installing Pushbullet to see if it can be salvaged.

(This is a work computer so I can install the Pushbullet add-on but not the executable, which is what I use at home).