X
Tap here to go to the mobile version of the site.

Support Forum

I can't set firefox as my default browser. The options menu won't let me make it the default browser. Using Windows 8

Posted

When I try to set Firefox as my default browser in Windows 8, the options menu goes to the Set Associations menu and won't set it as the default browser. In the instructions on your website for the alternate way to set it it only gives directions for Windows 7, Vista and XP not Windows 8. This is most annoying. I have tried reinstalling Firefox but that didn't work.

When I try to set Firefox as my default browser in Windows 8, the options menu goes to the Set Associations menu and won't set it as the default browser. In the instructions on your website for the alternate way to set it it only gives directions for Windows 7, Vista and XP not Windows 8. This is most annoying. I have tried reinstalling Firefox but that didn't work.

Chosen solution

JoanO said

I have done those instructions and the ones in the video several times and it still doesn't work. When I open Chrome I don't get the message that it is not my default browser. I wonder if removing Chrome might solve the problem. I don't use it anyway.

Might be a good idea, but : Like cor-el asked you earlier :   which browser is currently set as the default browser   ? And :   where in Windows 8 settings do you see which browser is set as default  ? No option there to change it  ?

Just thought of something :   you mentioned that you   had   Firefox set as default, but it changed back, right  ? After you've set Firefox to be your default browser, did you scroll down and click 'OK'  ? Those sly MS foxes make that so easy to miss   ......

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

Tomatoshadow2 20 solutions 242 answers

Did you try setting Firefox as your default inside the browser?

Did you try setting Firefox as your default inside the browser?
Happy112 561 solutions 5694 answers

Would you check this setting please  :

3-bar menu => Options => General Under 'Startup' : check : 'Always check if Firefox is your default browser'

Would you check this setting please : 3-bar menu => Options => General Under 'Startup' : check : 'Always check if Firefox is your default browser'

Question owner

tomatoshadow2 said

Did you try setting Firefox as your default inside the browser?

I tried that first. Didn't work.

''tomatoshadow2 [[#answer-973687|said]]'' <blockquote> Did you try setting Firefox as your default inside the browser? </blockquote> I tried that first. Didn't work.

Question owner

Happy112 said

Would you check this setting please  : 3-bar menu => Options => General Under 'Startup' : check : 'Always check if Firefox is your default browser'

The above is checked.

''Happy112 [[#answer-973691|said]]'' <blockquote> Would you check this setting please : 3-bar menu => Options => General Under 'Startup' : check : 'Always check if Firefox is your default browser' </blockquote> The above is checked.
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158604 answers
Try: *http://www.online-tech-tips.com/windows-8/change-default-web-browser-in-windows-8/

Question owner

Sorry but that didn't work either. Tried it twice but no luck. Thanks anyway.

Sorry but that didn't work either. Tried it twice but no luck. Thanks anyway.
Happy112 561 solutions 5694 answers

JoanO said

Happy112 said
Would you check this setting please  : 3-bar menu => Options => General Under 'Startup' : check : 'Always check if Firefox is your default browser'

The above is checked.

Under that checked line it should read :

Firefox is currently your default browser

And it doesn't  ?

''JoanO [[#answer-973761|said]]'' <blockquote> ''Happy112 [[#answer-973691|said]]'' <blockquote> Would you check this setting please : 3-bar menu => Options => General Under 'Startup' : check : 'Always check if Firefox is your default browser' </blockquote> The above is checked. </blockquote> Under that checked line it should read : '' Firefox is currently your default browser '' And it doesn't ?
Happy112 561 solutions 5694 answers

Not giving up that easily   -   running Windows 10 myself, and for me it's just : Windows menu => Settings => Change default browser ( and don't forget to click OK) But as it doesn't seem to be that simple in Windows 8,   I found this :

https://www.youtube.com/watch?v=QMF7jXTyxug

Not giving up that easily &nbsp; - &nbsp; running Windows 10 myself, and for me it's just : Windows menu => Settings => Change default browser ( and don't forget to click OK) But as it doesn't seem to be that simple in Windows 8, &nbsp; I found this : https://www.youtube.com/watch?v=QMF7jXTyxug

Question owner

Happy112 said

JoanO said
Happy112 said
Would you check this setting please  : 3-bar menu => Options => General Under 'Startup' : check : 'Always check if Firefox is your default browser'

The above is checked.

Under that checked line it should read :

Firefox is currently your default browser

And it doesn't  ?

No it doesn't

''Happy112 [[#answer-973809|said]]'' <blockquote> ''JoanO [[#answer-973761|said]]'' <blockquote> ''Happy112 [[#answer-973691|said]]'' <blockquote> Would you check this setting please : 3-bar menu => Options => General Under 'Startup' : check : 'Always check if Firefox is your default browser' </blockquote> The above is checked. </blockquote> Under that checked line it should read : '' Firefox is currently your default browser '' And it doesn't ? </blockquote> No it doesn't
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158604 answers

Which browser is currently set as the default browser?

Can you set any other browser (e.g. Google Chrome) as the default browser?

You can also check the Windows Registry to see what the .html file extension and protocols like HTTP and HTTPS look like. Thee would normally also a FirefoxHTML key to be used when Firefox is set as the default browser.

You can try to uninstall Firefox and reinstall as administrator (right-click: Run as administrator) in case some registry key couldn't be created.

Which browser is currently set as the default browser? Can you set any other browser (e.g. Google Chrome) as the default browser? You can also check the Windows Registry to see what the .html file extension and protocols like HTTP and HTTPS look like. Thee would normally also a FirefoxHTML key to be used when Firefox is set as the default browser. You can try to uninstall Firefox and reinstall as administrator (right-click: Run as administrator) in case some registry key couldn't be created.
Happy112 561 solutions 5694 answers

Before you do anything drastic, would you take a look at these instructions, please (just to give it one more try) :

http://www.online-tech-tips.com/windows-8/change-default-web-browser-in-windows-8/

(Those instructions in that video weren't helpful either   ?)

Before you do anything drastic, would you take a look at these instructions, please (just to give it one more try) : http://www.online-tech-tips.com/windows-8/change-default-web-browser-in-windows-8/ (Those instructions in that video weren't helpful either &nbsp; ?)

Question owner

I have done those instructions and the ones in the video several times and it still doesn't work. When I open Chrome I don't get the message that it is not my default browser. I wonder if removing Chrome might solve the problem. I don't use it anyway.

I have done those instructions and the ones in the video several times and it still doesn't work. When I open Chrome I don't get the message that it is not my default browser. I wonder if removing Chrome might solve the problem. I don't use it anyway.
Happy112 561 solutions 5694 answers

Chosen Solution

JoanO said

I have done those instructions and the ones in the video several times and it still doesn't work. When I open Chrome I don't get the message that it is not my default browser. I wonder if removing Chrome might solve the problem. I don't use it anyway.

Might be a good idea, but : Like cor-el asked you earlier :   which browser is currently set as the default browser   ? And :   where in Windows 8 settings do you see which browser is set as default  ? No option there to change it  ?

Just thought of something :   you mentioned that you   had   Firefox set as default, but it changed back, right  ? After you've set Firefox to be your default browser, did you scroll down and click 'OK'  ? Those sly MS foxes make that so easy to miss   ......

''JoanO [[#answer-973854|said]]'' <blockquote> I have done those instructions and the ones in the video several times and it still doesn't work. When I open Chrome I don't get the message that it is not my default browser. I wonder if removing Chrome might solve the problem. I don't use it anyway. </blockquote> Might be a good idea, but : Like cor-el asked you earlier : &nbsp; which browser is currently set as the default browser &nbsp; ? And : &nbsp; where in Windows 8 settings do you see which browser is set as default ? No option there to change it ? Just thought of something : &nbsp; you mentioned that you &nbsp; '' had'' &nbsp; Firefox set as default, but it changed back, right ? After you've set Firefox to be your default browser, did you scroll down and click 'OK' ? Those sly MS foxes make that so easy to miss &nbsp; ......

Question owner

Well I just fixed it. I went into Control Panel, Default Programs and clicked on Set Program Access and Computer Defaults. The last item on the list. I then chose Custom configuration. IE was the default browser, I changed it to Firefox. It now works properly. Thanks for all your help. I really appreciate it.

Well I just fixed it. I went into Control Panel, Default Programs and clicked on Set Program Access and Computer Defaults. The last item on the list. I then chose Custom configuration. IE was the default browser, I changed it to Firefox. It now works properly. Thanks for all your help. I really appreciate it.
Happy112 561 solutions 5694 answers

Yay   !   Finally   ! Well done, you   !!!

I noticed that you marked my last post as   'Chosen Solution',   but it
was   you   who finally figured it out,   so, I think that you should mark
your own last post as   'Chosen Solution'   !

Yay &nbsp; ! &nbsp; Finally &nbsp; ! Well done, you &nbsp; !!! I noticed that you marked my last post as &nbsp; 'Chosen Solution', &nbsp; but it <BR>was &nbsp; '' you'' &nbsp; who finally figured it out, &nbsp; so, I think that you should mark <BR>your own last post as &nbsp; 'Chosen Solution' &nbsp; !

Question owner

Will do and thanks. I am not sure, however, I would have found the solution without the assistance of all of you who gave me suggestions on what to do. I just thought it couldn't hurt to try it.

Will do and thanks. I am not sure, however, I would have found the solution without the assistance of all of you who gave me suggestions on what to do. I just thought it couldn't hurt to try it.
Happy112 561 solutions 5694 answers

JoanO said

Will do and thanks. I am not sure, however, I would have found the solution without the assistance of all of you who gave me suggestions on what to do. I just thought it couldn't hurt to try it.

Well, you did a great job and deserve the credits   !

(Thank you for your kind words, though)

''JoanO [[#answer-973914|said]]'' <blockquote> Will do and thanks. I am not sure, however, I would have found the solution without the assistance of all of you who gave me suggestions on what to do. I just thought it couldn't hurt to try it. </blockquote> Well, you did a great job and deserve the credits &nbsp; ! (Thank you for your kind words, though)