X
Tap here to go to the mobile version of the site.

Support Forum

Flash works extremely SLOW in Firefox

Posted

Hello,

After the last updates of firefox and flash, I cannot play any flash game - all of them works very slow. I tried everything, described in the forums, without success (disabling hardware acceleration, reinstalling, etc.). Everything works FINE in Opera, Edge and Chrome. Just in FF is very slow.

I use: Windows 10 (64 bit) Firefox 64 bit (latest version) Flash player (latest version)

Thanks in advance for your help!

Best regards!

Hello, After the last updates of firefox and flash, I cannot play any flash game - all of them works very slow. I tried everything, described in the forums, without success (disabling hardware acceleration, reinstalling, etc.). Everything works FINE in Opera, Edge and Chrome. Just in FF is very slow. I use: Windows 10 (64 bit) Firefox 64 bit (latest version) Flash player (latest version) Thanks in advance for your help! Best regards!

Chosen solution

Would you check this setting please :

Type in the address bar   about:config   (press Enter) (promise to be careful, if asked) Type and look for the preference : dom.ipc.plugins.asyncdrawing.enabled and make sure it's value is set to   false


Stab in the dark : Do you by any chance have Trusteer Rapport installed  ? If so : would you disable it and see if that makes a difference  ? The same goes for ant-virus software you may have   (not counting
Windows Defender).

Read this answer in context 14

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

FredMcD
  • Top 10 Contributor
3215 solutions 43393 answers

Helpful Reply

In what way is it slow? Displaying the page? Connecting to a site?

In what way is it slow? Displaying the page? Connecting to a site?

Question owner

The game itself is slow. The animations are slow. Also the settings menu of the flash player works slow!

The game itself is slow. The animations are slow. Also the settings menu of the flash player works slow!
FredMcD
  • Top 10 Contributor
3215 solutions 43393 answers

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration ---------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

Thank you for your answer. I updated the graphics drivers with the latest version, but the problem is still there... I tried that in Firefox in Safe mode - the problem is there...

Thank you for your answer. I updated the graphics drivers with the latest version, but the problem is still there... I tried that in Firefox in Safe mode - the problem is there...
Happy112
  • Top 10 Contributor
397 solutions 3902 answers

Chosen Solution

Would you check this setting please :

Type in the address bar   about:config   (press Enter) (promise to be careful, if asked) Type and look for the preference : dom.ipc.plugins.asyncdrawing.enabled and make sure it's value is set to   false


Stab in the dark : Do you by any chance have Trusteer Rapport installed  ? If so : would you disable it and see if that makes a difference  ? The same goes for ant-virus software you may have   (not counting
Windows Defender).

Would you check this setting please : Type in the address bar &nbsp; '''about:config''' &nbsp; (press Enter) (promise to be careful, if asked) Type and look for the preference : '''dom.ipc.plugins.asyncdrawing.enabled''' and make sure it's value is set to &nbsp; '''false''' --------------------------------------------------------------------------------------------------------- Stab in the dark : Do you by any chance have Trusteer Rapport installed ? If so : would you disable it and see if that makes a difference ? The same goes for ant-virus software you may have &nbsp; (not counting <BR>Windows Defender).

Question owner

I checked it.

"dom.ipc.plugins.asyncdrawing.enabled" is set to false.

I checked it. "dom.ipc.plugins.asyncdrawing.enabled" is set to false.
Happy112
  • Top 10 Contributor
397 solutions 3902 answers

vcoder said

I checked it. "dom.ipc.plugins.asyncdrawing.enabled" is set to false.

That's okay then. And how about my other questions  ?

''vcoder [[#answer-974068|said]]'' <blockquote> I checked it. "dom.ipc.plugins.asyncdrawing.enabled" is set to false. </blockquote> That's okay then. And how about my other questions ?

Question owner

I already answered to them in my previous posts. I updated the graphics drivers with the latest version, but the problem is still there... I tried that in Firefox in Safe mode - the problem is there...

I already answered to them in my previous posts. I updated the graphics drivers with the latest version, but the problem is still there... I tried that in Firefox in Safe mode - the problem is there...

Question owner

I am sorry. Now I saw the other part of your reply.

"Stab in the dark : Do you by any chance have Trusteer Rapport installed  ? If so : would you disable it and see if that makes a difference  ? The same goes for ant-virus software you may have (not counting Windows Defender)."

No, I don't have Trusteer Rapport installed. I use Kaspersky Antivirus. I removed it but everything is the same.

I am sorry. Now I saw the other part of your reply. "Stab in the dark : Do you by any chance have Trusteer Rapport installed ? If so : would you disable it and see if that makes a difference ? The same goes for ant-virus software you may have (not counting Windows Defender)." No, I don't have Trusteer Rapport installed. I use Kaspersky Antivirus. I removed it but everything is the same.

Question owner

I made it! Now every flash game works perfect!

I just set dom.ipc.plugins.asyncdrawing.enabled to TRUE and everything is fine now :)


Best regards and thank you for your help!

I made it! Now every flash game works perfect! I just set dom.ipc.plugins.asyncdrawing.enabled to TRUE and everything is fine now :) Best regards and thank you for your help!