X
Tap here to go to the mobile version of the site.

Support Forum

After opening the context menu (right click) it left click automatically.. and sometimes it don't

Posted

Hello,

I'm using Firefox on a Macbook Pro Mid 2015 and I have this silly problem, most of the times, whatever the website (youtube, reddit, google ect) when i right click (wether it is with the touchpad or and usb mouse) on a url, a text ect. to use the context menu with, it click on the option my mouse is right away... And I don't know why like 1 times out of 30 it dont, I don't have this problem at all in Google chrome and also I found out that if I hold the right click I can move to chose the option that is going to be clicked right after releasing it... but it's still silly to do this when also I don't have to do it sometimes ( And this isn't any of my modules because I tried to disable all of them, still the same problem)

Thanks in advance !

Hello, I'm using Firefox on a Macbook Pro Mid 2015 and I have this silly problem, most of the times, whatever the website (youtube, reddit, google ect) when i right click (wether it is with the touchpad or and usb mouse) on a url, a text ect. to use the context menu with, it click on the option my mouse is right away... And I don't know why like 1 times out of 30 it dont, I don't have this problem at all in Google chrome and also I found out that if I hold the right click I can move to chose the option that is going to be clicked right after releasing it... but it's still silly to do this when also I don't have to do it sometimes ( And this isn't any of my modules because I tried to disable all of them, still the same problem) Thanks in advance !

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

FredMcD
  • Top 10 Contributor
4248 solutions 59434 answers

When you right-click something in Firefox, the menu should open and wait for you to choose something. Are you pressing the left button without knowing it? Pressing the enter?

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

When you right-click something in Firefox, the menu should open and wait for you to choose something. Are you pressing the left button without knowing it? Pressing the enter? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

FredMcD a écrit

When you right-click something in Firefox, the menu should open and wait for you to choose something. Are you pressing the left button without knowing it? Pressing the enter? Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Thanks for the answer, that's the problem, the menu does not wait for me to choose. I tried with an usb mouse and in Safe Mode without extensions, and still have the same issue... I don't have this problem in the mac UI or with other browsers.

''FredMcD [[#answer-965931|a écrit]]'' <blockquote> When you right-click something in Firefox, the menu should open and wait for you to choose something. Are you pressing the left button without knowing it? Pressing the enter? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> Thanks for the answer, that's the problem, the menu does not wait for me to choose. I tried with an usb mouse and in Safe Mode without extensions, and still have the same issue... I don't have this problem in the mac UI or with other browsers.
FredMcD
  • Top 10 Contributor
4248 solutions 59434 answers

Let’s do a full clean re-install; Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder if there is one.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Let’s do a full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Mac: ''' Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ '''Do Not''' remove the profiles folder. Look for, and rename any '''Mozilla''' or '''Firefox''' program folders by adding .old to them. Do not rename the '''Mozilla Thunderbird''' folder if there is one. After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Question owner

It is really strange, I tried all this and I still have the same problem, even when my computer is in safe mode..

It is really strange, I tried all this and I still have the same problem, even when my computer is in safe mode..
FredMcD
  • Top 10 Contributor
4248 solutions 59434 answers

Are you using a mouse pad? Disable it.

Are you using a mouse pad? Disable it.

Question owner

I only use the integrated trackpad, I tried to disable it and use only my usb mouse, the problem still there !

I only use the integrated trackpad, I tried to disable it and use only my usb mouse, the problem still there !