X
Tap here to go to the mobile version of the site.

Support Forum

Why can't I view PDF document any longer without saving it to my computer first.

Posted

I used to get a option to open or save PDF files. Recently it now just automatically saves to the computer and I have to then open it. What happened to the option? It seems to justbe affecting PDF documents

I used to get a option to open or save PDF files. Recently it now just automatically saves to the computer and I have to then open it. What happened to the option? It seems to justbe affecting PDF documents

Chosen solution

Hi Gary, please check your settings on the Options page, Applications section. This article will get you to the spot (even if the title isn't exactly what you're aiming for): How to disable the built-in PDF viewer and use another viewer.

The PDF settings may have changed because the Adobe Acrobat plugin is no longer enabled in the regular release of Firefox 52 and later. (No plugins other than Flash run in those versions.) Users who were automatically directing PDFs to that plugin would have an invalid setting that might not get switched back to the built-in PDF Viewer for one reason or another.


Sometimes the settings file which stores these application handling preferences becomes corrupted. Since it has a somewhat inscrutable XML-based format, we generally recommend letting Firefox rebuild it from scratch. And this is how...

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Open Folder" / "Show in Finder" / "Open Directory" button. This should launch a new window listing various files and folders.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit / Quit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to mimeTypes.old.

Start Firefox back up again. PDFs should be assigned to "Preview in Firefox" by default.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

jscher2000
  • Top 10 Contributor
6733 solutions 55030 answers

Chosen Solution

Hi Gary, please check your settings on the Options page, Applications section. This article will get you to the spot (even if the title isn't exactly what you're aiming for): How to disable the built-in PDF viewer and use another viewer.

The PDF settings may have changed because the Adobe Acrobat plugin is no longer enabled in the regular release of Firefox 52 and later. (No plugins other than Flash run in those versions.) Users who were automatically directing PDFs to that plugin would have an invalid setting that might not get switched back to the built-in PDF Viewer for one reason or another.


Sometimes the settings file which stores these application handling preferences becomes corrupted. Since it has a somewhat inscrutable XML-based format, we generally recommend letting Firefox rebuild it from scratch. And this is how...

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Open Folder" / "Show in Finder" / "Open Directory" button. This should launch a new window listing various files and folders.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit / Quit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to mimeTypes.old.

Start Firefox back up again. PDFs should be assigned to "Preview in Firefox" by default.

Hi Gary, please check your settings on the Options page, Applications section. This article will get you to the spot (even if the title isn't exactly what you're aiming for): [[How to disable the built-in PDF viewer and use another viewer]]. The PDF settings may have changed because the Adobe Acrobat plugin is no longer enabled in the regular release of Firefox 52 and later. (No plugins other than Flash run in those versions.) Users who were automatically directing PDFs to that plugin would have an invalid setting that might not get switched back to the built-in PDF Viewer for one reason or another. ---- Sometimes the settings file which stores these application handling preferences becomes corrupted. Since it has a somewhat inscrutable XML-based format, we generally recommend letting Firefox rebuild it from scratch. And this is how... Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter/Return In the first table on the page, click the "Open Folder" / "Show in Finder" / "Open Directory" button. This should launch a new window listing various files and folders. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit / Quit Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to mimeTypes.old. Start Firefox back up again. PDFs should be assigned to "Preview in Firefox" by default.

Question owner

Thanks - worked perfectly Gary

Thanks - worked perfectly Gary
LadyT13 0 solutions 12 answers

Easy way to try first.  :) Go to your Firefox menu (3 bars at the top right) - choose "options" ; - choose "content" on the left menu; under "pop-ups" "exceptions" add the web address of the site you want to view pdf's in Then.... - choose "security" on the left menu; under "general" "warn you when sites try to install add ons" choose "exceptions" and add the web address of the site.

Sometimes Firefox updates and/or Windows updates seem to cause problems that re-setting these preferences fixes for me. Good luck! Keep us updated.

Easy way to try first. :) Go to your Firefox menu (3 bars at the top right) - choose "options" ; - choose "content" on the left menu; under "pop-ups" "exceptions" add the web address of the site you want to view pdf's in Then.... - choose "security" on the left menu; under "general" "warn you when sites try to install add ons" choose "exceptions" and add the web address of the site. Sometimes Firefox updates and/or Windows updates seem to cause problems that re-setting these preferences fixes for me. Good luck! Keep us updated.
jscher2000
  • Top 10 Contributor
6733 solutions 55030 answers

LadyT13 said

Go to your Firefox menu (3 bars at the top right)
- choose "options" ;
...
- choose "security" on the left menu; under "general" "warn you when sites try to install add ons" choose "exceptions" and add the web address of the site.

No, please do not do that. Why would a site need to install an add-on onto your Firefox so you can open or save a PDF? Be very, very suspicious of any site like that and remove their extension ASAP from the Add-ons page before it can do too much damage.

''LadyT13 [[#answer-1006650|said]]'' <blockquote> Go to your Firefox menu (3 bars at the top right) <br>- choose "options" ; <br>... <br>- choose "security" on the left menu; under "general" "warn you when sites try to install add ons" choose "exceptions" and add the web address of the site. </blockquote> No, please do not do that. Why would a site need to install an add-on onto your Firefox so you can open or save a PDF? Be very, very suspicious of any site like that and remove their extension ASAP from the Add-ons page before it can do too much damage.
cor-el
  • Top 10 Contributor
  • Moderator
15678 solutions 141802 answers

Helpful Reply

Note that current Firefox 55+ releases no longer use mimeTypes.rdf, but are now using handlers.json in the profile folder.

Note that current Firefox 55+ releases no longer use mimeTypes.rdf, but are now using handlers.json in the profile folder.
LadyT13 0 solutions 12 answers

jscher2000 said

LadyT13 said
Go to your Firefox menu (3 bars at the top right)
- choose "options" ;
...
- choose "security" on the left menu; under "general" "warn you when sites try to install add ons" choose "exceptions" and add the web address of the site.

No, please do not do that. Why would a site need to install an add-on onto your Firefox so you can open or save a PDF? Be very, very suspicious of any site like that and remove their extension ASAP from the Add-ons page before it can do too much damage.

FYI....there are PLENTY of safe sites that need to be "allowed" in Firefox to work properly. I have multiple sites I use for work that must be added as "safe sites" and allowed to run "add-ons" and "pop-ups". I'm not saying to add ANY RANDOM sites as safe, but there are sites we must use that won't display pdf's properly UNLESS they are given these permissions.

''jscher2000 [[#answer-1006694|said]]'' <blockquote> ''LadyT13 [[#answer-1006650|said]]'' <blockquote> Go to your Firefox menu (3 bars at the top right) <br>- choose "options" ; <br>... <br>- choose "security" on the left menu; under "general" "warn you when sites try to install add ons" choose "exceptions" and add the web address of the site. </blockquote> No, please do not do that. Why would a site need to install an add-on onto your Firefox so you can open or save a PDF? Be very, very suspicious of any site like that and remove their extension ASAP from the Add-ons page before it can do too much damage. </blockquote> FYI....there are PLENTY of safe sites that need to be "allowed" in Firefox to work properly. I have multiple sites I use for work that must be added as "safe sites" and allowed to run "add-ons" and "pop-ups". I'm not saying to add ANY RANDOM sites as safe, but there are sites we must use that won't display pdf's properly UNLESS they are given these permissions.
jscher2000
  • Top 10 Contributor
6733 solutions 55030 answers

Helpful Reply

LadyT13 said

jscher2000 said
LadyT13 said
Go to your Firefox menu (3 bars at the top right)
- choose "options" ;
...
- choose "security" on the left menu; under "general" "warn you when sites try to install add ons" choose "exceptions" and add the web address of the site.

No, please do not do that. Why would a site need to install an add-on onto your Firefox so you can open or save a PDF? Be very, very suspicious of any site like that and remove their extension ASAP from the Add-ons page before it can do too much damage.

FYI....there are PLENTY of safe sites that need to be "allowed" in Firefox to work properly. I have multiple sites I use for work that must be added as "safe sites" and allowed to run "add-ons" and "pop-ups". I'm not saying to add ANY RANDOM sites as safe, but there are sites we must use that won't display pdf's properly UNLESS they are given these permissions.

There's a big difference between allowing a site to use or activate an already installed plugin, and allowing a site to install a new add-on. You do not need to allow installation of extensions in order to allow a site to use/activate a plugin. On such sites, Firefox will display a plugin notification icon at the left end of a the address bar (looks like a small gray Lego block), or you can call up the Permissions panel of the Page Info dialog if the icon does not appear.

''LadyT13 [[#answer-1006875|said]]'' <blockquote> ''jscher2000 [[#answer-1006694|said]]'' <blockquote> ''LadyT13 [[#answer-1006650|said]]'' <blockquote> Go to your Firefox menu (3 bars at the top right) <br>- choose "options" ; <br>... <br>- choose "security" on the left menu; under "general" "warn you when sites try to install add ons" choose "exceptions" and add the web address of the site. </blockquote> No, please do not do that. Why would a site need to install an add-on onto your Firefox so you can open or save a PDF? Be very, very suspicious of any site like that and remove their extension ASAP from the Add-ons page before it can do too much damage. </blockquote> FYI....there are PLENTY of safe sites that need to be "allowed" in Firefox to work properly. I have multiple sites I use for work that must be added as "safe sites" and allowed to run "add-ons" and "pop-ups". I'm not saying to add ANY RANDOM sites as safe, but there are sites we must use that won't display pdf's properly UNLESS they are given these permissions. </blockquote> There's a big difference between allowing a site to ''use'' or ''activate'' an already installed plugin, and allowing a site to ''install'' a new add-on. You do not need to allow installation of extensions in order to allow a site to use/activate a plugin. On such sites, Firefox will display a plugin notification icon at the left end of a the address bar (looks like a small gray Lego block), or you can call up the Permissions panel of the Page Info dialog if the icon does not appear.