X
Tap here to go to the mobile version of the site.

Support Forum

FireFox continues to block Google Gmail. I have updated, uninstalled and reinstalled but remains the same.

Posted

I can access all Google's web pages, apps and functions except for Gmail (see security notice below). This only occurs on FireFox which is my preferred browser. Mozilla is not accepting the electronic security certificate from 'mail.google.com'. Also, 'mail.google.com' has NOT configured their website improperly as the security message below has stated.

I have added the website to exceptions under 'Advanced" settings, updated the software, uninstalled and reinstalled, but the problem remains. Should this continue, I will be forced to stop using FireFox all together.

Security Notice: "The owner of mail.google.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate."

I can access all Google's web pages, apps and functions except for Gmail (see security notice below). This only occurs on FireFox which is my preferred browser. Mozilla is not accepting the electronic security certificate from 'mail.google.com'. Also, 'mail.google.com' has NOT configured their website improperly as the security message below has stated. I have added the website to exceptions under 'Advanced" settings, updated the software, uninstalled and reinstalled, but the problem remains. Should this continue, I will be forced to stop using FireFox all together. Security Notice: "The owner of mail.google.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate."

Additional System Details

Installed Plug-ins

  • Shockwave Flash 22.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

Scribe 725 solutions 3456 answers

Hi, this may be caused by BrowserSafe or Browser Safeguard software on your computer - check your Programs/do a search in your PC's search box and disable/remove/update. If you don't have those, you may have some other security software that is causing this.

Incidentally, your Flash is out of date - Install Flash Player - take care to deselect any optional offers!

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Hi, this may be caused by BrowserSafe or Browser Safeguard software on your computer - check your Programs/do a search in your PC's search box and disable/remove/update. If you don't have those, you may have some other security software that is causing this. Incidentally, your Flash is out of date - [https://get.adobe.com/flashplayer/otherversions/ Install Flash Player] - take care to deselect any optional offers! ''If your question is resolved by this or another answer, please take a minute to let us know. Thank you!''

Modified by Scribe

jscher2000
  • Top 10 Contributor
8690 solutions 71033 answers

I just want to clarify: when Firefox cannot form a secure connection with a server, that is not an indication that a site is unsafe, it is an indication that the server failed to prove to Firefox's requirements that it actually is the site you want to reach. It could be a fake, or it could have obsolete security which Firefox considers insecure, or there could be a "man in the middle" reading all your communications with that server. You should never need to make exceptions for well run sites. Nor should you trust something as sensitive as your email on a questionable connection.


You can examine your previously saved exception(s) to see whether there is any pattern to the purported issuer of those certificates. That often identifies the interloper. Here's how:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. Then on the right side, click the Certificates mini-tab along the top. Then click the "View Certificates" button.

This should open the Certificate Manager. Click the "Servers" tab. Ignore the ones for "*" and check for any servers you remember adding an exception for. You can select some of those and click View to check the "Issued by" information.

Any pattern?

I just want to clarify: when Firefox cannot form a secure connection with a server, that is not an indication that a site is unsafe, it is an indication that the server failed to prove to Firefox's requirements that it actually is the site you want to reach. It could be a fake, or it could have obsolete security which Firefox considers insecure, or there could be a "man in the middle" reading all your communications with that server. You should '''never''' need to make exceptions for well run sites. Nor should you trust something as sensitive as your email on a questionable connection. ---- You can examine your previously saved exception(s) to see whether there is any pattern to the purported issuer of those certificates. That often identifies the interloper. Here's how: "3-bar" menu button (or Tools menu) > Options In the left column, click Advanced. Then on the right side, click the Certificates mini-tab along the top. Then click the "View Certificates" button. This should open the Certificate Manager. Click the "Servers" tab. Ignore the ones for "*" and check for any servers you remember adding an exception for. You can select some of those and click View to check the "Issued by" information. Any pattern?