Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Starting from v53 on, Firefox can no longer browse html files inside a zip/jar file using this kind of URL: jar:file:///C:/xxx/yyy.zip!/index.html

  • 4 replies
  • 13 have this problem
  • 303 views
  • Last reply by user1378671

more options

For years we are using zip-archives to store sets of linked html files with many 1000 of files. As these files are all read-only and we need to store many different versions of such sets we use the zip format. Till very recently we could browse the html in such zip archives using a local URL inside a zip file such as

  jar:file:///C:/xxx/yyy.zip!/index.html

After the automatic update to version 53 of Firebox this functionality has stopped working. With automatic updates just a few weeks before all was OK. So this change must have been introduced with version 53. So far Firefox was the only browser we know with this capability and and for us this is a core feature. Please get this functionality back. Thank you

All Replies (4)

more options

Hi.

There are two network.jar prefs present on the about:config page that default to false. You can try to toggle them to true to see if that has effect.

This can also be caused by sandboxing content in the current release preventing to open local files this way.

Try to set security.sandbox.content.level = 0 on the about:config page.

Try to disable multi-process windows in Firefox to see if that has effect. You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Is it specific to the jar: protocol or do you have problems with the file:/// protocol as well?

In that case: do you run the NoScript extension? There is a known issue in Firefox 53 with turning on "Allow local links" for Trusted sites -- if you do that, then file:/// doesn't load. You can turn that off here:

NoScript "S" button > Options > Advanced > Trusted mini-tab

See attached screenshot

Or:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste nosc and pause while the list is filtered

(3) If the noscript.allowLocalLinks preference is bolded and "user set" to true, double-click it to restore the default value of false

In my test, the results are instant: when this is on/true, files do not load, as soon as I set it back to off/false, back to normal.

Could you test that?

Reference: https://forums.informaction.com/viewtopic.php?f=7&t=22761

more options

Thanks a lot to "cor-el" and "jscher2000". So far I never touched about:config.

To the proposals from "cor-el": I applied these changes but the problem still exist, even after starting Firefox anew.

To "jscher2000": Browsing local HTML files works on my PC without any problems. The problems is only when they are in a zip file. And when entering "nosc" or "noscript.allowLocalLinks" in about:config, no preferences with such a names are displayed. Don't now why.

more options

If you are accessing those files via Windows Explorer, try using File > Open File from the Menu Bar inside Firefox.

Hit the Alt key to reveal the Menu Bar, then hit F, then O, and navigate from there to get to the jar file.