X
Tap here to go to the mobile version of the site.

Support Forum

Since Firefox 52 (and 53) I can not see any playing videos in YouTube.

Posted

Since Firefox 52 (and 53) I have a problem at playing the videos in YouTube. That does not succeed anymore. When I go in Firefox to the YouTube website (screenprint A) and next click e.g. on the first video (Lil Kleine), then I now arrive in a screen without videoplayerscreen (screenprint B). I can hear the audio of the video of Lil Kleine, but I see nothing playing. This applies to all YouTube-videos. How can I see the videos playing again?

I have also installed on my computer Internet Explorer 11. With IE YouTube videos work fine, no problems (screenprint C).

Unfortunately uploading screenprints A, B and C to you does not work either, so I hope you understand my story without the images.

Since Firefox 52 (and 53) I have a problem at playing the videos in YouTube. That does not succeed anymore. When I go in Firefox to the YouTube website (screenprint A) and next click e.g. on the first video (Lil Kleine), then I now arrive in a screen without videoplayerscreen (screenprint B). I can hear the audio of the video of Lil Kleine, but I see nothing playing. This applies to all YouTube-videos. How can I see the videos playing again? I have also installed on my computer Internet Explorer 11. With IE YouTube videos work fine, no problems (screenprint C). Unfortunately uploading screenprints A, B and C to you does not work either, so I hope you understand my story without the images.

Chosen solution

I have followed your advice. McAfee WebAdvisor was not the problem. It turns out to be the add-on You Tube High Definition. I have disabled it and YouTube works fine. Next I have downloaded and installed the newest version of You Tube High Definition and now the YouTube website keeps working well in Firefox.

Thank you guys for the good advices. All has been solved now. Thanks.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • Firefox 53.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
  • Support URL: https://support.mozilla.org/1/firefox/53.0/WINNT/nl/

Extensions

  • Adblock Plus 2.8.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AdBlocker for YouTube™ 0.2.5 (jid1-q4sG8pYhq8KGHs@jetpack)
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Download YouTube Videos as MP4 1.8.10 ({b9bfaf1c-a63f-47cd-8b9a-29526ced9060})
  • FireShot Pro 0.98.89 ({5e11ab1e-083c-11e5-a6c0-1697f925ec7b})
  • Google Analytics Opt-out Add-on (van Google) 1.0.7 ({6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65})
  • Google search link fix 1.6.3 (jid0-XWJxt5VvCXkKzQK99PhZqAn7Xbg@jetpack)
  • ImTranslator 10.36 ({9AA46F4F-4DC7-4c06-97AF-5035170634FE})
  • McAfee WebAdvisor 5.0.512.0 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • Multi-process staged rollout 1.14 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Video DownloadHelper 6.2.0 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Web Compat 1.0 (webcompat@mozilla.org)
  • YouTube High Definition 52.0 ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc})
  • YouTube Video and Audio Downloader 0.5.7 (feca4b87-3be4-43da-a1b1-137c24220968@jetpack)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2: NVIDIA GeForce GT 730M
  • adapterDeviceID: 0x0166
  • adapterDeviceID2: 0x0fe1
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: C:\WINDOWS\System32\DriverStore\FileRepository\nvacwu.inf_amd64_bdd6ea477d4e2fba\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nvacwu.inf_amd64_bdd6ea477d4e2fba\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvacwu.inf_amd64_bdd6ea477d4e2fba\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvacwu.inf_amd64_bdd6ea477d4e2fba\nvwgf2umx C:\WINDOWS\System32\DriverStore\FileRepository\nvacwu.inf_amd64_bdd6ea477d4e2fba\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nvacwu.inf_amd64_bdd6ea477d4e2fba\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvacwu.inf_amd64_bdd6ea477d4e2fba\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvacwu.inf_amd64_bdd6ea477d4e2fba\nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 4096
  • adapterSubsysID: 06861025
  • adapterSubsysID2: 06861025
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.14393.953
  • driverDate: 8-17-2015
  • driverDate2: 12-29-2016
  • driverVersion: 10.18.10.4276
  • driverVersion2: 21.21.13.7654
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'skia', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webgl2Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
3160 solutions 42648 answers

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration


Start Firefox in Safe Mode by holding down the <Shift> (Mac=Options) key, and then starting Firefox. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration ----------------- Start Firefox in Safe Mode by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

  • All drivers are up-to-date.
  • Starting in Safe Mode solves the problem indeed and I can see the YouTube videos again.

But what about the next time? And about the add-ons? Do I have to open Firefox every time in Safe Mode with the add-ons switched off? Or can I solve the problem for ever by changing some settings or delete a specific add-on?

* All drivers are up-to-date. * Starting in Safe Mode solves the problem indeed and I can see the YouTube videos again. But what about the next time? And about the add-ons? Do I have to open Firefox every time in Safe Mode with the add-ons switched off? Or can I solve the problem for ever by changing some settings or delete a specific add-on?
Happy112
  • Top 10 Contributor
377 solutions 3808 answers

Hi   !
When all add-ons are disabled,   you should enable them one by one, till you find the culprit. My advice would be to start with   McAfee WebAdvisor   ......

Hi &nbsp; !<BR> When all add-ons are disabled, &nbsp; you should enable them one by one, till you find the culprit. My advice would be to start with &nbsp; McAfee WebAdvisor &nbsp; ......

Chosen Solution

I have followed your advice. McAfee WebAdvisor was not the problem. It turns out to be the add-on You Tube High Definition. I have disabled it and YouTube works fine. Next I have downloaded and installed the newest version of You Tube High Definition and now the YouTube website keeps working well in Firefox.

Thank you guys for the good advices. All has been solved now. Thanks.

I have followed your advice. McAfee WebAdvisor was not the problem. It turns out to be the add-on You Tube High Definition. I have disabled it and YouTube works fine. Next I have downloaded and installed the newest version of You Tube High Definition and now the YouTube website keeps working well in Firefox. Thank you guys for the good advices. All has been solved now. Thanks.
FredMcD
  • Top 10 Contributor
3160 solutions 42648 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.
David McRitchie 320 solutions 3092 answers

The owner solved their own problem with installing the newest version of "You Tube High Definition" and should have marked their own reply as solving. However,

I don't have that, but what worked for me was to use Ctrl+0 which restores normal sizes to the page. That solved my problem, but I don't know how to cause the problem since the Video frame was not visible at all. Also the problem was with every YouTube page not just on one page.

The owner solved their own problem with installing the newest version of "'''You Tube High Definition'''" and should have marked their own reply as solving. '''However''', I don't have that, but what worked for me was to use '''Ctrl+0''' which restores normal sizes to the page. That solved my problem, but I don't know how to cause the problem since the Video frame was not visible at all. Also the problem was with every YouTube page not just on one page.

Modified by David McRitchie

Moses
  • Top 25 Contributor
  • Moderator
444 solutions 3552 answers

David McRitchie said

The owner solved their own problem with installing the newest version of "You Tube High Definition" and should have marked their own reply as solving.

I've went ahead and switched the solutions.

''David McRitchie [[#answer-1008946|said]]'' <blockquote> The owner solved their own problem with installing the newest version of "'''You Tube High Definition'''" and should have marked their own reply as solving. </blockquote> I've went ahead and switched the solutions.