Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't open after refreshing the browser

  • 8 replies
  • 1 has this problem
  • 20 views
  • Last reply by John99

more options

So when firefox is running slow or crashes, it usually suggests that I refresh the browser. This involves opening the menu, then clicking troubleshooting programs and the refresh firefox. Doing this, usually works. But, for about two months now, I can't refresh.

What usually happens is the browser will close, a new window will pop up, saying it's refreshing, and then the browser would open right back up. But, since March(when this problem started) the browser would NEVER open again. I sat for almost two hours the last time I tried. I even tried to reopen it in a bunch of different ways, but it never would. I usually have to restart my whole computer.

It's still running slow and will crash every now and then. I don't really want to reinstall the browser because I'm not 100% sure how to get my profile back and I have a lot of unsaved bookmarks I can't lose.

I really hope someone can help.

All Replies (8)

more options

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refreshing Firefox is a LAST RESORT ! !


In the address bar, type about:crashes<enter>.

Note: If any reports do not have BP in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Press the Reply button. Now go to the reply box and paste them in.

https://support.mozilla.org/legacyfs/online/sumo-media/gallery/images/2014-06-04-07-10-50-73db6f.png

For more help on crash reports, see; https://support.mozilla.org/t5/Documents-Archive/Forum-Response-Firefox-crashes/ta-p/19184

more options

bp-0b7773b4-c203-451a-9db4-9ffcf0170425 3/24/17 11:55 PM dbf020a3-3dde-4f56-8cb7-8e140a81123d 3/24/17 12:24 AM 249d5a4c-f4ed-4f97-98bc-c0cf1c7582e7 3/23/17 2:59 AM c52b0d12-564c-46eb-bf02-1b2200d20c51 3/21/17 8:44 PM 31b457d9-2e8a-435f-80b9-0bf0e056f615 3/21/17 2:53 AM 58ee85d6-aa05-4c49-90f8-867badee485d 3/19/17 8:59 PM ebccee7f-dca6-40d6-8983-e332788d6128 3/19/17 2:30 AM 0a6e2f0d-fd17-4559-9e79-d8add20df33e 3/15/17 1:48 AM a240db2e-939c-4b5f-84c9-3d182fc8fe8b 3/11/17 3:31 AM 5b643208-4976-4de1-acf8-03f9ea4d29e6FredMcD said

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refreshing Firefox is a LAST RESORT ! !

In the address bar, type about:crashes<enter>.

Note: If any reports do not have BP in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Press the Reply button. Now go to the reply box and paste them in.

https://support.mozilla.org/legacyfs/online/sumo-media/gallery/images/2014-06-04-07-10-50-73db6f.png

For more help on crash reports, see; https://support.mozilla.org/t5/Documents-Archive/Forum-Response-Firefox-crashes/ta-p/19184

more options

Most of your crash reports weren’t sent to the Mozilla Servers.

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.


bp-0b7773b4-c203-451a-9db4-9ffcf0170425 Signature: IPCError-browser | ShutDownKill

Attention Sumo's there are 20 related bug reports

msmpeg2vdec.dll = Microsoft DTV-DVD Video Decoder


Start Firefox in Safe Mode by holding down the <Shift> (Mac=Options) key, and then starting Firefox. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

FredMcD said

Most of your crash reports weren’t sent to the Mozilla Servers. In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them. The crash report is several pages of data. We need the report numbers to see the whole report.

bp-0b7773b4-c203-451a-9db4-9ffcf0170425 Signature: IPCError-browser | ShutDownKill

Attention Sumo's there are 20 related bug reports

msmpeg2vdec.dll = Microsoft DTV-DVD Video Decoder


Start Firefox in Safe Mode by holding down the <Shift> (Mac=Options) key, and then starting Firefox. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

No.This worked! Firefox is actually running much better. Thank you! :D

more options

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues.Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Modified by FredMcD

more options

Try to start Firefox with the about:blank page by creating a copy of the current Firefox desktop shortcut. Add a space and -url "about:blank" to the target field in the Properties.

Try to disable multi-process windows in Firefox to see if that has effect. You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

You can try to disable hardware acceleration in Firefox.

  • Options/Preferences -> Advanced -> General -> Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

While you remember make backups of your bookmarks and put then somewhere safe. Better still back up the whole of the Firefox profile now, and then if you make major changes and improve things back it up again.

See

Note you should not need to use the Refresh feature repeatedly if you do something is going wrong and needs sorting out.