X
Tap here to go to the mobile version of the site.

Support Forum

how to get rid of bing

Posted

When I search for something on the internet using Firefox, Bing most times comes up as the search engine and I'm trying to get rid of Bing as a search engine. I have changed the 'Search' preferences in Firefox but Bing still shows up?

When I search for something on the internet using Firefox, Bing most times comes up as the search engine and I'm trying to get rid of Bing as a search engine. I have changed the 'Search' preferences in Firefox but Bing still shows up?

Chosen solution

On the Preferences page, Search panel, top item, what is set as your default search engine? Presumably not Bing. Does it change to Bing without your doing anything, or is the setting being ignored?

Meanwhile...

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

Read this answer in context 4
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • Firefox 52.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.0.2/Darwin/en-US/

Extensions

  • Adblock Plus 2.8.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.2.1-signed.1-signed (adblockpopups@jessehakanen.net)
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Disable Prefetch 1.0 (disable-prefetch@mozilla.org)
  • Disable TLS Certificate Transparency 1.0 (disable-cert-transparency@mozilla.org)
  • Full Cal 1.3.1-signed.1-signed ({0ca81eb3-687d-4579-9480-fbff373b43bf})
  • Grammarly for Firefox 8.760.816 (87677a2c52b84ad3a151a4a72f5bd3c4@jetpack)
  • Multi-process staged rollout 1.12 (e10srollout@mozilla.org)
  • Norton Internet Security 7.3.0f111 (nortoninternetsecurity@symantec.com)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • RoboForm Toolbar 8.2.9.5 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • Site Deployment Checker 1.0 (deployment-checker@mozilla.org)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • XFINITY Toolbar 4.7.0.39 ({4b9bcce8-a70b-402a-a7e1-db96831ee26f})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x162b
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • crashGuards: []
  • currentAudioBackend: audiounit
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'TileHeight': 1024, u'TileWidth': 1024, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 1, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: Yes
  • webgl2Renderer: Intel Inc. -- Intel(R) Iris(TM) Graphics 6100
  • webglRenderer: Intel Inc. -- Intel(R) Iris(TM) Graphics 6100
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
6064 solutions 49809 answers

Chosen Solution

On the Preferences page, Search panel, top item, what is set as your default search engine? Presumably not Bing. Does it change to Bing without your doing anything, or is the setting being ignored?

Meanwhile...

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

On the Preferences page, Search panel, top item, what is set as your default search engine? Presumably not Bing. Does it change to Bing without your doing anything, or is the setting being ignored? Meanwhile... Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? (More info: [[Troubleshoot Firefox issues using Safe Mode]])
Was this helpful to you? 4
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.