Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opening link in a new tab gives blank page

  • 9 replies
  • 5 have this problem
  • Last reply by rufusdufus

more options

Hi, after updating opening page in new tab via right click gives me blank page. Oh and apparently it's also happened when I entering site via address bar, but clicking a link loads the page normally.

The blank page usually last only around a mere 0.5 second to the dreaded 2 seconds, and after that the page will kind of reloading itself (or maybe start connecting?) and start loading normally. The thing is in some case—around one in twelve—the page stuck at that blank page, and I have to reload the page to fix it.

Attached screenshots

All Replies (9)

more options

It's possible the web link you are using is being re-directed to another page.

more options

It's just one example. Unfortunately, that blank page thing almost always happens for whatever site I visit via address bar or via "Open Link in New Tab", particularly sites I visit for the first time since update (though it also happens at much lower rate for sites I regularly visit since then).

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Yes, sadly it's still there even in Safe Mode. I tried rebooting too just in case but the problem still persist.

more options

Please provide public link(s) that we can check out. No Personal Information Please !

more options

It's just about any site as long as you open it in a new tab or write it in address bar.

more options

I had no problem with those links.

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Try to disable multi-process tabs in Firefox.

You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

I have exactly the same problem Trying to download my monthly statement from Bank, Littlewoods home shopping etc in pdf gives a blank page, this problem reoccurs regularly and has done for years in both 32 and 64 bit. I normally have to revert to Windows explorer and more recently edge which as far as I remember never has this issue and today the same, I successfully got my statement in pdf. This is the first time in recent months, I actually thought it had been cured until it happened yesterday. I have tried the suggestions above with no improvement.