X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 51.0.1 not displaying the pop screen for htaccess protected folders

Posted

The latest version of Firefox 51.0.1 does not display the login screen for htaccess protected folders for my website. I've cleared the cache, cookies and browser history and the website is in the block pop-up window exceptions list.

The latest version of Firefox 51.0.1 does not display the login screen for htaccess protected folders for my website. I've cleared the cache, cookies and browser history and the website is in the block pop-up window exceptions list.

Chosen solution

PROBLEM SOLVED.

There was an addon in Firefox that I knew nothing about, I did not install it and several anti-malware programs said it was just that, malware. And it was never detected by Windows Defender.

What is even worse it did not show on the Firefox Addons page, I could only see it on the about:performance tab. Even then it could not be disabled or uninstalled on the page. I had to find it in file manager, delete it manually and then go into the windows registry and manually remove all the entries.

And the culprit was: Adblocker for Youtube

Firefox should not be allowed to install add-ons or malware without your permission.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Citrix Online App Detector Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 24.0 r0
  • 5.1.50901.0
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

More Information

FredMcD
  • Top 10 Contributor
4305 solutions 60413 answers

Helpful Reply

Is this with just Firefox? What about other browsers? Have others reported this issue?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Is this with just Firefox? What about other browsers? Have others reported this issue? Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

This only happens on the latest release of Firefox. If I uninstall FF 51.0.1 and go back to FF 50.1 it works fine. Also works fine on Chrome, Safari and MS Edge.

I have opened Firefox 51.0.1 in safe mode and that works, the authentication screen appears for me to login.

So why doesn't it work outside of safe mode? Am I missing a setting or exception somewhere?

This only happens on the latest release of Firefox. If I uninstall FF 51.0.1 and go back to FF 50.1 it works fine. Also works fine on Chrome, Safari and MS Edge. I have opened Firefox 51.0.1 in safe mode and that works, the authentication screen appears for me to login. So why doesn't it work outside of safe mode? Am I missing a setting or exception somewhere?
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • default toolbar layout is used
  • xulstore.json is ignored
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • JavaScript JIT compilers are disabled
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure such extensions do not block content. There is security software that can interfere with loading content, so check that as well.

See also:

In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *default toolbar layout is used *xulstore.json is ignored *userChrome.css and userContent.css are ignored (chrome folder in profile folder) *JavaScript JIT compilers are disabled *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure such extensions do not block content. There is security software that can interfere with loading content, so check that as well. See also: *https://support.mozilla.org/kb/Troubleshooting+extensions+and+"3-bar" menu button or Tools -> Add-ons -> Appearances

Question owner

The only extensions I have running are 1password and web developer, everything else is disabled. For plugins everything is marked as ask to activate.

Aha, found it, it's the 1password extension. Disabling that allows the popup to appear.

Will have to go back to them for a new version.

Many thanks.

The only extensions I have running are 1password and web developer, everything else is disabled. For plugins everything is marked as ask to activate. Aha, found it, it's the 1password extension. Disabling that allows the popup to appear. Will have to go back to them for a new version. Many thanks.

Question owner

Sadly I need to open this again as the 1password extension does work with Firefox 51.0.1 as I have tried it on a different computer and AgileBits the developers of 1password have confirmed everything is okay.

So I have narrowed it down to something purely on my laptop.

I have also deleted and removed Firefox and all profiles from the laptop, re-installed FF from new and copied the profile on that PC over to the laptop and still get the problem. So in desperation I deleted FF and all profiles again, re-installed with a brand new empty profile just added the 1password extension and again still get the problem.

Any ideas anyone?

Sadly I need to open this again as the 1password extension does work with Firefox 51.0.1 as I have tried it on a different computer and AgileBits the developers of 1password have confirmed everything is okay. So I have narrowed it down to something purely on my laptop. I have also deleted and removed Firefox and all profiles from the laptop, re-installed FF from new and copied the profile on that PC over to the laptop and still get the problem. So in desperation I deleted FF and all profiles again, re-installed with a brand new empty profile just added the 1password extension and again still get the problem. Any ideas anyone?
FredMcD
  • Top 10 Contributor
4305 solutions 60413 answers

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective. +++++++++++++++++++++++++++++++++++++++++++++++++++++++ Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh).

While you are in safe mode; Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Restart Firefox. Are there any problems?

It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective. +++++++++++++++++++++++++++++++++++++++++++++++++++++++ '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Restart Firefox. Are there any problems?

Question owner

There is only one add-on installed and enabled, the 1password extension. When that is disabled it still doesn't work. It only works when it has been completely removed.

Also as I mentioned earlier, it works fine on another computer with that add-on enabled.

I have also de-selected the hardware acceleration and still no joy. The problem still exists.

There is only one add-on installed and enabled, the 1password extension. When that is disabled it still doesn't work. It only works when it has been completely removed. Also as I mentioned earlier, it works fine on another computer with that add-on enabled. I have also de-selected the hardware acceleration and still no joy. The problem still exists.

Question owner

Cancel my earlier comment that it does work when the 1password extension is disabled, it does. It doesn't have to be deleted.

Cancel my earlier comment that it does work when the 1password extension is disabled, it does. It doesn't have to be deleted.
FredMcD
  • Top 10 Contributor
4305 solutions 60413 answers

Contact 1password support. Keep us posted.

Contact 1password support. Keep us posted.

Chosen Solution

PROBLEM SOLVED.

There was an addon in Firefox that I knew nothing about, I did not install it and several anti-malware programs said it was just that, malware. And it was never detected by Windows Defender.

What is even worse it did not show on the Firefox Addons page, I could only see it on the about:performance tab. Even then it could not be disabled or uninstalled on the page. I had to find it in file manager, delete it manually and then go into the windows registry and manually remove all the entries.

And the culprit was: Adblocker for Youtube

Firefox should not be allowed to install add-ons or malware without your permission.

PROBLEM SOLVED. There was an addon in Firefox that I knew nothing about, I did not install it and several anti-malware programs said it was just that, malware. And it was never detected by Windows Defender. What is even worse it did not show on the Firefox Addons page, I could only see it on the about:performance tab. Even then it could not be disabled or uninstalled on the page. I had to find it in file manager, delete it manually and then go into the windows registry and manually remove all the entries. And the culprit was: Adblocker for Youtube Firefox should not be allowed to install add-ons or malware without your permission.
FredMcD
  • Top 10 Contributor
4305 solutions 60413 answers

That was very good work. Well done.

I once had the same problem with a different add-on.

Discovered Hidden Add-on On Firefox. How To Check Yours https://support.mozilla.org/en-US/forums/support-forum-contributors/711335

Type chrome://mozapps/content/extensions/extensions.xul?<enter> in the address bar.

That was very good work. Well done. I once had the same problem with a different add-on. Discovered Hidden Add-on On Firefox. How To Check Yours https://support.mozilla.org/en-US/forums/support-forum-contributors/711335 Type '''chrome://mozapps/content/extensions/extensions.xul?'''<enter> in the address bar.